Search found 245 matches

by petergebruers
29 Mar 2020 15:04
Forum: Z-Uno
Topic: Z-UNO compatibility issue on Mac OS, boot loader
Replies: 7
Views: 1546

Re: Z-UNO compatibility issue on Mac OS, boot loader

Thank you for reporting back! Glad you have found a workaround with "Smart Implant".
by petergebruers
27 Mar 2020 08:59
Forum: Z-Uno
Topic: Z-UNO compatibility issue on Mac OS, boot loader
Replies: 7
Views: 1546

Re: Z-UNO compatibility issue on Mac OS, boot loader

IIRC I've fixed it like this, but it was a long time ago... I downloaded sdcc 64bit for mac. Possibly I used "homebrew" to do that but I cannot remember. The I searched where Arduino puts the sdcc compiler in its tool chain, in my case the path is: /Users/peter/Library/Arduino15/packages/Z-Uno/tools...
by petergebruers
06 Mar 2020 14:19
Forum: Z-Uno
Topic: Problems with reports to HC2 in 2.1.5
Replies: 2
Views: 9705

Re: Problems with reports to HC2 in 2.1.5

Make sure to set up Multichannel Association to 1:0 and not just a simple Association to 1 Neither HC2 nor HCL or HC3 allow you to enter associations like that (using numbers), but HC2 and HCL have columns marked "S" for single and "M" for multi which is the equivalent. I've tested this after a use...
by petergebruers
28 Dec 2019 16:13
Forum: Z-Uno
Topic: Z-Uno Sensor Binary and Fibaro HC2 not working properly
Replies: 11
Views: 7476

Re: Z-Uno Sensor Binary and Fibaro HC2 not working properly

I don't define pins in this sketch, this is intentional. I only send "on" or "off" to 7 sensors at regular intervals... To prove that the HC2 and Z-Uno can "understand each other", but only if I remove both checkmarks in S and M column, save, and then add M checkmark! If you want an example of "read...
by petergebruers
27 Dec 2019 21:06
Forum: Z-Uno
Topic: Z-Uno Sensor Binary and Fibaro HC2 not working properly
Replies: 11
Views: 7476

Re: Z-Uno Sensor Binary and Fibaro HC2 not working properly

No issues with "Sensor Binary"... Works for me after I remove both checkmarks in S and M column, save, and then add M checkmark, save. Don't forget to exclude your Z-Uno, then flash sketch and re-include before trying my sample sketch... All seven (or eight if you count "root" sensor object) devices...
by petergebruers
27 Dec 2019 17:26
Forum: Z-Uno
Topic: Z-Uno Sensor Binary and Fibaro HC2 not working properly
Replies: 11
Views: 7476

Re: Z-Uno Sensor Binary and Fibaro HC2 not working properly

Thank you for reporting back. If I find the time, I'll test with ZUNO_SENSOR_BINARY_MOTION or something similar
by petergebruers
24 Dec 2019 15:02
Forum: Z-Uno
Topic: Z-Uno Sensor Binary and Fibaro HC2 not working properly
Replies: 11
Views: 7476

Re: Z-Uno Sensor Binary and Fibaro HC2 not working properly

I don't have a "Sensor Binary" test sketch, but I do have this "Switch Binary" test sketch, I've extended it to handle 7 switches... Works for me after I remove both checkmarks, save, and then add M checkmark, save. Don't forget to exclude your Z-Uno, then flash sketch and re-include... MultiChannel...
by petergebruers
20 Dec 2019 12:15
Forum: Z-Uno
Topic: Z-Uno Sensor Binary and Fibaro HC2 not working properly
Replies: 11
Views: 7476

Re: Z-Uno Sensor Binary and Fibaro HC2 not working properly

On your HC2 on the advanced page, navigate to the "associaton" button. Click that and you'll get a table view. See the S and M columns? S means single and M multi. Put a checkmark in the M column, it is as simple as that. If your Z-Uno is a sleeping node, wake it up to get the new setting. If that d...
by petergebruers
07 Dec 2019 20:37
Forum: Z-Uno
Topic: Battery Reports and Fibaro HC2
Replies: 12
Views: 5498

Re: Battery Reports and Fibaro HC2

Thanks! So 7.5 mA... Ah, that is due to power regulator + all the extra hardware you've added. It is still better than the expected +/- 40 mA of an "always on slave", but certainly not as low as the Z-Wave SoC can go in FLiRS mode... Interesting project!
by petergebruers
21 Nov 2019 00:27
Forum: Z-Uno
Topic: Battery Reports and Fibaro HC2
Replies: 12
Views: 5498

Re: Battery Reports and Fibaro HC2

I would add a 30 second delay. I don't think there is an easy way to monitor the progress (there is a log at the top in the status window, so technically speaking there is "something"). I know the guys from Z-Wave.me follow this forum, they will chime in if there is something interesting to be said....