Search found 11 matches

by g-knight
18 Oct 2016 21:00
Forum: Z-Uno
Topic: GPIO inputs without pullup (HiZ) problem
Replies: 12
Views: 3532

Re: GPIO inputs without pullup (HiZ) problem

Hi p0lyg0n1,

Thank you for this investigation and answer. That’s a good point to know it will work again in the future.
I’ll look on the new version release notes to check fixing.

Gerard
by g-knight
18 Oct 2016 16:00
Forum: Z-Uno
Topic: GPIO inputs without pullup (HiZ) problem
Replies: 12
Views: 3532

Re: GPIO inputs without pullup (HiZ) problem

Hi p0lyg0n1, Thanks, great if we have another measure. But be careful to not confuse on the goal: the initial request was more that I suspect that there is a bug that prevent to disable the pull-up, and I gave current measures that show that it seems that there is a pull-up there on input even if we...
by g-knight
16 Oct 2016 22:39
Forum: Z-Uno
Topic: GPIO inputs without pullup (HiZ) problem
Replies: 12
Views: 3532

Re: GPIO inputs without pullup (HiZ) problem

Hi PoltoS, Is there any chance that someone in the Z-Uno project team at Z-Wave.Me has a look into this topic? The value I measured shows an internal impedance of approximately 50 K Ohms, which is typical from microcontrollers' internal pull-up nowadays. To solve this problem, I changed my circuit a...
by g-knight
16 Oct 2016 21:44
Forum: Z-Uno
Topic: Configuration Parameter
Replies: 11
Views: 4312

Re: Configuration Parameter

+1 for sure! My understanding is that parameter names have to be static (in Domoticz for instance, it's hard coded into an XML file along with documentation of each parameter). If I'm right, I'm just posting this to say that I would be happy if we have USER_DEFINED_1..USER_DEFINED_n as names and the...
by g-knight
16 Oct 2016 21:40
Forum: Z-Uno
Topic: Struggling with Channels. Finally working, but questions
Replies: 4
Views: 2053

Re: Struggling with Channels. Finally working, but questions

Thank you for your answer.

I'm not sure it's not working, it was just I was astonished by this "1.1" I never saw before. I'm not so much skilled considering ZWave...
I'll have a look on this topic later on.
by g-knight
15 Oct 2016 17:25
Forum: Z-Uno
Topic: Struggling with Channels. Finally working, but questions
Replies: 4
Views: 2053

Re: Struggling with Channels. Finally working, but questions

Hi PoltoS Thank you for your answer. I red several times the page you mention for channel documentation, but unfortunately, it doesn't help me to understand the problems I noticed. However, even if I don't understand 100 % why there are two channels for the switch with the copy, as it works with the...
by g-knight
14 Oct 2016 22:38
Forum: Z-Uno
Topic: Struggling with Channels. Finally working, but questions
Replies: 4
Views: 2053

Struggling with Channels. Finally working, but questions

Hi readers I should say motivated readers, because this post is long. So thank you for reading! I reused a PIR flood projector electronic and attached Z-Uno on 3 internal points: PIR detection (before inhibit logic by day light), Lamp Relay command and Day Light detector. On a ZWave standpoint, my n...
by g-knight
10 Oct 2016 09:35
Forum: Z-Uno
Topic: GPIO inputs without pullup (HiZ) problem
Replies: 12
Views: 3532

Re: GPIO inputs without pullup (HiZ) problem

No I can't use lower resistances, I really need high impedance. For the PIR, I don't use something based on a microcontroller, it's a standard flood projector with discrete components, and I don't want to disturb its internal logic. I'm pretty sure that's the pull-up is still enabled in the chip whe...
by g-knight
09 Oct 2016 23:03
Forum: Z-Uno
Topic: GPIO inputs without pullup (HiZ) problem
Replies: 12
Views: 3532

Re: GPIO inputs without pullup (HiZ) problem

Hi, I tried with pin 22 and it doesn't work better. Looks the same... After having programmed #define PIR_PIN 22 pinMode(PIR_PIN, INPUT); I measured voltage with the pin left unconnected. I got about 3V (so, not floating), and if connect it to ground with ampere meter, it draws 64 µA. More than 6 ti...
by g-knight
09 Oct 2016 21:35
Forum: Z-Uno
Topic: GPIO inputs without pullup (HiZ) problem
Replies: 12
Views: 3532

Re: GPIO inputs without pullup (HiZ) problem

Hi, Yes, if I disconnect the divider, I have around 0 and 2.95V as expected. I don't think 100/150 K is so much, given the documentation: "Pins configured as INPUT make extremely small demands on the circuit that they are sampling, equivalent to a series resistor of 100 MΩ in front of the pin. This ...