Search found 11 matches

by budm
05 Nov 2018 14:47
Forum: Z-Uno
Topic: Firmware 0.0.0 error
Replies: 9
Views: 2046

Re: Firmware 0.0.0 error

Screenshot.
by budm
05 Nov 2018 14:45
Forum: Z-Uno
Topic: Firmware 0.0.0 error
Replies: 9
Views: 2046

Re: Firmware 0.0.0 error

Ok, naked Zuno, went into reset mode (+BTN, +RST, -RST, -BTN). Set Erase NVM=All, cleared the logs, uploaded an empty sketch. Result says invalid Firmware 0.0.0. Think it also said "Found corrupt S2 key", which was something I'd noticed before I hosed it. Set Erase NVM=Disabled, moved the log out of...
by budm
29 Oct 2018 12:21
Forum: Z-Uno
Topic: Firmware 0.0.0 error
Replies: 9
Views: 2046

Re: Firmware 0.0.0 error

Attached is the code I have been working with, verbatim. I cannot submit a stripped-down version because I wouldn't know if it caused the same problem (both Zunos are basically unusable now). Hardware: - A few buttons - LiquidCrystal, Hitachi hd44780 chip (https://www.arduino.cc/en/Reference/LiquidC...
by budm
23 Oct 2018 00:47
Forum: Z-Uno
Topic: Firmware 0.0.0 error
Replies: 9
Views: 2046

Re: Firmware 0.0.0 error

Below are the last few lines from my IDE output when I try to upload the sketch. I had real problems getting this Zuno to attach to the USB bus as well, had to go into rescue mode a few times and unplug/replug the device. ---------------- *** ZME Z-UNO Compiler. Platform:Linux Version:1.05b1 Text: *...
by budm
23 Oct 2018 00:29
Forum: Z-Uno
Topic: Firmware 0.0.0 error
Replies: 9
Views: 2046

Re: Firmware 0.0.0 error

I have two Zunos, A and B. I started on Zuno A. The stack was regularly being clobbered, so I would routinely enter rescue mode, upload an updated sketch, then continue debugging. Eventually this Zuno hit the error where it said it had Firmware 0.0.0 installed, and I tried a factory reset. After tha...
by budm
18 Oct 2018 13:13
Forum: Z-Uno
Topic: Firmware 0.0.0 error
Replies: 9
Views: 2046

Firmware 0.0.0 error

This makes the second Zuno I've received this error on after spending days trying to port the MFRC522 library to the Zuno. "Z-Uno core version and device version mismatch. You have 0.0.0 firmware version on the board. Core version is 2.1.4. Please upgrade the bootloader." "An error occurred while up...
by budm
10 Apr 2018 01:12
Forum: Z-Uno
Topic: z-uno with adafruit TFT Display - libraries won't compile
Replies: 2
Views: 1014

Re: z-uno with adafruit TFT Display - libraries won't compile

Out of curiosity, how is it that a library written in C/C++ cannot be compiled out of the box for either platform? (Arduino/Z-Uno) I am looking at the code for a very simple library (https://github.com/bhagman/MillisTimer) and I see nothing in there that's architecture-specific. /Bud
by budm
09 Apr 2018 13:01
Forum: Z-Uno
Topic: New 2.1.1 release!
Replies: 13
Views: 4945

Re: New 2.1.1 release!

It's been along process of trying to get anything to build on Linux, but I finally managed to get a basic app working because of a simple macro error in my code. But as I try compiling some of our various projects, I notice that they fail to include basic libraries such as "LiquidCrystal.h". I then ...
by budm
05 Apr 2018 11:45
Forum: Z-Uno
Topic: New 2.1.1 release!
Replies: 13
Views: 4945

Re: New 2.1.1 release!

It's not my code, it's a small library, but it's also not wrong: ---- #if defined (ARDUINO) && ARDUINO >= 100 #include <Arduino.h> #else #include <WProgram.h> #include <pins_arduino.h> #endif ---- So the code above is correct. I even tried setting #define ARDUINO 152 right before including the heade...
by budm
30 Mar 2018 13:08
Forum: Z-Uno
Topic: New 2.1.1 release!
Replies: 13
Views: 4945

Re: New 2.1.1 release!

Screenshots attached. First one is trying to compile a simple z-uno app, second one is trying to compile a ping app that requires no zuno-specific libraries.