Search found 7 matches

by froggy
01 May 2019 15:49
Forum: Recipes
Topic: [userModule] Condition Switch (Updated 2017/02/02)
Replies: 17
Views: 15538

Re: [userModule] Condition Switch (Updated 2017/02/02)

Hi, I have an issue using this module. I've set a rule for garden lights. I wanted to be able to switch them also manually so I created a virtual switch for them. The rule is: Virtual switch on OR ( solar attitude < 5 AND time between 12pm and 0:00). This works fine overall, but when the lights are ...
by froggy
09 Jan 2019 14:15
Forum: Z-Uno
Topic: Color Switch in Z-uno for RGB leds
Replies: 4
Views: 607

Re: Color Switch in Z-uno for RGB leds

I don't use PWM to control the LEDs. I have WS2811 Led strips. I use this code to get the RGB values from the controller: ZUNO_SETUP_CHANNELS(ZUNO_SWITCH_COLOR(SWITCH_COLOR_FLAGS_RED|SWITCH_COLOR_FLAGS_GREEN|SWITCH_COLOR_FLAGS_BLUE, getColor, setColor)); void setColor (byte color,byte value){ switch...
by froggy
08 Jan 2019 16:08
Forum: Z-Uno
Topic: Bootloader mismatch
Replies: 5
Views: 704

Re: Bootloader mismatch

Have you installed in the Arduino IDE the latest Z-Uno libraries? I think the the latest Z-uno Core is 2.1.3.
by froggy
07 Jan 2019 16:35
Forum: Z-Uno
Topic: Color Switch in Z-uno for RGB leds
Replies: 4
Views: 607

Color Switch in Z-uno for RGB leds

Hi, I'm trying to control some RBG leds with Z-uno. I used the ZUNO_SWITCH_COLOR() macro to set-up the channel as in the Reference page. In the controller (Razberry) the color switch is registered properly and I can select a color there. But when I change the RGB color, the Z-Uno setter function is ...
by froggy
06 Jan 2019 16:03
Forum: Z-Uno
Topic: No channels registered when selecting S2 security
Replies: 4
Views: 584

Re: No channels registered when selecting S2 security

So one more question - what is the best way to upgrade Z-way to the beta version?
by froggy
05 Jan 2019 13:04
Forum: Z-Uno
Topic: No channels registered when selecting S2 security
Replies: 4
Views: 584

Re: No channels registered when selecting S2 security

Thanks for the explanation. The Z-way webpage mentions that it suports S2 without mentioning that this is valid only for the beta version :)
by froggy
02 Jan 2019 22:54
Forum: Z-Uno
Topic: No channels registered when selecting S2 security
Replies: 4
Views: 584

No channels registered when selecting S2 security

I just bought a Razberry and Z-uno to automate my doorlock. I have an issue that when I set Z-uno in S2 security mode the controller (Razberry) registers the device but without any channels. I did the test with the SimpleBinarySensor exemple without anything connected to Z-uno: - in No Security mode...