Search found 178 matches

by seattleneil
11 Jun 2024 21:34
Forum: Official announcements
Topic: job queue runs full after upgrade to v4.1.0
Replies: 141
Views: 198040

Re: job queue runs full after upgrade to v4.1.0

A few things you may want to consider... 1. The queue problem you're experiencing is not experienced by most/all other Z-Way users. Presumably, there's something unique about your setup. As an experiment, I would remove power from node 2 since that node looks to be clogging up the queue. It could be...
by seattleneil
28 May 2024 20:03
Forum: Todo for the software
Topic: COMMAND_CLASS_SOUND_SWITCH support
Replies: 11
Views: 27896

Re: COMMAND_CLASS_SOUND_SWITCH support

Based on Z-Wave.me adding products with Zigbee and Matter support, it feels like the Z-Way developers are less focused on Z-Wave technology. I understand they have a business to run, but it makes me a little sad. If I wasn't so lazy, I would experiment with Z-Wave JS UI and Home Assistant.
by seattleneil
28 May 2024 19:55
Forum: Official announcements
Topic: job queue runs full after upgrade to v4.1.0
Replies: 141
Views: 198040

Re: job queue runs full after upgrade to v4.1.0

It looks like Silicon Labs (the company that produces the Z-Wave chip) has released updated versions of the SDK where Silicon Labs release notes describe reliability improvements. Ideally, @PoltoS can share plans for when Z-Way will release firmware that includes an updated SDK version. Here's a lin...
by seattleneil
23 May 2024 18:33
Forum: Todo for the software
Topic: COMMAND_CLASS_SOUND_SWITCH support
Replies: 11
Views: 27896

Re: COMMAND_CLASS_SOUND_SWITCH support

A potential work-around is to the "Virtual Device (JavaScript)" app (aka CodeDevice module) to create a multilevel switch, where the command is something like: zway.devices[ZWAVE_DEVICE_ID].instances[CHANNEL_ID].commandClasses[0x79].Set(8,%%). Please understand that you'll need to determin...
by seattleneil
13 May 2024 18:06
Forum: RaZberry
Topic: Raspberry Pi 4, Razberry 2 and Cannot start Z-Wave binding: Error: Invalid port
Replies: 2
Views: 912

Re: Raspberry Pi 4, Razberry 2 and Cannot start Z-Wave binding: Error: Invalid port

It looks like problems with serial port /dev/ttyAMA0 are being reported by multiple users. From my experience with bookworm OS, Z-Way's installation script (called RaspbianInstall) needs to be updated. Here are the issues I've encountered with the installation script for the 32-bit lite version of b...
by seattleneil
04 May 2024 23:15
Forum: RaZberry
Topic: Razberry7 on Pi 3B fails setup, no port?
Replies: 12
Views: 1840

Re: Razberry7 on Pi 3B fails setup, no port?

Have you considered downloading Z-Way's SD card image from here: https://z-wave.me/z-way/download-z-way/? If your Raspberry Pi using Z-Way's SD card image works correctly, then you've isolated the problem to not be a hardware issue. The approach you've taken of installing Raspberry Pi OS using rpi-i...
by seattleneil
17 Feb 2024 20:56
Forum: Discussions in English
Topic: Bindings fail after Pi general software upgrade
Replies: 1
Views: 1470

Re: Bindings fail after Pi general software upgrade

It sounds like you have a complicated configuration. You may want to use the Easy Scripting app instead of adding your own bindings. This is a very useful app for creating complicated rules in JavaScript. Assuming your heater is a virtual device within Z-Way, you could have Easy Scripting logic that...
by seattleneil
07 Feb 2024 19:41
Forum: RaZberry
Topic: Migrate from UZB -> RaZberry PRO 7
Replies: 10
Views: 2710

Re: Migrate from UZB -> RaZberry PRO 7

The logs you provided show 2 different issues. For the issue related to RaZberry PRO 7 reliability, follow the instructions in this post: https://forum.z-wave.me/viewtopic.php?p=98974#p98974 For the issue related to JavaScript errors ("at automation/ userModules /SwitchPollingSelect/index.js:60...
by seattleneil
08 Jan 2024 20:12
Forum: Discussions in English
Topic: Virtual switch doesn't create events
Replies: 1
Views: 1612

Re: Virtual switch doesn't create events

You are correct, a device created using the "Dummy Device" app has very limited functionality. It will not do what you want. A binary switch created using the “Virtual Device (JavaScript)” app will do what you want. Here's a screenshot that shows you how to create a binary switch using the...
by seattleneil
23 Dec 2023 06:30
Forum: Discussions in English
Topic: V4.1.2: steadily increasing cpu load
Replies: 30
Views: 30166

Re: V4.1.2: steadily increasing cpu load

PoltoS wrote: Thanks to @aLiEnHeAd, let's add a few more:
The HTTP Device app index.js sets async=true. This is not configurable from the app's web UI.

Parser for on/off status: JSON.stringify($$).split('"')[3] === 'ON' ? 'on' : 'off'