Search found 245 matches

by petergebruers
02 Oct 2017 10:01
Forum: Z-Uno
Topic: float conversion
Replies: 18
Views: 7252

Re: float conversion

PoltoS, your previous post suddenly made me realize that I am confused again! I installed coco82's sketch and I did not use any other library... It just works, including the OLED display! It has been running for 12h now and it is still display temperature and the green LED is still blinking. Let me ...
by petergebruers
01 Oct 2017 23:40
Forum: Z-Uno
Topic: float conversion
Replies: 18
Views: 7252

Re: float conversion

I have connected a DS18B20 and an OLED display, so now I can fully run and test your sketch. While doing so, I discovered that the DS18B20 example has the 4K7 pull-up and the VCC of the sensor connected to 5.0 V. This injects a small current into the Z-Wave SoC because it is a 3.3V chip (and due to ...
by petergebruers
01 Oct 2017 14:55
Forum: Z-Uno
Topic: I have made an attempt at improving the BH1750 demo sketch and it is available for comment
Replies: 7
Views: 3312

I have made an attempt at improving the BH1750 demo sketch and it is available for comment

Motivation After I've toyed with the Z-Uno demo sketches (see http://z-uno.z-wave.me) for some time, I thought I would show a little ambition and at the same time seek feedback from experienced users. I took the BH1750 sketch and improved the reporting range (from about 13000 to about 79000 Lux), ad...
by petergebruers
01 Oct 2017 10:55
Forum: RaZberry
Topic: Danfoss Thermostate Error
Replies: 6
Views: 3481

Re: Danfoss Thermostate Error

I have heard the rumour that this often happens if your LC-13 has firmware 1.0. Mine are 1.1 and I never have this problem. Exclusion and inclusion might help but I do not know if that is a permanent fix. Sorry I do not have more details...
by petergebruers
01 Oct 2017 00:25
Forum: Z-Uno
Topic: DS18B20 in argument
Replies: 1
Views: 1376

Re: DS18B20 in argument

All I can tell you is that the uCxx is a simplified version of C++ and it does not support everything standard C++ does. As you have found out, uCxx translates your code to plain C (that is translated to assembly language and in the end linked into binary code) so that is why you suddenly see a stru...
by petergebruers
30 Sep 2017 23:01
Forum: Device specific
Topic: Fibaro RGBW Controller 0-10V Input
Replies: 3
Views: 4538

Re: Fibaro RGBW Controller 0-10V Input

That is correct... The input is read through the dimmer. This unfortunately means it has only 100 steps, so 0.1 V resolution. It is a pity, because the internal ADC has better resolution, but there is no means to read it...
by petergebruers
30 Sep 2017 21:48
Forum: Z-Uno
Topic: float conversion
Replies: 18
Views: 7252

Re: float conversion

I see, I am sorry that I did not understand that right away, but when I reread this topic it is clear to me! If you get corruption, then I would guess something is writing to the wrong memory address. Maybe something to do with size of variables. I am sorry, I am talking out loud. Probably not very ...
by petergebruers
30 Sep 2017 18:28
Forum: Z-Uno
Topic: float conversion
Replies: 18
Views: 7252

Re: float conversion

Did you rule out a hardware issue? I do not want to underestimate you, because we do not know eachother (yet) I might be asking silly questions. I was thinking maybe you do not have sufficiently low pullup resistors. Or a 5 V - 3.3 V conversion issue. Does your library check the I2C ACK? If it does ...
by petergebruers
29 Sep 2017 19:31
Forum: Z-Uno
Topic: Sleeping Z-Uno - Power consumption
Replies: 17
Views: 9756

Re: Sleeping Z-Uno - Power consumption

Ah, the EEPROM, thanks for bringing that up. I see, so the usable range is 2.8 - 3.6 V. If someone wants to charge a cell in-circuit, you would have to do something to limit the upper voltage... Maybe use a low quiescent regulator, like XC6206 or equivalent.
by petergebruers
29 Sep 2017 18:49
Forum: Z-Uno
Topic: Z-UNO blocked after several hours of operation
Replies: 27
Views: 10118

Re: Z-UNO blocked after several hours of operation

I see. So you think the issue was introduced by upgrading the framework? I do not know how to test that hypothesis... In that case maybe other user have similar problems. Let us wait and see...