Search found 181 matches

by p0lyg0n1
18 Nov 2017 00:46
Forum: Z-Uno
Topic: Input current on A0 higher as soon as I read A1
Replies: 13
Views: 6542

Re: Input current on A0 higher as soon as I read A1

Sorry for the waiting. Finally I have a time for ADC. So, yes, there is a very strange behavior when I try to use multiple channels. I have to go deeper to hardware to say what is wrong. I confirm the behavior of ADC that Peter and knst08 has reported previously. I'll try to find the reason and fix ...
by p0lyg0n1
17 Nov 2017 13:44
Forum: Z-Uno
Topic: Strange ADC behaviour
Replies: 5
Views: 3546

Re: Strange ADC behaviour

Please have a look to different settings I listed in viewtopic.php?f=3427&t=25646. Try to apply this and check the behavior. Looks like it's a internal behavior of ADC. I'll try to get an ACS712 for tests.
by p0lyg0n1
08 Nov 2017 00:13
Forum: Z-Uno
Topic: Config Parameters are note set/received
Replies: 8
Views: 4438

Re: Config Parameters are note set/received

Post your sketch here, or you can send me it by means of PM. Don't worry, we will help you. :-)
by p0lyg0n1
08 Nov 2017 00:10
Forum: Z-Uno
Topic: Debugging USB
Replies: 3
Views: 2689

Re: Debugging USB

Hi, you can't see the output of the Serial in setup() because it's a native USB port and it goes to reboot with the Z-Uno, but Serial0/Serial1 + UART2USB have to work properly for debug. It's more comfortable way to use UART0 for debug purposes. Use external software to look for the output of Serial...
by p0lyg0n1
03 Nov 2017 00:02
Forum: Z-Uno
Topic: Pin 5 in INPUT_PULLUP mode isn't pulled HIGH
Replies: 5
Views: 2704

Re: Pin 5 in INPUT_PULLUP mode isn't pulled HIGH

The workaround is to initialize it after the first loop(in the second loop). For example try this: byte loop_cnt = 0; void loop() { if(loop_cnt < 2) { if(loop_cnt == 1) { // ... pinMode(5, INPUT_PULLUP); // ... } loop_cnt++; } }
by p0lyg0n1
02 Nov 2017 08:21
Forum: Z-Uno
Topic: ZUNO_SETUP_DEBUG_MODE() missing ?
Replies: 2
Views: 1612

Re: ZUNO_SETUP_DEBUG_MODE() missing ?

This have to work in the sketch file:

Code: Select all

// --- beginning of the file
ZUNO_SETUP_DEBUG_MODE(TRUE);
// ...
ZUNO_SETUP_CHANNELS(...);
by p0lyg0n1
02 Nov 2017 08:17
Forum: Z-Uno
Topic: CFGParam Usage
Replies: 2
Views: 1730

Re: CFGParam Usage

Hi, Yes, now it works only for globals. It's not a good idea to place this on the stack. Parameters use dword type, so it's 4 bytes of stack for one parameter. We try to make it clear for the next release. zunoSaveCFGParam() have to work. The main limitation that you can't do a filtering of values b...
by p0lyg0n1
31 Oct 2017 01:27
Forum: Z-Uno
Topic: Compiler Bug? local arrays not initialised correctly
Replies: 19
Views: 7420

Re: Compiler Bug? local arrays not initialised correctly

Don't do them private! When you add them to class you increase the parameter list. They have to work fine with multiple displays too, because the parameters will be buffered anyway. Please, modify the code carefully. The right way is to add additional global variable for current backlight, or add th...
by p0lyg0n1
28 Oct 2017 22:12
Forum: Z-Uno
Topic: Input current on A0 higher as soon as I read A1
Replies: 13
Views: 6542

Re: Input current on A0 higher as soon as I read A1

It sounds great. I don't have a time to check your example on the hardware myself, but I have a little time to refresh some info from datasheet and look into code. So, there are some new data: 1. ADC0(VRef+) & ADC1(VRef-) can be used as voltage references. May be it's a side affect of this. Code loo...
by p0lyg0n1
28 Oct 2017 21:29
Forum: Z-Uno
Topic: Compiler Bug? local arrays not initialised correctly
Replies: 19
Views: 7420

Re: Compiler Bug? local arrays not initialised correctly

Hi, I don't have any hardware to test it... I reworked the code to improve the stack usage. You can see the main ideas of auxilary methods, globals variables for parameter translation, decorating macroses instead of inlines etc. We use this approach in our libraries. Now your library compiles ok. Yo...