Z-Way v3.0.0 Release

Official announcements from Z-Wave.Me team. Check this forum to get information about new releases and bug fixes.
User avatar
PoltoS
Posts: 5002
Joined: 26 Jan 2011 19:36

Z-Way v3.0.0 Release

Post by PoltoS » 20 Jul 2019 16:07

Dear Z-Way/RaZberry users, we are proud to announce a new release: v3.0.0!

This is a major release that introduces full support of the new Z-Wave Security S2 and Z-Wave Smart Start. In addition to that we focused a lot on stability and improvements of the existing functionality, fixing many issues in Smart Home and Expert interfaces. We have also improved HomeKit support (via HomeKit Gate app), added full OAuth2 support and added Yandex Alice voice assistant (for Russian audience).

More info here: https://z-wave.me/z-way-v3-0-0/

What is next? Next week we will release Z-Way for Western Digital and Windows. Next month we will release new mobile apps for iOS and Android. In September will focus on approval of the new Google Home support.

Have fun with Z-Way!

MrRusch
Posts: 6
Joined: 23 Jul 2019 09:11

Re: Z-Way v3.0.0 Release

Post by MrRusch » 23 Jul 2019 09:17

With this release I notice some stricter security policies through session management.
There is still the option to allow public access to the Z-wave API, but automation modules utilizing the allowExternalAccess method seem to require authentication now.
Any way to get around this? For my use it doesn't really make sense to allow access to the entire data tree, but not through controlled requests in automation modules - without authentication.
Best regards,
/Fred

User avatar
PoltoS
Posts: 5002
Joined: 26 Jan 2011 19:36

Re: Z-Way v3.0.0 Release

Post by PoltoS » 23 Jul 2019 09:40

You can either make a permanent token for your requests or (like before) check Allow Public API access in the Z-Wave app.

MrRusch
Posts: 6
Joined: 23 Jul 2019 09:11

Re: Z-Way v3.0.0 Release

Post by MrRusch » 23 Jul 2019 09:53

PoltoS wrote:
23 Jul 2019 09:40
You can either make a permanent token for your requests or (like before) check Allow Public API access in the Z-Wave app.
Allowing public access to the API doesn't allow access to the user modules' allowExternalAccess methods - results in "Not logged in" response.
Is there a way to grant specific users access to specific user modules? When using Basic auth the user needs to be of Admin type to access allowExternalAccess method.

User avatar
PoltoS
Posts: 5002
Joined: 26 Jan 2011 19:36

Re: Z-Way v3.0.0 Release

Post by PoltoS » 23 Jul 2019 23:15

There was never full access to the API without admin credentials before. allowExternalAccess has a second argument that defines the permissions. For example:

Code: Select all

ws.allowExternalAccess("MyAPI", this.controller.auth.ROLE.ADMIN);
You can also use USER and ANONYMOUS instead of ADMIN.

Also note that there is a LOCAL role type that is ANONYMOUS but with restrictions to localhost.

MrRusch
Posts: 6
Joined: 23 Jul 2019 09:11

Re: Z-Way v3.0.0 Release

Post by MrRusch » 25 Jul 2019 00:30

Hmm odd.. Thanks for the pointer on that second argument! This allowed me to find a resolution to my issue.

rafale77
Posts: 31
Joined: 23 Jun 2018 19:26

Re: Z-Way v3.0.0 Release

Post by rafale77 » 25 Jul 2019 07:14

Can't figure out how to upgrade the ubuntu version. Downloaded it and ran decompressed the folder and wrote it over the old installation (2.3.8 with a backup) but the thing won't start properly. The server seems to be very slow to load and I keep get to a page asking for me to login but none of my user credential work.The page shows a big error loading data at the top.

User avatar
PoltoS
Posts: 5002
Joined: 26 Jan 2011 19:36

Re: Z-Way v3.0.0 Release

Post by PoltoS » 25 Jul 2019 20:46

Please stop the service, look for orphan z-way-server processes to stop them too, then start it again and CLEAR cookies and cache in your browser

rafale77
Posts: 31
Joined: 23 Jun 2018 19:26

Re: Z-Way v3.0.0 Release

Post by rafale77 » 26 Jul 2019 02:30

I did this and still same problem.I even changed client computer. I get to a login page with a big warning sign and no way to login because "user does not exist"
Edit: Finally got it to start properly but losing all of my user data including the S0 security key. I tried restoring from backup but it does not appear to work.

Edit2: At the 3rd restore attempt, it worked.

fez
Posts: 97
Joined: 20 Jul 2015 23:03

Re: Z-Way v3.0.0 Release

Post by fez » 27 Jul 2019 11:09

I have the same issue after the update:
"User not found. Please check your login or password"
None of the above measures worked.

Just for info, I am upgrading from Jessie 2.3.8:
- upgraded from Jessie to Stretch, worked fine
- upgrading to 3.0.0 as described in the other post
I also tried a fresh install, but after the restore I have the same issue.

Update:
I used Firefox for all my trials and (still) failed.
Finally I tried it in Edge and it worked fine, could log in.
... it might be browser related, so if you have the same issue, try another browser

Post Reply