Z-way-server occasionally goes down

Discussions about Z-Way software and Z-Wave technology in general
User avatar
PoltoS
Posts: 7248
Joined: 26 Jan 2011 19:36

Re: Z-way-server occasionally goes down

Post by PoltoS »

JohannesF wrote:
17 Jan 2023 22:06
In parallel I have deleted the current log file with the result that no new file has been created. No logging at all.
After a reboot the system started to build and fill the log file. Again, nothing related to the issue we've been discussing here.
This is how Unix works. When you delete a file opened by some program (Z-Way in your case), it is not deleted, but removed from the folder to become orphaned until all handles are closed. The Unix way to solve it is to send USR1 signal to the program. This will instruct the program to re-open log file. Good Unix programs follow this recommendations. Z-Way is doing it too. And logrotate is relying on this.

So, this is by design, but maybe a bit counterintuitive.
lanbrown
Posts: 213
Joined: 01 Jun 2021 08:06

Re: Z-way-server occasionally goes down

Post by lanbrown »

So far four days and the polling is at 1 second.

Code: Select all

● z-way-server.service - LSB: RaZberry Z-Wave service
     Loaded: loaded (/etc/init.d/z-way-server; generated)
    Drop-In: /etc/systemd/system/z-way-server.service.d
             └─override.conf
     Active: active (running) since Fri 2023-01-13 16:22:37 CST; 4 days ago
       Docs: man:systemd-sysv-generator(8)
    Process: 22668 ExecStart=/etc/init.d/z-way-server start (code=exited, status>
      Tasks: 14 (limit: 4915)
        CPU: 3d 13h 47min 4.136s
     CGroup: /system.slice/z-way-server.service
             └─22673 z-way-server
Unfortunately this weekend I'm going to have to stop it. It'll be moving to its new home.
JohannesF
Posts: 33
Joined: 04 Jan 2021 13:20

Re: Z-way-server occasionally goes down

Post by JohannesF »

Thanks, Poltos. Unix and I are not (yet) good friends. But I am learning from each and every mistake I make.
lanbrown
Posts: 213
Joined: 01 Jun 2021 08:06

Re: Z-way-server occasionally goes down

Post by lanbrown »

I had the first crash:

Code: Select all

z-way-server	OK	25m	2.4%	0.9% [74.9 MB]	334.4 B/s	403.7 B/s

Code: Select all

sudo service z-way-server status
● z-way-server.service - LSB: RaZberry Z-Wave service
     Loaded: loaded (/etc/init.d/z-way-server; generated)
    Drop-In: /etc/systemd/system/z-way-server.service.d
             └─override.conf
     Active: active (exited) since Fri 2023-01-13 16:22:37 CST; 1 weeks 2 days ago
       Docs: man:systemd-sysv-generator(8)
      Tasks: 0 (limit: 4915)
        CPU: 0
     CGroup: /system.slice/z-way-server.service
JohannesF
Posts: 33
Joined: 04 Jan 2021 13:20

Re: Z-way-server occasionally goes down

Post by JohannesF »

I am sad to hear that. My system is still running.
Have you been running Z-Way in debugging environment?
Fingers crossed that Poltos can find the root cause.
lanbrown
Posts: 213
Joined: 01 Jun 2021 08:06

Re: Z-way-server occasionally goes down

Post by lanbrown »

I did not have it under gdb. I think part of the issue is that it is too much for a Raspberry Pi 4B. Believe it or not, the system felt quicker with a five second polling than one second. I think I'm going to extend the time to say 2 seconds and see how it feels. Even just loading all of the rooms on the main node takes several seconds albeit the CPU usage doesn't show that.
teempade04
Posts: 1
Joined: 27 Jan 2023 16:56

Re: Z-way-server occasionally goes down

Post by teempade04 »

I use openHAB and have seen the Z-Way server (seemingly randomly) just exit. I see no errors in the logs and systemd says nothing is wrong,
User avatar
PoltoS
Posts: 7248
Joined: 26 Jan 2011 19:36

Re: Z-way-server occasionally goes down

Post by PoltoS »

As I remember (please correct me) OH is polling Z-Way and not vice versa. So this might be some other issue. Or Z-Way is configured to poll some HTTP devices. Please check your configuration.

The fix bug we discuss here is related to Z-Way doing HTTP request to other services.
Post Reply