Raspberry Pi / Aeon Labs Z-Stick Generation 5

Discussions about Z-Way software and Z-Wave technology in general
Post Reply
Max-1968
Posts: 2
Joined: 24 Nov 2015 18:40

Raspberry Pi / Aeon Labs Z-Stick Generation 5

Post by Max-1968 »

I'm trying to get the z-wave.me software working with a Raspberry Pi with the Aeon Labs Gen 5 USB Stick, but seem failing.

What i did so far is the following:

Plugged the USB STick into the Pi, this results in the following messages in kernel.log:

Code: Select all

root@EGDrivewayCamera:/var/log# tail kernel.log
[    2.205080] usb 1-1.3: new full-speed USB device number 5 using dwc_otg
[    2.309124] usb 1-1.3: New USB device found, idVendor=0658, idProduct=0200
[    2.311036] usb 1-1.3: New USB device strings: Mfr=0, Product=0, SerialNumber=0
[    4.300161] gpiomem-bcm2835 20200000.gpiomem: Initialised: Registers at 0x20200000
[    4.898427] cdc_acm 1-1.3:1.0: ttyACM0: USB ACM device
[    4.985776] usbcore: registered new interface driver cdc_acm
[    5.046813] cdc_acm: USB Abstract Control Model driver for USB modems and ISDN adapters

root@EGDrivewayCamera:/var/log# lsusb
Bus 001 Device 002: ID 0424:9512 Standard Microsystems Corp.
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 003: ID 0424:ec00 Standard Microsystems Corp.
Bus 001 Device 004: ID 7392:7822 Edimax Technology Co., Ltd
Bus 001 Device 005: ID 0658:0200 Sigma Designs, Inc.
Once this was done I installed the software:

Code: Select all

wget -q -O - razberry.z-wave.me/install | sudo bash
created a link for ttyAMA0 to ttyACM0:

Code: Select all

root@EGDrivewayCamera:/dev# ln -s /dev/ttyACM0 ttyAMA0
root@EGDrivewayCamera:/dev# ls -altr ttyA*
crw-rw---T 1 root dialout 166, 0 Jan  1  1970 ttyACM0
lrwxrwxrwx 1 root root        12 Nov 24 17:05 ttyAMA0 -> /dev/ttyACM0
and added root to the dialout group:

Code: Select all

root@EGDrivewayCamera:/dev# usermod -a -G dialout root
root@EGDrivewayCamera:/dev# id
uid=0(root) gid=0(root) groups=0(root),20(dialout),1001(indiecity)
between all these steps (plugging it, installing software, creating symlink) I rebooted the pi. Still it is not getting access to my controller as i understand the messages in z-way-server.log:

Code: Select all

[2015-11-24 17:02:13.068] [D] [zway] Opened device: /dev/ttyAMA0
[2015-11-24 17:02:13.069] [D] [zway] Worker thread successfully created
[2015-11-24 17:02:13.071] [D] [zway] Worker thread entry point
[2015-11-24 17:02:13.082] [I] [zway] Adding job: Get controller info and supported function classes
[2015-11-24 17:02:13.082] [D] [zway] SENDING: ( 01 03 00 07 FB )
[2015-11-24 17:02:13.288] [I] [zway] Job 0x07 (Get controller info and supported function classes): No ACK received before timeout
[2015-11-24 17:02:13.288] [D] [zway] SENDING: ( 01 03 00 07 FB )
[2015-11-24 17:02:13.494] [I] [zway] Job 0x07 (Get controller info and supported function classes): No ACK received before timeout
[2015-11-24 17:02:13.495] [D] [zway] SENDING: ( 01 03 00 07 FB )
[2015-11-24 17:02:13.701] [I] [zway] Job 0x07 (Get controller info and supported function classes): No ACK received before timeout
[2015-11-24 17:02:13.702] [W] [zway] Job 0x07 (Get controller info and supported function classes) dropped: too many resends
[2015-11-24 17:02:13.702] [D] [zway] Job 0x07 (Get controller info and supported function classes): fail
[2015-11-24 17:02:13.702] [C] [zway] Get Serial API Capabilities returned zero.
[2015-11-24 17:02:13.702] [I] [zway] Removing job: Get controller info and supported function classes
[2015-11-24 17:02:13.713] [D] [zway] Worker thread exit point
[2015-11-24 17:02:13.713] [D] [zway] Worker thread successfully finished
[2015-11-24 17:02:13.718] [E] [zway] SaveData will not save data since it wasn't loaded. This is to prevent data loss.
[2015-11-24 17:02:13.765] [I] [core] Notification: critical (z-wave): Cannot start Z-Wave binding: Error: Bad data - communication failed
What am I missing here ? Or isnt this supposed to work with other USB sticks at all ?

Thx,
Max

pofs
Posts: 688
Joined: 25 Mar 2011 19:03

Re: Raspberry Pi / Aeon Labs Z-Stick Generation 5

Post by pofs »

Probably unlinking system built-in serial port and redefining it is not very good idea, especially when system occupies it by default.

Anyway, Z-Way won't work with Aeon stick even if you manage to fix your port problem.

Max-1968
Posts: 2
Joined: 24 Nov 2015 18:40

Re: Raspberry Pi / Aeon Labs Z-Stick Generation 5

Post by Max-1968 »

Thx - Then this seems to be a general misunderstanding. Does it only work with the Razberry board/stick or does it work with any other sticks as well ? If yes which ?

I created the symbolic link as it didnt work with the original config, as to me it looked as if zway is "hardcoded" to ttyAMA0 while my stick seems to provide ttyACM0 instead - seems i was wrong with this.

remoticz
Posts: 45
Joined: 07 Oct 2015 20:35
Location: no

Re: Raspberry Pi / Aeon Labs Z-Stick Generation 5

Post by remoticz »

Only RaZberry and the Zwave.me UZB1 stick. Besides for that USB stick you must purchase a separate license to get ZWay running. That license afaik is not available for other Z-Wave controllers.
RaZberry is by far the cheapest solution of the two. UZB1 is more powerfull
v2.1.1 raspi2

Post Reply