razberry interface not working with Raspberry3

Discussions about Z-Way software and Z-Wave technology in general
Locked
jeey
Posts: 19
Joined: 06 Mar 2016 06:44

razberry interface not working with Raspberry3

Post by jeey »

Hi

Got a working setup on raspberry2, tried moving this into the new raspberry3 and it fails.
Also tested clean install, no difference (when putting the same sd card in raspberry2 box everything works).

Seems it can't talk to the interface on raspberry3.

See logs / output of installer script.

Code: Select all

[2016-03-05 02:16:42.281] [D] [zway] Opened device: /dev/ttyAMA0
[2016-03-05 02:16:42.281] [D] [zway] Worker thread successfully created
[2016-03-05 02:16:42.281] [D] [zway] Worker thread entry point
[2016-03-05 02:16:42.282] [I] [zway] Adding job: Get controller info and supported function classes
[2016-03-05 02:16:42.291] [D] [zway] SENDING: ( 01 03 00 07 FB )
[2016-03-05 02:16:42.493] [I] [zway] Job 0x07 (Get controller info and supported function classes): No ACK received before timeout
[2016-03-05 02:16:42.493] [D] [zway] SENDING: ( 01 03 00 07 FB )
[2016-03-05 02:16:42.694] [I] [zway] Job 0x07 (Get controller info and supported function classes): No ACK received before timeout
[2016-03-05 02:16:42.694] [D] [zway] SENDING: ( 01 03 00 07 FB )
[2016-03-05 02:16:42.896] [I] [zway] Job 0x07 (Get controller info and supported function classes): No ACK received before timeout
[2016-03-05 02:16:42.896] [W] [zway] Job 0x07 (Get controller info and supported function classes) dropped: too many resends
[2016-03-05 02:16:42.896] [D] [zway] Job 0x07 (Get controller info and supported function classes): fail
[2016-03-05 02:16:42.896] [C] [zway] Get Serial API Capabilities returned zero.
[2016-03-05 02:16:42.896] [I] [zway] Removing job: Get controller info and supported function classes
[2016-03-05 02:16:42.906] [D] [zway] Worker thread exit point
[2016-03-05 02:16:42.906] [D] [zway] Worker thread successfully finished
[2016-03-05 02:16:42.907] [E] [zway] SaveData will not save data since it wasn't loaded. This is to prevent data loss.
[2016-03-05 02:16:42.924] [I] [core] Notification: critical (z-wave): Cannot start Z-Wave binding: Error: Bad data - communication failed
Log above is from an image verified working before and after in RPI2

Code: Select all

[ ok ] Starting mongoose (via systemctl): mongoose.service.
sed: can't read /etc/inittab: No such file or directory
ls: cannot access config/zddx/*.xml: No such file or directory
Usage: ./z-cfg-update <filename>
diff: /etc/inittab: No such file or directory
Preparing AMA0 interface:
 removing 'console=ttyAMA0,115200' and 'kgdboc=ttyAMA0,115200' from kernel command line (/boot/cmdline.txt)
 removing '*:*:respawn:/sbin/getty ttyAMA0' from /etc/inittab
AMA0 interface reconfigured, please restart Raspberry
Do you want to receive emails with news about RaZberry project?
! Please subscribe again if you did it before 30.03.2013
yes/no: no
Thank you for using RaZberry!
root@raspberrypi:~#

pz1
Posts: 2053
Joined: 08 Apr 2012 13:44

Re: razberry interface not working with Raspberry3

Post by pz1 »

Continue discussions here viewtopic.php?f=3422&t=22957
topic locked

Locked