Upgraded from 2.0.1 to current, nothing works now.

Discussions about Z-Way software and Z-Wave technology in general
Mike Yeager
Posts: 160
Joined: 03 May 2014 07:02

Upgraded from 2.0.1 to current, nothing works now.

Post by Mike Yeager »

I upgraded last night to the current version and no nothing wants to work. Tried going back to previous version, same result. In the putty window where I issued the command to upgrade, it says (repeatedly) that it's stopping and starting the z-way server. There's an error there about no such file or directory. The one in question is '/opt/z-way-server/automation/defaultConfigs/config.json_ttyAMA0'. I can confirm there is no such directory or file and there doesn't appear to be in any of the previous versions still on the Pi. None of them seem to want to work anymore either....

Tried clean install, same result without the error. Just a stop / start loop. Any idea where I might find a log to tell me why?

jstaffon
Posts: 80
Joined: 29 May 2015 04:47

Re: Upgraded from 2.0.1 to current, nothing works now.

Post by jstaffon »

I'm having the same problem my friend. I'm not sure why no one has posted a sticky note or something. There seems to be a lot of talk but not many solutions...that I can follow at least. I saw something back in March where someone posted that there's some problem with an XML configuration and that they're working on a solution. I don't understand why downgrading to an earlier version doesn't fix the problem unless they accidentally tainted critical files for all the versions and releases. This seems serious and would have expected a formal explanation. There are a lot of people being impacted by this.

pz1
Posts: 2053
Joined: 08 Apr 2012 13:44

Re: Upgraded from 2.0.1 to current, nothing works now.

Post by pz1 »

Last week I have written directly to the developers that many users do have this problem. No response yet here or in my email
Since 29-12-2016 I am no longer a moderator for this forum

bogr
Posts: 179
Joined: 16 Nov 2015 22:46

Re: Upgraded from 2.0.1 to current, nothing works now.

Post by bogr »

I know it doesn't help you guys, but just a thought - for future cases. Before upgrading, shouldn't it be safe to just make a copy of the entire z-way-server lib and then if everything get messed up, a downgrade should just mean copying the backed up file system back to the original? I think you already get a backed up version of the z-way-server lib, with a timestamp in the name, when upgrading but just to be sure and not being tied to possible bugs in the built in upgrade/downgrade functionality? So, just a simple

Code: Select all

cp -r z-way-server z-way-server.YYYY-MM-DD
or is there more stuff happening somewhere else on the file system, that breakes this "idea"?

pz1
Posts: 2053
Joined: 08 Apr 2012 13:44

Re: Upgraded from 2.0.1 to current, nothing works now.

Post by pz1 »

I don't know if this still works, but in the past I just did the following with the command line interface:

At the installation of a new version, the existing directory /opt/z-way-server is renamed to /opt/z-way-server_PresentDate.
So if the update failed, I stopped ZWay and renamed the then active directory to something like /opt/z-way-server_broken followed by a rename of /opt/z-way-server_PresentDate to /opt/z-way-server

Next start Zway again.

jstaffon
Posts: 80
Joined: 29 May 2015 04:47

Re: Upgraded from 2.0.1 to current, nothing works now.

Post by jstaffon »

I had several backup folders from older releases. I tried to go back to an older release. I believe there were changes to areas outside the z-way-folder but I'm not sure. Something impacted the ability to start the server in /etc/init.d along with issues of the UIs both on ports 8083 and 8084. This is a very strange problem. Does anyone know if there are zip/tar/gz files of older releases available to download without using the "install" wget process? If I was running v2.1.1 before the upgrade, why doesn't a clean install of version v2.1.1 work?

Mike Yeager
Posts: 160
Joined: 03 May 2014 07:02

Re: Upgraded from 2.0.1 to current, nothing works now.

Post by Mike Yeager »

I wound up taking the opportunity to update my RPi to the current OS and a bunch of other things. I no longer have the problem but if my Z-Wave network had a hundred devices I'd be in a world of hurt. I did figure out that the problem is only intermittent on my end. I haven't figured out what causes it though...

jstaffon
Posts: 80
Joined: 29 May 2015 04:47

Re: Upgraded from 2.0.1 to current, nothing works now.

Post by jstaffon »

Mike,
What did you finally do to your OS or v2.2.2 to get it working. I'm stuck.... I've tried 1.7.1, 2.1.1 (version I had working) and 2.2.2. Everything keeps starting and stopping the server in an endless loop following a reboot. I've checked my hardware and that seems to be working ... according to the self-check light. When trying to start the server on a reboot, there is no /var/log/z-way-server.log file created. If I start the server manually, sometimes it creates the log file. It seems to be something related to the OS but I can't put my finger on it.

Mike Yeager
Posts: 160
Joined: 03 May 2014 07:02

Re: Upgraded from 2.0.1 to current, nothing works now.

Post by Mike Yeager »

Since I was still on Raspbian Wheezy and using Upstart, I took the opportunity to rebuild my system with the new Raspian Jesse OS. Since I reloaded the OS and did a fresh install, I haven't had a hiccup. Haven't taken the time to go back and look to see if I can figure out what happened before. Sorry I can't help much at the moment.

jstaffon
Posts: 80
Joined: 29 May 2015 04:47

Re: Upgraded from 2.0.1 to current, nothing works now.

Post by jstaffon »

No problem...thanks for the reply. I'm on Wheezy and use NOOBS on an SD card. How would you recommend I upgrade to Jesse?
Last edited by jstaffon on 16 May 2016 16:14, edited 2 times in total.

Post Reply