Offset Multisensor

Discussions about Z-Way software and Z-Wave technology in general
Osorkon
Posts: 42
Joined: 09 Sep 2015 12:05

Offset Multisensor

Post by Osorkon »

I already addressed my issue in the German forum, but not answer until yet.
I hope the English community is a little bit bigger than the German one.

I have two devices to measure the humidity and temperature.
- everspring st814
- aeon labs multisensor gen 5
The measured values for the humidity are inaccurate also the temperature values.
The deviation for the humidity is +10% (aeon labs) and -8% (everspring) :evil:
As I know there is no offset parameter in the configuration of the devices.
Is there another way to make an offset of the measured values? :idea:
Maybe in combination with a dummy device?
The app “Arithmetic" doesn’t work for me.

Thanks a lot in advance.

Best regards
Osorkon

pz1
Posts: 2053
Joined: 08 Apr 2012 13:44

Re: Offset Multisensor

Post by pz1 »

Osorkon wrote:The app “Arithmetic" doesn’t work for me.
This app was initially made as a teaser for others to make a more generic module. Your use case of multiplying and off-setting one sensor value seems a sensible extension of the module. I'll have a look into that over the weekend
Pieter

Mike Yeager
Posts: 160
Joined: 03 May 2014 07:02

Re: Offset Multisensor

Post by Mike Yeager »

It would be very easy to adapt the Dummy Sensor app I've written to read your sensor, add the offset you're looking for and display it on the Dummy Sensor instead. I've put a few of these up on the App store but I don't think they've made the cut to actually be in the app store. Are you sure that the variance is stable all the way across the range of the sensor or does it change? I've seen a few that are pretty much dead on at the bottom of the range and get further and further off as the top of the range is reached... If you'd like, I'll modify one and figure out how to get it to you.

pz1
Posts: 2053
Joined: 08 Apr 2012 13:44

Re: Offset Multisensor

Post by pz1 »

Mike Yeager wrote:I've put a few of these up on the App store but I don't think they've made the cut to actually be in the app store.
Mike,
As an author you can define a personal token in the apps manager. Give the token to this user, and he should be able to download. It has the advantage that others can test it in their environment before you submit it for evaluation

Edit: You could consider to rename one of your Dummy variants to Calibrate or something like that. In thinking about the function last night, I also stumbled on non-linear deviations 1.

Mike Yeager
Posts: 160
Joined: 03 May 2014 07:02

Re: Offset Multisensor

Post by Mike Yeager »

pz1,

I'll look into that if the other user replies and is interested in giving it a go. The offset is easy as long as it's a steady offset. If not, then the user will need to determine the curve as I would have no way of doing so. Once the curve was realized, it wouldn't be that hard to code. Good find on the calibration link you posted...

Mike

Osorkon
Posts: 42
Joined: 09 Sep 2015 12:05

Re: Offset Multisensor

Post by Osorkon »

I'am very interested, if somebody can provide an app. :D
I did some measurements. I find out the characteristic of the variance.
Temperature offset: new value = measure value + x (in my case, x= 0,4)
Humidity offset: new value = measure value * x (in my case, x = 0,8)
At least in a range between 55-65% Humidity.

Thanks a lot.

bogr
Posts: 179
Joined: 16 Nov 2015 22:46

Re: Offset Multisensor

Post by bogr »

Mike Yeager wrote:It would be very easy to adapt the Dummy Sensor app I've written to read your sensor
Do you have an example of reading the value from your Dummy Sensor that you're willing to share ;)?

Mike Yeager
Posts: 160
Joined: 03 May 2014 07:02

Re: Offset Multisensor

Post by Mike Yeager »

Here's an example of the first DummySensor module I wrote. It takes the temperature (in celsius) from whatever sensor you point it at and converts it to Fahrenheit before displaying it in a vDev element. If I did it correctly, you should be able to access it by adding the token MYeager01 to your app store. I'm sure pz1 will help correct me if I screwed it up. In the case above, it appears that Osorkon needs to add 0.4 degrees to his reading. Not sure if I'd worry about .4 degrees but if he's dealing in Celsius, I might understand. Check out what I've already done and if you're willing to work with me and show a little patience, I'd be happy to put something together for you to tweak the sensor reading...

bogr
Posts: 179
Joined: 16 Nov 2015 22:46

Re: Offset Multisensor

Post by bogr »

Mike Yeager wrote:If I did it correctly, you should be able to access it by adding the token MYeager01 to your app store.
Yepp, it worked great. Thanx a lot!

pz1
Posts: 2053
Joined: 08 Apr 2012 13:44

Re: Offset Multisensor

Post by pz1 »

Mike Yeager wrote:I'm sure pz1 will help correct me if I screwed it up.
Maybe I did screw it up ;) Unfortunately whatever sensor I pick it still shows 78.8F as a result. (I did use the outcome of a Fibaro Universal Sensor (22.2C ) , and the local temperature from my weathermodule "Wunderground"(19C). The 22.2C should convert to 71.96F.

The install of the module on my test rig v2.2.2 gave some errors in the log. This error did not show up at the next readings of the sensor. After a while I did remove the App and reinstalled. Same observation.

Code: Select all

[2016-06-12 12:40:32.012] [I] [core] Installing app TempF ...
[2016-06-12 12:40:32.424] [I] [core] Downloaded contents for 'TempF'
[2016-06-12 12:40:32.435] [I] [core] Extracting automation/userModules/TempF/index.js
[2016-06-12 12:40:32.436] [I] [core] Extracting automation/userModules/TempF/htdocs/icon.png
[2016-06-12 12:40:32.444] [I] [core] Extracting automation/userModules/TempF/module.json
[2016-06-12 12:40:32.445] [I] [core] Extracting automation/userModules/TempF/lang/en.json
[2016-06-12 12:40:32.447] [I] [core] Module successfully unpacked
[2016-06-12 12:40:32.455] [I] [core] Load app "TempF" from folder ...
[2016-06-12 12:40:32.479] [I] [core] Loading module TempF from userModules/TempF
[2016-06-12 12:40:32.483] [I] [core] Executing script: /*** TempF Z-Way Home Automation module ***********************************
 ...
[2016-06-12 12:41:11.682] [I] [core] Instantiating module 14 from class TempF
[2016-06-12 12:41:11.688] [I] [core] --- Starting module TempF
[2016-06-12 12:41:11.996] [I] [core] Creating device sensorMultilevel DummyTempSensor_14
[2016-06-12 12:42:09.408] [I] [core] TempF: Temperature C -> 22.2
[2016-06-12 12:42:09.455] [E] [8083] Callback execution error: ReferenceError: temp is not defined
    at TempF.OnChange (automation/userModules/TempF/index.js:96:43)
    at null.<anonymous> (automation/userModules/TempF/index.js:64:14)
    at EventEmitter.emit (automation/lib/eventemitter2.js:317:33)
    at _.extend.emit (automation/classes/VirtualDevice.js:315:32)
    at automation/classes/VirtualDevice.js:241:22
    at Array.forEach (native)
    at _.extend.set (automation/classes/VirtualDevice.js:237:21)
    at ZAutomationAPIWebRequest._.extend.setVDevFunc (automation/ZAutomationAPIProvider.js:311:33)
    at ZAutomationAPIWebRequest.handlerFunc (automation/ZAutomationAPIProvider.js:2387:52)
    at ZAutomationAPIWebRequest.ZAutomationWebRequest.handleRequest (automation/WebserverRequestRouter.js:258:41)
[2016-06-12 12:42:42.154] [D] [zway] RECEIVED: ( 01 12 00 04 00 0D 0C 60 0D 03 03 31 05 01 44 00 00 07 AA 59 )
Since 29-12-2016 I am no longer a moderator for this forum

Post Reply