Periodic reporting

Discussions about Z-Way software and Z-Wave technology in general
Post Reply
jstaffon
Posts: 80
Joined: 29 May 2015 04:47

Periodic reporting

Post by jstaffon »

I've been trying to find the setting to change the reporting interval. I thought I had it when I changed the "Polling" app but that doesn't do the trick. Does anyone know how to accomplish this? When I look at the log file, it seems like there's an entry about every 15 minutes. I'm trying to disable some of them...and increase the interval on some of them in order to increase the battery life of my devices. In some cases the reporting in the log file seems to be associated with changes to the state of the device. Thanks in advance!

Duvel
Posts: 4
Joined: 22 Sep 2015 17:53

Re: Periodic reporting

Post by Duvel »

Hi,

I think there is something wrong with the app in version 2.2.3. It seems that changing the period doesn't have any effect. I removed and recreated it and I think it is now stuck on the default of every 60 minutes.

Duvel
Posts: 4
Joined: 22 Sep 2015 17:53

Re: Periodic reporting

Post by Duvel »

Okay, I found out my problem with the SensorsPolling app. It does listen to the period set in in the settings, but in the logic to determine if a device needs to be polled, it also checks if it hasn't been polled in the last period and only then adds a poll request.

I want to poll my battery operated devices every 5 minutes, but due to this condition I get a result about every 10 minutes as my devices wake very 5 minutes. So I'm now going to change the period to 2 minutes.

Looking in the code I don't see a way so set different periods for seperate sensors. Maybe you can try to create your own automation module for that. I did something simular to read thermostat setpoints.

jstaffon
Posts: 80
Joined: 29 May 2015 04:47

Re: Periodic reporting

Post by jstaffon »

Interesting. Thanks for the reply!

Post Reply