"License key not found" error

Discussions about Z-Way software and Z-Wave technology in general
Post Reply
ligerzero459
Posts: 2
Joined: 22 Nov 2016 11:24

"License key not found" error

Post by ligerzero459 »

I recently purchased a UZB stick and a license key to go with it. I've attempted to put the key in on the ExpertUI, but every time I do I get a "License key not found" error. This is actually the second code I've received because I had the issue with the other code as well.

I've run the Z-Way software on both Windows and Debian with the same results. Anyone encountered this before?
Attachments
4sMvT5Y.png
4sMvT5Y.png (29.31 KiB) Viewed 3966 times

phzi
Posts: 13
Joined: 08 Nov 2016 04:24

Re: "License key not found" error

Post by phzi »

Had a similar problem. Ended up being an SSL issue with the remote server. I opened up firebug and watched the network activity when it was trying to validate the licence key. Connection was being blocked because of security issues. Added an exception for that site, and then it worked fine.

ligerzero459
Posts: 2
Joined: 22 Nov 2016 11:24

Re: "License key not found" error

Post by ligerzero459 »

Thanks, that ended up being the solution! Looks like they need to fix their SSL cert

richos
Posts: 1
Joined: 13 Dec 2016 00:35

Re: "License key not found" error

Post by richos »

phzi wrote:Had a similar problem. Ended up being an SSL issue with the remote server. I opened up firebug and watched the network activity when it was trying to validate the licence key. Connection was being blocked because of security issues. Added an exception for that site, and then it worked fine.
Hi, have the same problem but don't know how to set the exeption in Raspberry or Windows. Can you help me?


EDIT
Hmm, interesting. After downgrading the Z-way firmware to v2.2.1 and restarting it started to work :D
Looks like there is something messed up in 2.2.5.

kWave
Posts: 22
Joined: 11 Dec 2016 00:02

Re: "License key not found" error

Post by kWave »

There's no need to downgrade. Just open up your Browsers Web Development tool, open up the Network Connection Tab, and watch for the zwave.me address when you click on the Licence button.
Open up the url which is shown and add an exception in your browser.

Post Reply