Problem with Raspberry Pi 3 / Z-Wave board

Discussions about Z-Way software and Z-Wave technology in general
Jeff66
Posts: 7
Joined: 23 Nov 2016 20:54

Re: Problem with Raspberry Pi 3 / Z-Wave board

Post by Jeff66 »

Powered OFF then back ON. Same problem.

I went under MyIp:8083/expert but did not find the boot loader.
Where is it ? Could you tell me a bit more ?

PS : I'm also logged in as pi in ssh. I can take a look at the logs if needed.
Anyway, your help is warmly welcome !

User avatar
Z-Wave Support
Posts: 353
Joined: 21 Oct 2016 15:49

Re: Problem with Raspberry Pi 3 / Z-Wave board

Post by Z-Wave Support »

Hello,

Please view ip:8083/expert/#/network/controller
If you not see, have your controller the current Version.

We think your Razberry is defect.

regards
Z-Wave Support

brianaker
Posts: 32
Joined: 11 Nov 2016 16:57

Re: Problem with Raspberry Pi 3 / Z-Wave board

Post by brianaker »

I've seen this happen multiple times now, with both the PI 3 and Pi2 models.

To fix this you need to pull the plug on Pi and then power it back up. The reset button on the Pi3 will also work, but just rebooting the Pi does nothing at all.

tontze
Posts: 13
Joined: 12 Dec 2016 17:48

Re: Problem with Raspberry Pi 3 / Z-Wave board

Post by tontze »

Did brianaker´s solution work ?

kWave
Posts: 22
Joined: 11 Dec 2016 00:02

Re: Problem with Raspberry Pi 3 / Z-Wave board

Post by kWave »

I had similar Problems.
You have to enter your licence key in the expert ui at first. Then do a reboot.

JimC
Posts: 4
Joined: 30 Dec 2016 20:06

Re: Problem with Raspberry Pi 3 / Z-Wave board

Post by JimC »

I'm having a very similar issue with a RPI3 and a Z-Wave. At this point I am trying to determine if I have a bad ZWave board or misconfigured software. Please let me know if you need additional information

I did the following:
- Installed 2016-11-25-raspbian-jessie.img on a SD card
- Installed Z-wave board on RPI3
- booted RPI3
- Configured Wifi connection on RPI3
- ran sudo apt-get update and sudo apt-get upgrade and then
- sudo reboot
- sudo apt-get install rpi-update
- sudo rpi-update
- sudo reboot
- wget -q -O - razberry.z-wave.me/install | sudo bash
- sudo shutdown
- remove power
-reapply power

The install process has a few errors amongst the console output including:
- ".. cannot access config/zddx/*.xml: No such file or directory"
- "diff: /etc/inittab: No such file or directory"
- "diff /tmp/zway_install_inittab: No such file or directory"

The last lines of z-way-server.log include:
[2016-12-30 12:48:03.541] [D] [zway] Opened device: /dev/ttyAMA0
[2016-12-30 12:48:03.541] [D] [zway] Worker thread successfully created
[2016-12-30 12:48:03.541] [D] [zway] Worker thread entry point
[2016-12-30 12:48:03.542] [zway] Adding job: Get controller info and support
ed function classes
[2016-12-30 12:48:03.552] [D] [zway] SENDING: ( 01 03 00 07 FB )
[2016-12-30 12:48:03.754] [zway] Job 0x07 (Get controller info and supported function classes): No ACK received before timeout
[2016-12-30 12:48:03.754] [D] [zway] SENDING: ( 01 03 00 07 FB )
[2016-12-30 12:48:03.956] [zway] Job 0x07 (Get controller info and supported function classes): No ACK received before timeout
[2016-12-30 12:48:03.956] [D] [zway] SENDING: ( 01 03 00 07 FB )
[2016-12-30 12:48:04.158] [zway] Job 0x07 (Get controller info and supported function classes): No ACK received before timeout
[2016-12-30 12:48:05.246] [W] [zway] Job 0x07 (Get controller info and supported function classes) dropped: too many resends
[2016-12-30 12:48:05.246] [C] [zway] Get Serial API Capabilities returned zero.
[2016-12-30 12:48:05.246] [zway] Removing job: Get controller info and supported function classes
[2016-12-30 12:48:05.256] [D] [zway] Worker thread exit point
[2016-12-30 12:48:05.257] [D] [zway] Worker thread successfully finished
[2016-12-30 12:48:05.257] [E] [zway] SaveData will not save data since it wasn't loaded. This is to prevent data loss.
[2016-12-30 12:48:05.278] [core] Notification: critical (z-wave): Cannot start Z-Wave binding: Error: Bad data - communication failed

Thanks

Post Reply