Correct way to update firmware on a z-wave node

Discussions about Z-Way software and Z-Wave technology in general
Post Reply
jeey
Posts: 19
Joined: 06 Mar 2016 06:44

Correct way to update firmware on a z-wave node

Post by jeey »

Hi

Recieved an firmware update for Popp 10Y firealarm, and can't get it flash the update trough the webui.
Webui says says firmware update successfull, but nothing indicates that the firmware was actually updated (v should change from 1.01 to 1.014).

Tailing the z-way-server logfile during the command but nothing is added to log, no error no success.
I suspect that it doesn't actually do anything.

Is it supposed to work?

User avatar
PoltoS
Posts: 5507
Joined: 26 Jan 2011 19:36

Re: Correct way to update firmware on a z-wave node

Post by PoltoS »

If the f/w is correct, should work. There should be a firmware upgrade status in the log

jeey
Posts: 19
Joined: 06 Mar 2016 06:44

Re: Correct way to update firmware on a z-wave node

Post by jeey »

Added a video, just to verify im doing it correctly

https://youtu.be/6pAftT6zYtw

User avatar
PoltoS
Posts: 5507
Joined: 26 Jan 2011 19:36

Re: Correct way to update firmware on a z-wave node

Post by PoltoS »

You should use targetId = 0 and wake up the device and confirm upgrade (the log should show commans back and forward with the 10Y device)

jeey
Posts: 19
Joined: 06 Mar 2016 06:44

Re: Correct way to update firmware on a z-wave node

Post by jeey »

So tried again

https://youtu.be/asRJc5WWhrk

Timeframe:
3s: i press button 1 time to wake device
22s: i dobbel tap the button to "accept" firmware according to manual

Still no difference

User avatar
PoltoS
Posts: 5507
Joined: 26 Jan 2011 19:36

Re: Correct way to update firmware on a z-wave node

Post by PoltoS »

I see no action on button press. Can you show browser console? May be there is an error?

Once you press the button a request should be sent and log should show some activity (even if device is sleeping)

jeey
Posts: 19
Joined: 06 Mar 2016 06:44

Re: Correct way to update firmware on a z-wave node

Post by jeey »

Hi

Updated the video with a new one where console is open.

https://youtu.be/ngIAN9krNVo

I dont see any errors during the update from the webui


There is only a generic error
angular-cookies.js:6 GET http://10.x.x.160:8083/config/Configuration.xml 404 (Not Found)

--------- ERROR: ---------- Object {data: "", status: 404, config: Object}


Tested some other teories
Uploaded the file to an local webserver
and tried to get it to pull it from there

If i enter a wrong server name it says
[2017-01-31 17:13:49.946] [core] Failed to download firmware: Couldn't connect to server
But if i enter the correct url
it gives me an error
[2017-01-31 17:15:25.725] [E] [core] Callback execution error: TypeError: undefined is not a function
at Function.http.request.success (automation/modules/ZWave/index.js:1133:20)

jeey
Posts: 19
Joined: 06 Mar 2016 06:44

Re: Correct way to update firmware on a z-wave node

Post by jeey »

For other users getting this problem.
Firmware update seems to broken in 2.3.0, works in 2.2.5
Last edited by jeey on 02 Feb 2017 01:30, edited 1 time in total.

User avatar
PoltoS
Posts: 5507
Joined: 26 Jan 2011 19:36

Re: Correct way to update firmware on a z-wave node

Post by PoltoS »

Video is not available

jeey
Posts: 19
Joined: 06 Mar 2016 06:44

Re: Correct way to update firmware on a z-wave node

Post by jeey »

PoltoS wrote:Video is not available
sent you an link in PM.

Post Reply