Upgrade to R3.0.0 and S2

Discussions about Z-Way software and Z-Wave technology in general
nemo
Posts: 3
Joined: 12 Sep 2019 18:53

Re: Upgrade to R3.0.0 and S2

Post by nemo » 12 Sep 2019 19:54

@ibjr: you seem to have included in S2 mode some Danalocks V3 to the z-way-server 3.0.0 via the expert mode:
ExpertUI -> network -> control etc
When I do the inclusion via ExpertUI, the PIN code seems to be wrong and the authorisation fails (see attachment).
Could you please explain, where you get the PIN code for your lock from?
Attachments
z-way-danalock-inclusion-fails-on-pin.png.zip
(49.32 KiB) Downloaded 21 times

brun368
Posts: 12
Joined: 12 Sep 2015 01:49

Re: Upgrade to R3.0.0 and S2

Post by brun368 » 13 Sep 2019 09:30

Hi,
the S2 pin is on the inside of the battery cover.

Please give me some feedback if the Inclusion works and the if the interview will be completed because my Interview with the Danalock stops at 38% even if the authentication is successful.

Which Danalock firmware are you using? (mine is 0.11.0)

ibjr
Posts: 20
Joined: 05 May 2016 21:52

Re: Upgrade to R3.0.0 and S2

Post by ibjr » 13 Sep 2019 17:28

@nemo, @brun368:
indeed the pincode is on the inside of the battery cover.
I included two Danalock V3's successfully; I do not remember the lock's firmware version at that time; I always update new firmware immediately when it becomes available. (Currently they are on 0.11.0).
If I remember it correctly (but it's a long time ago), there were two different modes for S2 inclusion: Access and Authentication. The locks are included in S2 Access mode. You have to enter the pincode rather quickly and hit Confirm, because else the inclusion seems to continue, but with a invalid pin(?), (although the PIN window suggest that you have 3 minutes, in my recollection I had to be very fast)

The interview was 100%.

nemo
Posts: 3
Joined: 12 Sep 2019 18:53

Re: Upgrade to R3.0.0 and S2

Post by nemo » 29 Sep 2019 18:44

@ibjr, @brun368:
Thanks for the information regarding the PIN code.
However, the inclusion using the expert mode does not work in my home. I tried several times, always first excluding and including again and the interview progress stops at 33%, but only after forcing each interview command class one by one. The lock does not show up in the device overview.
The firmware installed is v0.11.0.

I will get in contact with Danalock to ask if they are working on a solution for it.

Post Reply