Z-Way + UZB beginner trouble - help please

Discussions about Z-Way software and Z-Wave technology in general
Leif
Posts: 17
Joined: 19 Jan 2019 17:28

Z-Way + UZB beginner trouble - help please

Post by Leif » 19 Jan 2019 17:45

Hello,

I'm brand new to Z-Way but I've used a Fibaro Home Center 2 for a while.

I purchased a ZMEEUZBB stick, and a license to run Z-Way (8 hexadecimal digit license code).

I've plugged the stick into a dedicated Windows 10 PC, and it immediately showed up as UZB (COM3).

Z-Way starts and runs, but I can't seem to add the license key.

If I go to Expert Mode, Network, Controller, License Upgrade, and enter the key:

License key successfully verified
Unable to upgrade capabilities


If I try to Start Inclusion in export mode (Network / Control / Start Inclusion) I immediately get this error: Unable to update data. controller.AddNodeToNetwork(1)


I have no idea where to look next.


Here's the controller info in case it provides a clue to anyone:

Role in Network
Node Id: 1
Home Id: 0xf7a4a8de
Primary Role: Yes
Primary Capability: Yes
SUC/SIS in network: 1 (SIS)
Hardware
Vendor: Z-Wave.Me
Vendors Product ID: 1024 / 1
Z-Wave Chip: ZW0500
Firmware
Library Type: Static Controller
SDK Version:
Serial API Version: 05.25
Capabillities:
UUID: 3273f4a9597a21d0bd41c74679be9779
Subvendor: 0x0000
Nodes limit: Unlimited
Capabillities: SlM
Software Information
Version number: v2.3.3
Compile-ID: 25bdd65bc580b075ba69b766a4113866403c0036
Compile-Date: 2017-04-13 21:53:20 +0300
UI
UI version 1.3.0-RC-47
Built date 31-03-2017 13:04:26


Controller data:

/: None (09:18 PM)
nodeId: 1 (09:18 PM)
homeId: -140203810 (09:18 PM)
SUCNodeId: 1 (09:18 PM)
isPrimary: true (09:18 PM)
isInOthersNetwork: false (09:18 PM)
isRealPrimary: true (09:18 PM)
isSUC: true (09:18 PM)
SISPresent: true (09:18 PM)
libType: Static Controller (09:18 PM)
SDK: (09:18 PM)
ZWlibMajor: 4 (09:18 PM)
ZWlibMinor: 61 (09:18 PM)
ZWLib: 1 (09:18 PM)
ZWVersion: 6 (09:18 PM)
ZWaveChip: ZW0500 (09:18 PM)
APIVersion: 05.25 (09:18 PM)
manufacturerId: 277 (09:18 PM)
vendor: Z-Wave.Me (09:18 PM)
manufacturerProductType: 1024 (09:18 PM)
manufacturerProductId: 1 (09:18 PM)
bootloaderCRC: 48059 (09:18 PM)
firmwareCRC: 17009 (09:18 PM)
capabilities: 2,3,4,5,6,7,8,9,11,16,17,18,19,20,21,22,23,28,32,33,34,35,36,39,40,41,42,43,44,45,46,55,56,57,58,59,63,65,66,68,69,70,71,72,73,74,75,76,77,79,80,81,83,84,85,86,87,88,94,95,96,97,98,99,102,103,120,128,144,146,147,152,180,182,183,184,185,186,189,190,191,208,209,210,211,212,238,239,242,244,245,247 (09:18 PM)
controllerState: 0 (09:18 PM)
nonManagmentJobs: 0 (09:18 PM)
lastIncludedDevice: 0 (09:18 PM)
lastExcludedDevice: 0 (09:18 PM)
secureInclusion: true (09:18 PM)
oldSerialAPIAckTimeout10ms: 10 (09:18 PM)
oldSerialAPIByteTimeout10ms: 10 (09:18 PM)
curSerialAPIAckTimeout10ms: 10 (09:18 PM)
curSerialAPIByteTimeout10ms: 10 (09:18 PM)
countJobs: false (09:18 PM)
memoryGetAddress: 25856 (09:18 PM)
memoryGetData: 187,187,66,113 (09:18 PM)
memoryManufacturerId: None (09:18 PM)
memoryType: None (09:18 PM)
memoryCapacity: None (09:18 PM)
functionClasses: 2,3,4,5,6,7,8,11,18,19,21,22,23,32,33,34,35,36,39,41,42,43,44,45,57,58,59,63,65,66,68,70,71,72,73,74,75,76,77,80,81,82,83,84,85,86,87,94,96,97,98,99,128,146,147,186,190,208,209,210,211,242,243,244,245 (09:18 PM)
functionClassesNames: SerialAPIGetInitData,SerialAPIApplicationNodeInformation,ApplicationCommandHandler,GetControllerCapabilities,SerialAPISetTimeouts,GetSerialAPICapabilities,SerialAPISoftReset,SerialAPISetup,SendNodeInformation,SendData,GetVersion,SendDataAbort,RFPowerLevelSet,GetHomeId,MemoryGetByte,MemoryPutByte,MemoryGetBuffer,MemoryPutBuffer,FlashAutoProgSet,NVMGetId,NVMExtReadLongBuffer,NVMExtWriteLongBuffer,NVMExtReadLongByte,NVMExtWriteLongByte,ClearNetworkStats,GetNetworkStats,GetBackgroundRSSI,RemoveNodeIdFromNetwork,GetNodeProtocolInformation,SetDefault,ReplicationReceiveComplete,AssignReturnRoute,DeleteReturnRoute,RequestNodeNeighbourUpdate,ApplicationNodeUpdate,AddNodeToNetwork,RemoveNodeFromNetwork,CreateNewPrimary,ControllerChange,SetLearnMode,AssignSUCReturnRoute,EnableSUC,RequestNetworkUpdate,SetSUCNodeId,DeleteSUCReturnRoute,GetSUCNodeId,SendSUCNodeId,ExploreRequestInclusion,RequestNodeInformation,RemoveFailedNode,IsFailedNode,ReplaceFailedNode,GetRoutingTableLine,GetPriorityRoute,SetPriorityRoute,RFPowerLevelGet,SendTestFrame,SetPromiscuousMode,PromiscuousCommandHandler,WatchDogStart,WatchDogStop,ZMEFreqChange,ZMERestore,ZMEBootloaderFlash,ZMECapabilities (09:18 PM)
softwareRevisionVersion: v2.3.3 (09:18 PM)
softwareRevisionId: 25bdd65bc580b075ba69b766a4113866403c0036 (09:18 PM)
softwareRevisionDate: 2017-04-13 21:53:20 +0300 (09:18 PM)
uuid: 3273f4a9597a21d0bd41c74679be9779 (09:18 PM)
caps: 0,0,255,5 (09:18 PM)
frequency: EU (09:18 PM)
deviceRelaxDelay: 15 (09:18 PM)
statistics: None (09:18 PM)
backgroundRSSI: None (09:18 PM)
channel1: 177 (09:43 PM)
channel2: 162 (09:43 PM)
channel3: 127 (09:43 PM)
RFTxFrames: 0 (09:18 PM)
RFTxLBTBackOffs: 0 (09:18 PM)
RFRxFrames: 0 (09:18 PM)
RFRxLRCErrors: 0 (09:18 PM)
RFRxCRC16Errors: 0 (09:18 PM)
RFRxForeignHomeID: 0 (09:18 PM)
priorityRoute: None (09:18 PM)
dstNodeId: None (09:18 PM)
routeType: None (09:18 PM)
speed: None (09:18 PM)
hops: None (09:18 PM)
homeName: (12:38 AM)
homeNotes: (12:38 AM)





I'm sure I'm doing something wrong.
Any help would be greatly appreciated!

Thanks in advance.

Leif
Posts: 17
Joined: 19 Jan 2019 17:28

Re: Z-Way + UZB beginner trouble - help please

Post by Leif » 22 Jan 2019 13:52

Is there a better place to ask this question? Is there an official support channel?

enbemokel
Posts: 259
Joined: 08 Aug 2016 17:36

Re: Z-Way + UZB beginner trouble - help please

Post by enbemokel » 22 Jan 2019 16:54

Polto is answering from time to time these questions, maybe you can send him a message via the forum.
I´m not using the UZB, so can´t help with ideas.

Leif
Posts: 17
Joined: 19 Jan 2019 17:28

Re: Z-Way + UZB beginner trouble - help please

Post by Leif » 23 Jan 2019 05:35

Thanks for the suggestion! He responded quickly -- the Windows version is out of date and doesn't support adding license keys to new UZB hardware. He suggested using a raspberry pi.

I may have a pi clone somewhere.. maybe i'll give it a try.

Leif
Posts: 17
Joined: 19 Jan 2019 17:28

Re: Z-Way + UZB beginner trouble - help please

Post by Leif » 23 Jan 2019 07:28

I tried with an actual Raspberry Pi (forgot that I had one) and Z-Way 2.3.8, and I'm seeing the EXACT same issue.

PM'ed again, hoping for solution.

Leif
Posts: 17
Joined: 19 Jan 2019 17:28

Re: Z-Way + UZB beginner trouble - help please

Post by Leif » 23 Jan 2019 09:59

I also successfully upgraded the bootloader, and the firmware to 5.36..
and I'm STILL getting the same exact error!!

Role in Network
Node Id: 1
Home Id: 0xf7a4a8de
Primary Role: Yes
Primary Capability: Yes
SUC/SIS in network: 1 (SIS)
Hardware
Vendor: Z-Wave.Me
Vendors Product ID: 1024 / 1
Z-Wave Chip: ZW0500
Firmware
Library Type: Static Controller
SDK Version: 6.81.01
Serial API Version: 05.36
Capabillities:
UUID: 3273f4a9597a21d0bd41c74679be9779
Subvendor: 0x0000
Nodes limit: Unlimited
Capabillities: SlM
Software Information
Version number: v2.3.8
Compile-ID: 854d8c466afa676694043ff7a9d17febb3bb01d6
Compile-Date: 2018-10-10 00:47:52 +0300
UI
UI version 1.3.3
Built date 05-07-2018 09:28:46


License key successfully verified
Unable to upgrade capabilities

I mean, seriously?? What gives?

Eagle
Posts: 90
Joined: 18 Jun 2017 19:04

Re: Z-Way + UZB beginner trouble - help please

Post by Eagle » 23 Jan 2019 12:32

hi,

have you ever tried to include some devices in normal mode? i got the same nodes limit and capabilities as you and my key is verified.

maybe unable to upgrade capabilities means, that your capabilities cant be upgraded any further, because you alredy got the upgraded status?

Leif
Posts: 17
Joined: 19 Jan 2019 17:28

Re: Z-Way + UZB beginner trouble - help please

Post by Leif » 23 Jan 2019 13:47

Yes I have actually -- I tried the normal mode before I went to Expert mode. After half a minute I get the following message:

"INCLUSION takes a long time to start up."

That's not a clear message at all. I mean, "uh, okay? thanks for telling me, I guess it's normal then?"

Because this message is not very clear (i think they meant to say "Timed out while waiting for inclusion to start"?) then I did also wonder wehther "Unable to upgrade capabilities" perhaps means that it has already been upgraded.. but, it isn't working. It also is not clear to me where to see whether it has been upgraded.. because I have never used this system before, I don't know what any of the status indicators are supposed to show. This only adds to frustration of course, I'm sure when things are working everything will be much nicer.

Eagle
Posts: 90
Joined: 18 Jun 2017 19:04

Re: Z-Way + UZB beginner trouble - help please

Post by Eagle » 23 Jan 2019 14:27

youll get "inclusion takes a long time to start up" as a normal message, if your controller did not find a device to include, or the device was not in inclusion mode.

what device did you try to include?

Leif
Posts: 17
Joined: 19 Jan 2019 17:28

Re: Z-Way + UZB beginner trouble - help please

Post by Leif » 23 Jan 2019 16:06

Eagle wrote:
23 Jan 2019 14:27
what device did you try to include?
I tried including a NEO CoolCam PowerPlug.

This type of device has always worked perfectly for me with Fibaro HC2, so I figured it was a safe bet to start. In fact, i included and excluded it from the Fibaro system before trying on Z-Way.

"Inclusion takes a long time to start up", the way it's formulated and because it comes after such a long time, seems more akin to a microsoft-style "that didn't work" message. The fact that the expert mode message comes immediately, but the simple UI comes after a long time, tells me perhaps the simple UI doesn't quite know what it's doing. Of course, I'm only guessing, since I have yet to see Z-way work!

Post Reply