Z-Way 3.0.0: sensor values logging stopped working

Discussions about Z-Way software and Z-Wave technology in general
Post Reply
Confuzer
Posts: 10
Joined: 19 Jun 2014 12:55

Z-Way 3.0.0: sensor values logging stopped working

Post by Confuzer » 27 Sep 2019 13:14

Heya,

I just updated to Z-Way 3.0.0 and I sensor data is visible, but the created webhooks in the app Sensor Values Logging are not firing anymore.

Does the app need an update, or is it me? I am not sure how to start debugging this, so any help is welcome :)

platypus
Posts: 16
Joined: 28 Apr 2019 16:32

Re: Z-Way 3.0.0: sensor values logging stopped working

Post by platypus » 29 Sep 2019 20:04

Did you try to uninstall and reinstall the app? Creating a new instance of this app helped me once.

Confuzer
Posts: 10
Joined: 19 Jun 2014 12:55

Re: Z-Way 3.0.0: sensor values logging stopped working

Post by Confuzer » 30 Sep 2019 00:34

I was thinking of that as a last resort... dove into the log file but saw this which is the same as older files:

working
[2019-03-03 08:00:23.967] [core] Instantiating module 16 from class SensorValueLogging
[2019-03-03 08:00:23.968] [core] --- Starting module Sensor Values Logging

Not working
[2019-09-29 04:00:16.280] [core] Executing script: /*** SensorValueLogging Z-Way Home Automation module ***********************$
[2019-09-29 04:00:16.293] [core] Instantiating module 13 from class SensorValueLogging
[2019-09-29 04:00:16.294] [core] --- Starting module Sensor Values Logging
[2019-09-29 04:00:16.331] [core] Instantiating module 15 from class SensorValueLogging
[2019-09-29 04:00:16.332] [core] --- Starting module Sensor Values Logging
[2019-09-29 04:00:16.372] [core] Instantiating module 16 from class SensorValueLogg


In the code, which is simple, it just does an http request. Makes me wonder if it lost some Curl/wget whatever access, not sure what the js compiler uses underwater.
https://github.com/Z-Wave-Me/home-autom ... g/index.js

Just worried the backup file you can download doesn't have the app backups... do you know? (o wait, with the app you mean the sensorvalueslogging...)

Confuzer
Posts: 10
Joined: 19 Jun 2014 12:55

Re: Z-Way 3.0.0: sensor values logging stopped working

Post by Confuzer » 02 Oct 2019 11:10

Well... as I don't know how to remove the sensor logging module (is it even possible?) I tried the stretch upgrade again, hoping some tools were not up to date.

And after 3 hours of installing the whole internet on it (dist-upgrade) with some errors (as always, I need a custom Python implementation and it didn't like that) I tried rebooting the machine, praying to god.

Dead.

I am going to hook it up to a monitor today and check which 80 errors it has, but seriously, I DON'T like this. Maybe you shouldn't update from Jessie if you have too much custom settings and tweaks on it.

Did I also mention that the extensive logging it does to the log file made my z-way crash within a day again? I disabled the logging in the previous version (in the js save funcion) and it never crashed.

Post Reply