Razberry Z-Way 3.0.0--CRC16 and Security classes showing up

Discussions about Z-Way software and Z-Wave technology in general
timb
Posts: 79
Joined: 03 Jan 2015 00:10

Re: Razberry Z-Way 3.0.0--CRC16 and Security classes showing up

Post by timb »

and later in the same log:
2020-02-14 10:20:39.469] [W] [zway] Got command class 0x30, command 0x03 frame from device 87 to controller, but policy do not allow it - ignoring
[2020-02-14 10:20:39.469] [D] [zway] SETDATA devices.87.data.lastReceived = 0 (0x00000000)
[2020-02-14 10:20:39.767] [D] [zway] RECEIVED: ( 01 16 00 04 10 57 0E 30 03 00 43 21 44 00 00 00 02 00 00 6B 8A B5 00 E7 )
[2020-02-14 10:20:39.767] [D] [zway] SENT ACK
[2020-02-14 10:20:39.767] [W] [zway] Got command class 0x30, command 0x03 frame from device 87 to controller, but policy do not allow it - ignoring
[2020-02-14 10:20:39.767] [D] [zway] SETDATA devices.87.data.lastReceived = 0 (0x00000000)
[2020-02-14 10:20:40.107] [D] [zway] RECEIVED: ( 01 16 00 04 10 57 0E 30 03 00 43 21 44 00 00 00 02 00 00 6B 8A B6 00 E4 )
[2020-02-14 10:20:40.107] [D] [zway] SENT ACK
[2020-02-14 10:20:40.108] [W] [zway] Got command class 0x30, command 0x03 frame from device 87 to controller, but policy do not allow it - ignoring
[2020-02-14 10:20:40.108] [D] [zway] SETDATA devices.87.data.lastReceived = 0 (0x00000000)

brianaker
Posts: 33
Joined: 11 Nov 2016 16:57

Re: Razberry Z-Way 3.0.0--CRC16 and Security classes showing up

Post by brianaker »

FWIW I have been seeing similar behavior. Devices will add CRC at random. As soon as I try interview the device CRC will disappear.

timb
Posts: 79
Joined: 03 Jan 2015 00:10

Re: Razberry Z-Way 3.0.0--CRC16 and Security classes showing up

Post by timb »

Were the logs i provided no good?
How else can i help?
Still suffering here.

User avatar
PoltoS
Posts: 5956
Joined: 26 Jan 2011 19:36

Re: Razberry Z-Way 3.0.0--CRC16 and Security classes showing up

Post by PoltoS »

[2020-02-14 10:00:17.563] [D] [zway] RECEIVED: ( 01 12 00 04 10 FF 0A 56 01 31 05 03 0A 00 12 35 E2 AD 00 0E )
[2020-02-14 10:00:17.563] [D] [zway] SENT ACK
[2020-02-14 10:00:17.563] [E] [zway] Got frame from device 255 to controller, but device is not registered - do re-inclusion
255 is broadcast. Some device is broadcasting, but with wrong packet. The packet flag is not broadcast, but destID is 255.

User avatar
PoltoS
Posts: 5956
Joined: 26 Jan 2011 19:36

Re: Razberry Z-Way 3.0.0--CRC16 and Security classes showing up

Post by PoltoS »

2020-02-14 10:20:39.469] [W] [zway] Got command class 0x30, command 0x03 frame from device 87 to controller, but policy do not allow it - ignoring
[2020-02-14 10:20:39.469] [D] [zway] SETDATA devices.87.data.lastReceived = 0 (0x00000000)
[2020-02-14 10:20:39.767] [D] [zway] RECEIVED: ( 01 16 00 04 10 57 0E 30 03 00 43 21 44 00 00 00 02 00 00 6B 8A B5 00 E7 )
This looks like device 87 is sending a Sensor Binary Report with bad sensor type. But the packet is too long and wrong. Since the same packet is sent twice, looks not as a CRC/RF error, but as a memory overrun inside the device (device send buffer corruption)

timb
Posts: 79
Joined: 03 Jan 2015 00:10

Re: Razberry Z-Way 3.0.0--CRC16 and Security classes showing up

Post by timb »

OK thanks for that. I will try to re-include, see what happens.
Device 87 is a dual Qibino relay.
When i force interview, all classes interview OK except Security. But then, a lot of my devices fail interview on security. Is there a way I can fix this?
Thanks

User avatar
PoltoS
Posts: 5956
Joined: 26 Jan 2011 19:36

Re: Razberry Z-Way 3.0.0--CRC16 and Security classes showing up

Post by PoltoS »

Security interview happens only in first 20 seconds after inclusion

rafale77
Posts: 115
Joined: 23 Jun 2018 19:26

Re: Razberry Z-Way 3.0.0--CRC16 and Security classes showing up

Post by rafale77 »

I just had this sporadic command class show up again today on one of my non secure devices. Unfortunately I have no idea when it occurred so I can't find the logs for it. The time range could be very long. For me it shows up on completely random devices. Sensors, light switches, dimmers. A forced reinterview removes the security or the CRC16 command class. It isn't very frequent... This is the first in 2 weeks.

rafale77
Posts: 115
Joined: 23 Jun 2018 19:26

Re: Razberry Z-Way 3.0.0--CRC16 and Security classes showing up

Post by rafale77 »

I am starting to suspect that these problems are caused by bad packets on the zwave network caused by either noise or retransmission/collisions. I have significantly decreased background noise on my network so I will see if this goes away.

rafale77
Posts: 115
Joined: 23 Jun 2018 19:26

Re: Razberry Z-Way 3.0.0--CRC16 and Security classes showing up

Post by rafale77 »

Well I spoke two fast, I just had two in a week. One on a door sensor and another on a outlet plug.
I can believe that they are caused by noise and retransmissions in the network causing z-way to be confused. Maybe @PoltoS, one way to avoid it is to prevent the addition of new command class after a certain time after the forced interview? It doesn’t do anything to the device itself. It is just a cosmetic annoyance.

Post Reply