Page 8 of 9

Re: Razberry Z-Way 3.0.0--CRC16 and Security classes showing up

Posted: 16 Jul 2020 19:10
by cdogg76
Thanks, PoltoS! I can't wait to give this a try--hopefully I'll be rid of all the "Interview is not complete" listings!

What was the fix exactly?

Thanks!

Re: Razberry Z-Way 3.0.0--CRC16 and Security classes showing up

Posted: 17 Jul 2020 02:22
by PoltoS
We have added checking of the NIF, secure NIF and Multichannel NIF before instantiating new CC. RPi and Ubuntu beta are available. You can test them

Re: Razberry Z-Way 3.0.0--CRC16 and Security classes showing up

Posted: 17 Jul 2020 19:15
by cdogg76
Thanks, PoltoS! I upgraded my RPi yesterday and manually removed the Security and CRC CC's from the devices that mistakenly had them. So far so good--they haven't come back!

I'm seeing another unrelated problem. I have several in-wall binary switches (Jasco and Honeywell) that can't complete the AssociationGroupInformation interview. When I force it, I see a bunch of related jobs run through the queue and deliver, but the interview item never completes. Any idea why that might happen? Thanks!

Re: Razberry Z-Way 3.0.0--CRC16 and Security classes showing up

Posted: 26 Jul 2020 19:34
by PoltoS
As I remember, those devices are a bit buggy, they don't reply AGI correctly.

You can send us logs and use meanwhile the hack to mark the interview as done.

Re: Razberry Z-Way 3.0.0--CRC16 and Security classes showing up

Posted: 09 Aug 2020 15:03
by DesT
@PoltoS, not sure at 100% it's related but since I move to the "Beta" version for Ubuntu that corrected the Security classes showing up, I got some light dimmer and receptacle that are not working as well as before...

Re: Razberry Z-Way 3.0.0--CRC16 and Security classes showing up

Posted: 11 Aug 2020 01:17
by PoltoS
@DesT Can you give us more details?

Re: Razberry Z-Way 3.0.0--CRC16 and Security classes showing up

Posted: 13 Aug 2020 14:16
by DesT
@PoltoS,

Since that, my device "DZ1KD" from Leviton is working bad as hell ;)

The instant status stopped working, and I can't toggle it on/off using zwave. Last weekend, I had to reset to factory, and pair again to the network to make it work again, but that worked for a couple of days and then stopped working.

Never got an issue like that before the last update!

Re: Razberry Z-Way 3.0.0--CRC16 and Security classes showing up

Posted: 14 Aug 2020 11:18
by karan123
I am currently practically persuaded that this issue is because of undermined outlines coming into the Z-Wave dongle and passing the CRC check. Bringing down in general RF commotion on the system helps however I on a very basic level, CC ought to never be included after the meeting is finished so a square ought to be made to not permit CC expansion in the event that they are not in the NIF bring the list back. I think PoltoS is taking a shot at it.

Re: Razberry Z-Way 3.0.0--CRC16 and Security classes showing up

Posted: 14 Aug 2020 17:28
by PoltoS
@karan123 We have released a beta version solving this. Please hek this thread above. It will soon become a release

Re: Razberry Z-Way 3.0.0--CRC16 and Security classes showing up

Posted: 22 Aug 2020 18:37
by DesT
@PoltoS,

The issue with my Leviton dimmer since the upgrade with the Beta, it's the status is not reported back correctly. The status always appear as ON but i'm able to switch them on/off!