Eventlog/history retention

Discussions about Z-Way software and Z-Wave technology in general
micky1500
Posts: 154
Joined: 07 Feb 2016 16:29

Re: Eventlog/history retention

Post by micky1500 »

PoltoS posted this a while ago.
Just need to edit the version at the beginning and all the work is done with one go.
I have upgraded with this command.

export BUILD=3.1.2; cd /tmp/ && wget https://storage.z-wave.me/z-way-server/ ... _armhf.deb && sudo dpkg -i z-way-${BUILD}_armhf.deb
Raspi 4(Buster), Zwave Version 3.1.2
vinisz
Posts: 65
Joined: 23 Nov 2019 23:23

Re: Eventlog/history retention

Post by vinisz »

apt-get does not update the version.. all I get is this:

sudo apt-get update
Hit:1 http://giteduberger.fr rpimonitor/ InRelease
Get:2 http://raspbian.raspberrypi.org/raspbian buster InRelease [15.0 kB]
Get:3 http://archive.raspberrypi.org/debian buster InRelease [32.6 kB]
Hit:4 https://deb.nodesource.com/node_12.x buster InRelease
Get:5 https://repo.z-wave.me/z-way/raspbian buster InRelease [1,809 B]
Get:6 http://archive.raspberrypi.org/debian buster/main armhf Packages [351 kB]
Fetched 401 kB in 2s (221 kB/s)
Update rpimonitor Packages Status
Reading package lists... Done

sudo apt-get upgrade
Reading package lists... Done
Building dependency tree
Reading state information... Done
Calculating upgrade... Done
The following package was automatically installed and is no longer required:
rpi-eeprom-images
Use 'sudo apt autoremove' to remove it.
The following packages have been kept back:
binutils binutils-arm-linux-gnueabihf binutils-common libbinutils
python-rpi.gpio webif
0 upgraded, 0 newly installed, 0 to remove and 6 not upgraded.

I'm not very willing to try other workaround, I had issues with that in the past.
Why does upgrading the normal way (via apt-get) not work ?
micky1500
Posts: 154
Joined: 07 Feb 2016 16:29

Re: Eventlog/history retention

Post by micky1500 »

Yes that is the correct response from sudo apt-get upgrade
That is a request to Upgrade your Raspberry with Latest update for your Raspberry version.
It's not clever enough to know you wanted to upgrade you z-way application.

I don't think z-way updates are stored on the Raspberry repository.
Z-way updates need to be downloaded from z-wave.me

export BUILD=3.1.2; cd /tmp/ && wget https://storage.z-wave.me/z-way-server/ ... _armhf.deb && sudo dpkg -i z-way-${BUILD}_armhf.deb

Hope that helps you.
Raspi 4(Buster), Zwave Version 3.1.2
vinisz
Posts: 65
Joined: 23 Nov 2019 23:23

Re: Eventlog/history retention

Post by vinisz »

Strange, I upgraded this way last time and you can see “repo.z-wave.me” listed, it should look there for new builds right ?
vinisz
Posts: 65
Joined: 23 Nov 2019 23:23

Re: Eventlog/history retention

Post by vinisz »

PoltoS wrote:
11 Jan 2021 05:55
It is already. You can upgrade via apt-get
As Stated above, does not work Poltos, can you have a look ?
User avatar
PoltoS
Posts: 6086
Joined: 26 Jan 2011 19:36

Re: Eventlog/history retention

Post by PoltoS »

Can you reproduce it under a temp user and provide us access?
vinisz
Posts: 65
Joined: 23 Nov 2019 23:23

Re: Eventlog/history retention

Post by vinisz »

What do you mean with "reproduce it under a temp user ?" , apt-get update & upgrade need to be done by root (so sudo is needed) , I don't think another user makes a difference..
vinisz
Posts: 65
Joined: 23 Nov 2019 23:23

Re: Eventlog/history retention

Post by vinisz »

Updating from the GUI also does not work, when I press the button I get my ip adres(of the Rpi) shown and then "refuses to connect"
Naamloos.png
Naamloos.png (8.8 KiB) Viewed 90 times
enbemokel
Posts: 400
Joined: 08 Aug 2016 17:36

Re: Eventlog/history retention

Post by enbemokel »

export BUILD=3.1.2; cd /tmp/ && wget https://storage.z-wave.me/z-way-server/ ... _armhf.deb && sudo dpkg -i z-way-${BUILD}_armhf.deb

Worked for me, thanks. I only had to correct the link, seems forum software is changing some of the copied letters/numbers.
Nico
User avatar
PoltoS
Posts: 6086
Joined: 26 Jan 2011 19:36

Re: Eventlog/history retention

Post by PoltoS »

vinisz wrote:
12 Jan 2021 14:28
What do you mean with "reproduce it under a temp user ?" , apt-get update & upgrade need to be done by root (so sudo is needed) , I don't think another user makes a difference..
I meant make a new user with admin role (in Z-Way) and let us check it. Or you can provide your existing user
Post Reply