Interview errors with Fibaro Walli devices

Discussions about Z-Way software and Z-Wave technology in general
ukku_voigt
Posts: 5
Joined: 17 Jan 2020 19:34

Interview errors with Fibaro Walli devices

Post by ukku_voigt »

I purchased thre different Fibaro Walli devices:
- Walli Roller Shutter (FGWREU-111)
- Walli Switch (FGWDSEU-221)
- Walli Outlet (FGWOE-011)
All three run on error in the UI but I they appeared in Expert UI and I could force most interviews. But two parameters couldn't be forced: Security and SecurityS2. Both failing with "Unable to update Data". I allready updated z-way to 3.0.3. The devises are working fine, so far I can't see any operational problems. What may cause this problem?

User avatar
PoltoS
Posts: 5820
Joined: 26 Jan 2011 19:36

Re: Interview errors with Fibaro Walli devices

Post by PoltoS »

Security requires full reinclusion

ukku_voigt
Posts: 5
Joined: 17 Jan 2020 19:34

Re: Interview errors with Fibaro Walli devices

Post by ukku_voigt »

UNfortunately that fails again.

User avatar
PoltoS
Posts: 5820
Joined: 26 Jan 2011 19:36

Re: Interview errors with Fibaro Walli devices

Post by PoltoS »

We have made few fixes in v3.0.4. Please give it a try

ukku_voigt
Posts: 5
Joined: 17 Jan 2020 19:34

Re: Interview errors with Fibaro Walli devices

Post by ukku_voigt »

With 3.0.4 Interview stops at 90 or sometimes 95%. Expert view shows that interview for Security and SecurityS2 still fail.
I discovered something else: If in Expert UI I try to set the LED frame brightness with the available value 256, the LEDs switch off. On expert commands I tried the value of 99, then it works (LEDs on).

User avatar
PoltoS
Posts: 5820
Joined: 26 Jan 2011 19:36

Re: Interview errors with Fibaro Walli devices

Post by PoltoS »

256 is 0 when converted to a byte ;)

To re-interview security you need to exclude and then include again

ursk
Posts: 13
Joined: 01 Apr 2018 17:09

Re: Interview errors with Fibaro Walli devices

Post by ursk »

I have a similar problem with a Devolo door sensor.
I made the update to 3.0.4 doesn't solve the problem.
Errors like "Repaet faild inteviews.."

Finaly the interview stopped at 90% and I could get it to 100% with the command
http://IP:8083/JS/Run/zway.devices[32]. ... wDone=true

I can see the sensor on the UI but without any function.

The inclusion of this sensor worked with v2.3.8

micky1500
Posts: 150
Joined: 07 Feb 2016 16:29

Re: Interview errors with Fibaro Walli devices

Post by micky1500 »

I also have a FIBARO device (FGWPG-121-ZW5) that will not complete it's interview.
I have v3.0.4 running, have Excluded and tried to re-Include, Interview still fails but the device is working.
Fails to Include with Secure S2, says Authentication failed. (I used the pin number provided from the device)
I removed and re-included with "Force unsecure inclusion"
Even with UN-secure inclusion, it still wants S2 interview to complete !

I have bypassed the interview with the following commands :-
192.168.1.89:8083/JS/Run/zway.devices[47].SecurityS2.data.interviewDone=true
192.168.1.89:8083/JS/Run/zway.devices[47].Security.data.interviewDone=true
192.168.1.89:8083/JS/Run/zway.devices[47].Protection.data.interviewDone=true
192.168.1.89:8083/JS/Run/zway.devices[47].instances[1].Security.data.interviewDone=true
192.168.1.89:8083/JS/Run/zway.devices[47].instances[1].SecurityS2.data.interviewDone=true
192.168.1.89:8083/JS/Run/zway.devices[47].instances[1].Protection.data.interviewDone=true
192.168.1.89:8083/JS/Run/zway.devices[47].instances[2].Security.data.interviewDone=true
192.168.1.89:8083/JS/Run/zway.devices[47].instances[2].SecurityS2.data.interviewDone=true



log:-
[2020-01-24 13:17:09.144] [zway] Node 47:2 CC SecurityS2 Interview started
[2020-01-24 13:17:09.144] [D] [zway] SETDATA devices.47.instances.2.commandClasses.159.data.grantedKeys.S0 = False
[2020-01-24 13:17:09.144] [D] [zway] SETDATA devices.47.instances.2.commandClasses.159.data.grantedKeys.S2Unauthenticated = False
[2020-01-24 13:17:09.144] [D] [zway] SETDATA devices.47.instances.2.commandClasses.159.data.grantedKeys.S2Authenticated = False
[2020-01-24 13:17:09.144] [D] [zway] SETDATA devices.47.instances.2.commandClasses.159.data.grantedKeys.S2Access = False
[2020-01-24 13:17:09.144] [E] [zway] Node 47:2 CC SecurityS2: secure channel not established on root device - can not interview inside channel
[2020-01-24 13:17:09.144] [E] [zway] Error returned from (command->cc->interview_handler)(zway, command): Function class not supported by the hardware (-4)
[2020-01-24 13:17:09.144] [W] [zway] Security S0/S2 bootstrap failed
[2020-01-24 13:17:09.144] [D] [zway] Own inclusion - nothing to report to inclusion controller
[2020-01-24 13:17:09.154] [D] [zway] SENDING (cb 0xa7): ( 01 11 00 13 2F 0A 56 01 60 0D 00 01 75 04 EC 8D 25 A7 71 )
[2020-01-24 13:17:09.161] [D] [zway] RECEIVED: ( 01 04 01 13 01 E8 )
[2020-01-24 13:17:09.161] [D] [zway] Delivered to Z-Wave stack
[2020-01-24 13:17:09.205] [D] [zway] RECEIVED: ( 01 18 00 13 A7 00 00 04 00 C9 7F 7F 7F 7F 01 01 03 00 00 00 00 02 01 00 00 9E )
[2020-01-24 13:17:09.206] [zway] Job 0x13 (Protection Supported Get): Delivered
[2020-01-24 13:17:09.206] [D] [zway] SendData Response with callback 0xa7 received: received by recipient
[2020-01-24 13:17:09.206] [D] [zway] SETDATA devices.47.data.lastSendInternal = **********
[2020-01-24 13:17:09.206] [D] [zway] SETDATA devices.47.data.lastSend = 8564202 (0x0082adea)
[2020-01-24 13:17:09.206] [D] [zway] Job 0x13 (Protection Supported Get): success
[2020-01-24 13:17:09.206] [zway] Waiting for job reply: Protection Supported Get
[2020-01-24 13:17:09.235] [D] [zway] RECEIVED: ( 01 17 00 04 00 2F 0F 56 01 60 0D 01 00 75 05 00 05 00 03 00 54 DF C9 00 C3 )
[2020-01-24 13:17:09.235] [D] [zway] SETDATA devices.47.data.lastReceived = 0 (0x00000000)
[2020-01-24 13:17:09.235] [D] [zway] Received reply on job (Protection Supported Get)
[2020-01-24 13:17:09.235] [D] [zway] SETDATA devices.47.instances.1.commandClasses.117.data.exclusiveCap = False
[2020-01-24 13:17:09.235] [D] [zway] SETDATA devices.47.instances.1.commandClasses.117.data.timeoutCap = False
[2020-01-24 13:17:09.235] [D] [zway] SETDATA devices.47.instances.1.commandClasses.117.data.stateCap = 5 (0x00000005)
[2020-01-24 13:17:09.235] [D] [zway] SETDATA devices.47.instances.1.commandClasses.117.data.rfStateCap = 3 (0x00000003)
[2020-01-24 13:17:09.287] [E] [zway] Error returned from __ProtectionSet(zway, command, value, 0, NULL, NULL, NULL): Bad arguments (-1)
[2020-01-24 13:17:09.287] [zway] Node 47:1 CC Protection: Auto Configuration done
[2020-01-24 13:17:11.168] [D] [zway] SETDATA devices.47.instances.2.commandClasses.159.data.grantedKeys.S0 = False
[2020-01-24 13:17:11.168] [D] [zway] SETDATA devices.47.instances.2.commandClasses.159.data.grantedKeys.S2Unauthenticated = False
[2020-01-24 13:17:11.168] [D] [zway] SETDATA devices.47.instances.2.commandClasses.159.data.grantedKeys.S2Authenticated = False
[2020-01-24 13:17:11.168] [D] [zway] SETDATA devices.47.instances.2.commandClasses.159.data.grantedKeys.S2Access = False
[2020-01-24 13:17:11.168] [E] [zway] Node 47:2 CC SecurityS2: secure channel not established on root device - can not interview inside channel
Raspi 4(Buster), Zwave Version 3.1.1

User avatar
PoltoS
Posts: 5820
Joined: 26 Jan 2011 19:36

Re: Interview errors with Fibaro Walli devices

Post by PoltoS »

@ursk: set association group #1 to Z-Way (also #1). This will make events work again.

@micky1500:
Node 47:2 CC SecurityS2 Interview started
It is not allowed to have S2 inside channels - this device will never pass Z-Wave certification.

The Protection Set error looks to come from the same reason, but we can not reproduce it for now.

Benn
Posts: 1
Joined: 04 Feb 2020 14:25

Re: Interview errors with Fibaro Walli devices

Post by Benn »

I have a similar problem with a Devolo door sensor.
MyBKExperience

Post Reply