Heating control - time driven broken

Discussions about Z-Way software and Z-Wave technology in general
Post Reply
zavinator
Posts: 2
Joined: 15 Oct 2020 01:24

Heating control - time driven broken

Post by zavinator »

Hi,

The heating control seems to be buggy in v3.1.1 (don't know in which version exactly it breaks)

If I set heating control to "time-driven" it is not using the "saving temperature" for the unset zones, but always the "comfort temperature" from the UI.
Setting heating control to "comfort" or "e-save" works good.

Does anyone have this problem too?

michap
Posts: 374
Joined: 26 Mar 2013 10:35
Contact:

Re: Heating control - time driven broken

Post by michap »

Hi,

in UI is written:
"A comfortable temperature is always keeping. Add new entries with a click. Move entries with drag and drop."

But it does NOT take the comfortable temperature, but the energy save temperature:
configuration:

Code: Select all

{"comfortTemp":21,"energySaveTemp":19,"fallbackTemp":"","sensorId":"ZWayVDev_zway_3-0-49-1","schedule":
{"0":[],"1":[],"2":[],"3":[],"4":[],"5":[],"6":[
{"stime":"00:00","etime":"04:00","temp":17},
{"stime":"04:00","etime":"05:00","temp":20},
{"stime":"05:05","etime":"07:30","temp":22},
{"stime":"08:00","etime":"08:50","temp":22},
{"stime":"10:10","etime":"11:40","temp":22}
result:

Code: Select all

[2020-10-17 07:30:01.480] [I] [core] [BaseModule-24] Set lastLevel to 19 for ZWayVDev_zway_3-0-67-1 (was 22)
[2020-10-17 08:00:01.407] [I] [core] [BaseModule-24] Set lastLevel to 22 for ZWayVDev_zway_3-0-67-1 (was 19)
Same will be shown on thermostat (and in attached Z-Wave log)
zwave.log.gz
(101.82 KiB) Downloaded 4 times
details)

What is an other effect - if you are in the "unset time frame" and it was set the energy save temperature - an you will click again on heating control "time driven" option - will be set the comfortable temperature.

So something is here wrong in code, I think so...

Michael

fez
Posts: 121
Joined: 20 Jul 2015 23:03

Re: Heating control - time driven broken

Post by fez »

zavinator wrote:
15 Oct 2020 01:32
Hi,

The heating control seems to be buggy in v3.1.1 (don't know in which version exactly it breaks)

If I set heating control to "time-driven" it is not using the "saving temperature" for the unset zones, but always the "comfort temperature" from the UI.
Setting heating control to "comfort" or "e-save" works good.

Does anyone have this problem too?
I can confirm the issue, at least partially. What I have seen is that the change is not done when activating the time driven mode, but later ... I guess when the schedule is triggering a change. For rooms with no schedule is bad luck.

User avatar
PoltoS
Posts: 5887
Joined: 26 Jan 2011 19:36

Re: Heating control - time driven broken

Post by PoltoS »

Thanks, we check it.

Post Reply