Heating control - scheduler - temperature setting wrong

Discussions about Z-Way software and Z-Wave technology in general
Post Reply
michap
Posts: 374
Joined: 26 Mar 2013 10:35
Contact:

Heating control - scheduler - temperature setting wrong

Post by michap »

I have following temperature setting configuration:

Code: Select all

{"comfortTemp":21,"energySaveTemp":19,"fallbackTemp":"","sensorId":"ZWayVDev_zway_3-0-49-1","schedule":
{"0":[],"1":[],"2":[],"3":[],"4":[],"5":[],"6":[
{"stime":"00:00","etime":"04:00","temp":17},
{"stime":"04:00","etime":"05:00","temp":20},
{"stime":"05:05","etime":"07:30","temp":22},
{"stime":"08:00","etime":"08:50","temp":22},
{"stime":"10:10","etime":"11:40","temp":22}
As you can see at 04:00 I have a continuous configuration - a temperature change from 17 to 20 degree.

This kind of configuration does not work - in result will be set the energy save temperature. So in my case I do not have 20 degree but 19 degree.
(it maybe more critical if you set in winter 23 degree and will get in result 18 degree only :) )

it is only working if you will use a "pause" between the settings like between 05:00 and 05:05 in configuration.

results:

Code: Select all

[2020-10-17 04:00:02.777] [I] [core] [BaseModule-24] Set lastLevel to 19 for ZWayVDev_zway_3-0-67-1 (was 17)
[2020-10-17 04:00:23.689] [I] [core] [BaseModule-24] Set lastLevel to 20 for ZWayVDev_zway_3-0-67-1 (was 19)
[2020-10-17 04:00:24.498] [I] [core] [BaseModule-24] Set lastLevel to 19 for ZWayVDev_zway_3-0-67-1 (was 20)
workaround with "pause":

Code: Select all

[2020-10-17 05:00:00.892] [I] [core] ---  ZWayVDev_zway_3-0-67-1 performCommand processing: {"0":"exact","1":{"level":"19"}}
[2020-10-17 05:05:00.651] [I] [core] ---  ZWayVDev_zway_3-0-67-1 performCommand processing: {"0":"exact","1":{"level":"22"}}
The workaround is not very nice because it will make an additional not needed setting on thermostat (battery).

Attached the Z-Wave log - in testing configuration is only the one thermostat (Eurotronic Spirit)

Michael
Attachments
zwave.log.gz
(101.82 KiB) Downloaded 4 times

User avatar
PoltoS
Posts: 5887
Joined: 26 Jan 2011 19:36

Re: Heating control - scheduler - temperature setting wrong

Post by PoltoS »

good point. Thanks for pointing us to the issue

Post Reply