need help to unmask type specific events

Discussions about Z-Way software and Z-Wave technology in general
Post Reply
wildling
Posts: 5
Joined: 13 Feb 2018 20:49

need help to unmask type specific events

Post by wildling »

Hi, by mistake I masked all events from type "connection lost", by the way these events disappear from the z-way-server.log too
can anybody tell me how to re-enable events masked by type?
Thanks

User avatar
PoltoS
Posts: 5956
Joined: 26 Jan 2011 19:36

Re: need help to unmask type specific events

Post by PoltoS »

Looks like the UI is missing this. We have created a ticket for it.

Meanwhile stop Z-Way, open config,json on the filesystem and search for hide_single_device_events. Edit the value of this field and restart Z-Way back.

wildling
Posts: 5
Joined: 13 Feb 2018 20:49

Re: need help to unmask type specific events

Post by wildling »

Thanks for your response,

I changed in config,json "hide_single_device_events": [], --> "hide_single_device_events": false,

I now have the "[core] Notification: error (connection): Connection lost to Z-Wave device ID: 9" in the log, but neither events in the event gui, nor unfortunately a way to get the event watcher triggering according to
https://forum.z-wave.me/viewtopic.php?t=25726
which worked perfectly before.
As I workaround I now use SEC analyzing the log and the code device app "to get value"

Do you have another hint?

User avatar
PoltoS
Posts: 5956
Joined: 26 Jan 2011 19:36

Re: need help to unmask type specific events

Post by PoltoS »

[] -> false is wrong. [] means it is not the correct value - you need to find another one. Please send this file or check yourself similar fields around.

wildling
Posts: 5
Joined: 13 Feb 2018 20:49

Re: need help to unmask type specific events

Post by wildling »

Okay, mysterious, false appeared to be the appropriate value regarding the other parameters ....
I joined the file (zipped for upload reasons)
Attachments
config.zip
(2.73 KiB) Downloaded 13 times

User avatar
PoltoS
Posts: 5956
Joined: 26 Jan 2011 19:36

Re: need help to unmask type specific events

Post by PoltoS »

"hide_single_device_events": [] should be the correct way to reset it. Make sure you are fixing this in the correct (may be all) profile

wildling
Posts: 5
Joined: 13 Feb 2018 20:49

Re: need help to unmask type specific events

Post by wildling »

I changed again for "hide_single_device_events": [] in all (2) profiles, rebooted and tested by powering off the z-wave switch device. No notification about connection lost.
My sec + code device (log tracking with sec -> value in a semaphore file -> red by a zway code device) workaround works very well.
If its to give mor information for the ticket you created on 9th November I ll be ready to continue with you on this, otherwise I get all I need by the workaround.
Thank you

Post Reply