Ubuntu v4.1.3

Discussions about Z-Way software and Z-Wave technology in general
Post Reply
DesT
Posts: 68
Joined: 07 Mar 2020 17:04

Ubuntu v4.1.3

Post by DesT »

@Poltos,

When upgrading 4.1.1 to 4.1.3 on Ubuntu 20.04.06 LTS (amd64), z-way-server refuse to start...

Got this:

error while loading shared libraries: libgattlib.so: cannot open shared object file: No such file or directory

And I can't find the package that contain this libraries...
lanbrown
Posts: 308
Joined: 01 Jun 2021 08:06

Re: Ubuntu v4.1.3

Post by lanbrown »

$ dpkg-deb -I gattlib-0.1.deb
new debian package, version 2.0.
size 81510 bytes: control archive=440 bytes.
258 bytes, 10 lines control
175 bytes, 3 lines md5sums
Package: gattlib
Version: 0.1
Section: devel
Priority: optional
Architecture: amd64
Depends: libglib2.0-0
Installed-Size: 227
Maintainer: Olivier Martin <olivier@labapart.com>
Description: Library to access GATT information from Bluetooth Low Power devices

$ dpkg-deb -c gattlib-0.1.deb
drwxrwxr-x root/root 0 2016-04-28 13:05 ./usr/
drwxrwxr-x root/root 0 2016-04-28 13:05 ./usr/lib/
drwxrwxr-x root/root 0 2016-04-28 13:05 ./usr/lib/pkgconfig/
-rw-r--r-- root/root 269 2016-04-28 13:04 ./usr/lib/pkgconfig/gattlib.pc
-rw-r--r-- root/root 228334 2016-04-28 13:05 ./usr/lib/libgattlib.so
drwxrwxr-x root/root 0 2016-04-28 13:05 ./usr/include/
-rw-r--r-- root/root 3421 2016-04-28 00:47 ./usr/include/gattlib.h
DesT
Posts: 68
Joined: 07 Mar 2020 17:04

Re: Ubuntu v4.1.3

Post by DesT »

thanks but this package is not available to install.

Nothing return with apt-cache search, where can I download it ?
lanbrown
Posts: 308
Joined: 01 Jun 2021 08:06

Re: Ubuntu v4.1.3

Post by lanbrown »

DesT
Posts: 68
Joined: 07 Mar 2020 17:04

Re: Ubuntu v4.1.3

Post by DesT »

Thanks @lanbrown

Is there any other prereq for the build ? Can't find a list of them anywhere as, just after installing the gattlib package, now it asked for libpython3.10, but in Ubuntu 20.04.06 it's version 3.9
lanbrown
Posts: 308
Joined: 01 Jun 2021 08:06

Re: Ubuntu v4.1.3

Post by lanbrown »

That would be a question for the developer.

You can try:

Code: Select all

sudo apt install ./* && sudo apt --fix-broken install ./*
or

Code: Select all

apt-get install -f
User avatar
PoltoS
Posts: 7601
Joined: 26 Jan 2011 19:36

Re: Ubuntu v4.1.3

Post by PoltoS »

Thanks for the feedback, we found that the file was not copied in the build. Please put this file in the /opt/z-way-server/libs folder: https://storage.z-wave.me/tmp/libgattlib.so
DesT
Posts: 68
Joined: 07 Mar 2020 17:04

Re: Ubuntu v4.1.3

Post by DesT »

thanks @PoltoS

4.1.3 is working with this file added ;)
User avatar
PoltoS
Posts: 7601
Joined: 26 Jan 2011 19:36

Re: Ubuntu v4.1.3

Post by PoltoS »

We have rebuilt the v4.1.3 so it includes the missing library now.
Post Reply