Не могу установить новую версию 3.0.0

Данный раздел предназначен для русскоязычных пользователей. Если вы владеете английским, рекомендуем также просмотреть общую ветку обсуждений на английском.
Dan
Posts: 24
Joined: 01 May 2019 11:39

Re: Не могу установить новую версию 3.0.0

Post by Dan »

PoltoS wrote:
04 Apr 2020 02:53
Кто хочет потестить v3.0.5 для Hub? Присылайте uuid контроллеров!
3ff51ffcd95dce8c34bff2b92205421c
Сейчас стоит v3.0.0 и обновлений не предлагает

artik
Posts: 5
Joined: 04 Aug 2020 16:08

Re: Не могу установить новую версию 3.0.0

Post by artik »

Решил обновиться на новую версию (сейчас 2.7) Проверил версию системы у меня jessie.
Нужно ли мне выполнять команды для апгрейда wheezy ?

sudo sed -i /deb/s/wheezy/buster/g /etc/apt/sources.list
sudo sed -i /deb/s/wheezy/buster/g /etc/apt/sources.list.d/*.list

Прошу прощения за идиотский вопрос...

User avatar
PoltoS
Posts: 5946
Joined: 26 Jan 2011 19:36

Re: Не могу установить новую версию 3.0.0

Post by PoltoS »

Да, только замените wheezy на jessie

artik
Posts: 5
Joined: 04 Aug 2020 16:08

Re: Не могу установить новую версию 3.0.0

Post by artik »

Т.е вот так будет правильно?

sudo apt-get update
sudo apt-get upgrade
sudo apt-get dist-upgrade
sudo sed -i /deb/s/jessie/buster/g /etc/apt/sources.list
sudo sed -i /deb/s/jessie/buster/g /etc/apt/sources.list.d/*.list
sudo apt-get update
sudo apt-get upgrade
sudo apt-get dist-upgrade
sudo apt-get autoremove
sudo apt-get autoclean

И после этого выполнить команду:
wget -q -O - https://storage.z-wave.me/RaspbianInstall | sudo bash

User avatar
PoltoS
Posts: 5946
Joined: 26 Jan 2011 19:36

Re: Не могу установить новую версию 3.0.0

Post by PoltoS »

Да. Но лучше часть обновления проверить по инструкциям с сайта Raspberry Pi. Кстати, возможно, записать новый образ будет быстрее.

artik
Posts: 5
Joined: 04 Aug 2020 16:08

Re: Не могу установить новую версию 3.0.0

Post by artik »

Об образе я тоже подумал. Тогда вопрос как правильно сделать бэкап? И насколько я помню нужно еще какую то команду внести чтобы заходить под старым логином в облако?

User avatar
PoltoS
Posts: 5946
Joined: 26 Jan 2011 19:36

Re: Не могу установить новую версию 3.0.0

Post by PoltoS »

В интерфейсе есть Backup. Сохраните .zab файл и потом из него восстановитесь

Post Reply