Не установить свежую версию (3.0.6).

Данный раздел предназначен для русскоязычных пользователей. Если вы владеете английским, рекомендуем также просмотреть общую ветку обсуждений на английском.
Post Reply
wusiko
Posts: 2
Joined: 31 May 2020 16:24

Не установить свежую версию (3.0.6).

Post by wusiko »

Привет. Ситуация следующая. Умерла моя старая Rpi, и я решил перенести железку и софт на другую RPi (3B). Но меня постигла неудача.

Rpi запущена с последнего доступного образа и обновлена.
Пробую полную инсталляцию через:

Code: Select all

wget -q -O - https://storage.z-wave.me/RaspbianInstall | sudo bash
Ничего не происходит. Пробую посмотреть что там в файле.

Code: Select all

~ $ wget https://storage.z-wave.me/RaspbianInstall
--2020-05-31 16:23:45--  https://storage.z-wave.me/RaspbianInstall
Resolving storage.z-wave.me (storage.z-wave.me)... 46.20.244.36
Connecting to storage.z-wave.me (storage.z-wave.me)|46.20.244.36|:443... connected.
ERROR: The certificate of ‘storage.z-wave.me’ is not trusted.
ERROR: The certificate of ‘storage.z-wave.me’ has expired.
Браузер при этом файл открывает без всяких предупреждений. Ладно пробую скачать так

Code: Select all

~ $  wget --no-check-certificate https://storage.z-wave.me/RaspbianInstall
--2020-05-31 16:30:59--  https://storage.z-wave.me/RaspbianInstall
Resolving storage.z-wave.me (storage.z-wave.me)... 46.20.244.36
Connecting to storage.z-wave.me (storage.z-wave.me)|46.20.244.36|:443... connected.
WARNING: The certificate of ‘storage.z-wave.me’ is not trusted.
WARNING: The certificate of ‘storage.z-wave.me’ has expired.
HTTP request sent, awaiting response... 200 OK
Length: 2222 (2.2K) [text/plain]
Saving to: ‘RaspbianInstall’

RaspbianInstall                       100%[===============================================================================>]   2.17K  --.-KB/s    in 0s

2020-05-31 16:31:00 (9.67 MB/s) - ‘RaspbianInstall’ saved [2222/2222]


Дальше пробую запустить

Code: Select all

:~ $ sudo bash RaspbianInstall
Hit:1 http://raspbian.raspberrypi.org/raspbian buster InRelease
Hit:2 http://archive.raspberrypi.org/debian buster InRelease
Ign:3 https://repo.z-wave.me/z-way/raspbian stretch InRelease
Err:4 https://repo.z-wave.me/z-way/raspbian stretch Release
  Certificate verification failed: The certificate is NOT trusted. The certificate chain uses expired certificate.  Could not handshake: Error in the certificate verification. [IP: 185.25.224.239 443]
Reading package lists... Done
E: The repository 'https://repo.z-wave.me/z-way/raspbian stretch Release' does not have a Release file.
N: Updating from such a repository can't be done securely, and is therefore disabled by default.
N: See apt-secure(8) manpage for repository creation and user configuration details.
......
И тут сертификаты не те.

Ладно, пробую сделать репо trusted. Меняю в скрипте строку (не уверен, что этого достаточно, но тут уж вы подскажите, что еще сделать)

Code: Select all

....
echo "deb [trusted=yes] https://repo.z-wave.me/z-way/raspbian $distro main" > /etc/apt/sources.list.d/z-wave-me.list
...
И запускаю

Code: Select all

~ $ sudo bash RaspbianInstall
Hit:1 http://archive.raspberrypi.org/debian buster InRelease
Hit:2 http://raspbian.raspberrypi.org/raspbian buster InRelease
Ign:3 https://repo.z-wave.me/z-way/raspbian buster InRelease
Err:4 https://repo.z-wave.me/z-way/raspbian buster Release
  Certificate verification failed: The certificate is NOT trusted. The certificate chain uses expired certificate.  Could not handshake: Error in the certificate verification. [IP: 185.25.224.239 443]
Reading package lists... Done
E: The repository 'https://repo.z-wave.me/z-way/raspbian buster Release' does not have a Release file.
N: Updating from such a repository can't be done securely, and is therefore disabled by default.
N: See apt-secure(8) manpage for repository creation and user configuration details.
Reading package lists... Done
Building dependency tree
Reading state information... Done
apt-transport-https is already the newest version (1.8.2.1).
dirmngr is already the newest version (2.2.12-1+rpi1+deb10u1).
The following packages were automatically installed and are no longer required:
  libarchive13 libavahi-client-dev libavahi-client3 libavahi-common-dev libavahi-compat-libdnssd-dev libavahi-compat-libdnssd1 libc-ares2 libdbus-1-dev libev4
  libuv1 libwebsockets8 sharutils
Use 'sudo apt autoremove' to remove them.
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
Executing: /tmp/apt-key-gpghome.SGpgLkMyJS/gpg.1.sh --keyserver hkp://keyserver.ubuntu.com:80 --recv-keys 0x7E148E3C
gpg: key 2222290F7E148E3C: "Z-Wave.Me <info@z-wave.me>" not changed
gpg: Total number processed: 1
gpg:              unchanged: 1
Hit:1 http://raspbian.raspberrypi.org/raspbian buster InRelease
Hit:2 http://archive.raspberrypi.org/debian buster InRelease
Ign:3 https://repo.z-wave.me/z-way/raspbian buster InRelease
Ign:4 https://repo.z-wave.me/z-way/raspbian buster Release
Ign:5 https://repo.z-wave.me/z-way/raspbian buster/main all Packages
Ign:6 https://repo.z-wave.me/z-way/raspbian buster/main armhf Packages
Ign:7 https://repo.z-wave.me/z-way/raspbian buster/main Translation-en_GB
Ign:8 https://repo.z-wave.me/z-way/raspbian buster/main Translation-en
Ign:5 https://repo.z-wave.me/z-way/raspbian buster/main all Packages
Ign:6 https://repo.z-wave.me/z-way/raspbian buster/main armhf Packages
Ign:7 https://repo.z-wave.me/z-way/raspbian buster/main Translation-en_GB
Ign:8 https://repo.z-wave.me/z-way/raspbian buster/main Translation-en
Ign:5 https://repo.z-wave.me/z-way/raspbian buster/main all Packages
Ign:6 https://repo.z-wave.me/z-way/raspbian buster/main armhf Packages
Ign:7 https://repo.z-wave.me/z-way/raspbian buster/main Translation-en_GB
Ign:8 https://repo.z-wave.me/z-way/raspbian buster/main Translation-en
Ign:5 https://repo.z-wave.me/z-way/raspbian buster/main all Packages
Ign:6 https://repo.z-wave.me/z-way/raspbian buster/main armhf Packages
Ign:7 https://repo.z-wave.me/z-way/raspbian buster/main Translation-en_GB
Ign:8 https://repo.z-wave.me/z-way/raspbian buster/main Translation-en
Ign:5 https://repo.z-wave.me/z-way/raspbian buster/main all Packages
Ign:6 https://repo.z-wave.me/z-way/raspbian buster/main armhf Packages
Ign:7 https://repo.z-wave.me/z-way/raspbian buster/main Translation-en_GB
Ign:8 https://repo.z-wave.me/z-way/raspbian buster/main Translation-en
Ign:5 https://repo.z-wave.me/z-way/raspbian buster/main all Packages
Ign:6 https://repo.z-wave.me/z-way/raspbian buster/main armhf Packages
Ign:7 https://repo.z-wave.me/z-way/raspbian buster/main Translation-en_GB
Ign:8 https://repo.z-wave.me/z-way/raspbian buster/main Translation-en
Ign:5 https://repo.z-wave.me/z-way/raspbian buster/main all Packages
Err:6 https://repo.z-wave.me/z-way/raspbian buster/main armhf Packages
  Certificate verification failed: The certificate is NOT trusted. The certificate chain uses expired certificate.  Could not handshake: Error in the certificate verification. [IP: 185.25.224.239 443]
Ign:7 https://repo.z-wave.me/z-way/raspbian buster/main Translation-en_GB
Ign:8 https://repo.z-wave.me/z-way/raspbian buster/main Translation-en
Reading package lists... Done
E: Failed to fetch https://repo.z-wave.me/z-way/raspbian/dists/buster/main/binary-armhf/Packages  Certificate verification failed: The certificate is NOT trusted. The certificate chain uses expired certificate.  Could not handshake: Error in the certificate verification. [IP: 185.25.224.239 443]
E: Some index files failed to download. They have been ignored, or old ones used instead.
Reading package lists... Done
Building dependency tree
Reading state information... Done
Package z-way-server is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

E: Unable to locate package z-way-full
E: Package 'z-way-server' has no installation candidate
E: Unable to locate package zbw
E: Unable to locate package webif
dpkg-query: no packages found matching webif
dpkg-query: no packages found matching zbw
В общем как-то так. Прошу помочь понять, что я делаю не так.

User avatar
PoltoS
Posts: 5880
Joined: 26 Jan 2011 19:36

Re: Не установить свежую версию (3.0.6).

Post by PoltoS »

Это глобальная ошибка из-за корневых сертификатов. Появилась 30 мая. Изучаем вопрос, но скорее всего обновление вашей системы уже содержит патч

https://www.opennet.ru/opennews/art.shtml?num=53061
https://news.ycombinator.com/item?id=23362759

wusiko
Posts: 2
Joined: 31 May 2020 16:24

Re: Не установить свежую версию (3.0.6).

Post by wusiko »

Благодарю за ответ. Такие мысли меня посещали. Дождусь патча.

User avatar
PoltoS
Posts: 5880
Joined: 26 Jan 2011 19:36

Re: Не установить свежую версию (3.0.6).

Post by PoltoS »

Готово

Post Reply