Upgrade z-way Server in Docker Container fails

Discussions about RaZberry - Z-Wave board for Raspberry computer
Post Reply
Dumperios
Posts: 19
Joined: 23 Jul 2022 15:34

Upgrade z-way Server in Docker Container fails

Post by Dumperios »

Hello,

after still using z-way-server 3.2.3 I tried to upgrade to the newest z-way-server version, but the new build image doesn't start.

Dockerfile:

Code: Select all

FROM balenalib/rpi-raspbian

WORKDIR /opt/z-way-server

RUN apt-get update && \
    apt-get install -qqy --no-install-recommends \
    ca-certificates curl \
    wget procps gpg iproute2 openssh-client logrotate

RUN wget -q -O - https://storage.z-wave.me/RaspbianInstall | sudo bash

EXPOSE 8083
Docker-Compose:

Code: Select all

version: '3.8'

services:
  z-way:
    container_name: z-way
    build: ./z-way-builder
    image: z-way
    restart: always
    expose:
     - 8083
    ports:
     - 8083:8083
    volumes:
     - z-way-config:/opt/z-way-server/config
     - z-way-automation-storage:/opt/z-way-server/automation/storage
     - z-way-htdocs-smarthome-user:/opt/z-way-server/htdocs/smarthome/user
     - z-way-zddx:/opt/z-way-server/ZDDX
     - z-way-log:/var/log
    devices:
     - '/dev/ttyAMA0:/dev/ttyAMA0'
    networks:
      - app-nw
      - backend-nw
      
volumes:
  z-way-config:
  z-way-automation-storage:
  z-way-htdocs-smarthome-user:
  z-way-zddx:
  z-way-log:
 
networks:
  app-nw:
    internal: false
    driver: bridge
    driver_opts:
      com.docker.network.bridge.name: app-${PROJECT_NAME}
  backend-nw:
    internal: true
    driver: bridge
    driver_opts:
      com.docker.network.bridge.name: be-${PROJECT_NAME}      
I built the image with the this command:
docker-compose build --no-cache z-way

Build-Output:

Code: Select all

root@raspberrypi:/opt/openhab3# docker-compose build --no-cache z-way
Building z-way
Sending build context to Docker daemon  2.048kB
Step 1/6 : FROM balenalib/rpi-raspbian
 ---> 438d2cc59a55
Step 2/6 : WORKDIR /opt/z-way-server
 ---> [Warning] The requested image's platform (linux/arm/v6) does not match the detected host platform (linux/arm64/v8) and no specific platform was requested
 ---> Running in b2b818a06f31
Removing intermediate container b2b818a06f31
 ---> d99dfc0d32e5
Step 3/6 : ENV DEBIAN_FRONTEND=noninteractive
 ---> [Warning] The requested image's platform (linux/arm/v6) does not match the detected host platform (linux/arm64/v8) and no specific platform was requested
 ---> Running in 9d799d2e903c
Removing intermediate container 9d799d2e903c
 ---> 50e7c602d171
Step 4/6 : RUN apt-get update &&     apt-get install -qqy --no-install-recommends     ca-certificates curl     wget procps gpg iproute2 openssh-client logrotate
 ---> [Warning] The requested image's platform (linux/arm/v6) does not match the detected host platform (linux/arm64/v8) and no specific platform was requested
 ---> Running in 1e7b0cc7edf9
Get:1 http://archive.raspberrypi.org/debian bullseye InRelease [23.6 kB]
Get:2 http://archive.raspbian.org/raspbian bullseye InRelease [15.0 kB]
Get:3 http://archive.raspberrypi.org/debian bullseye/main armhf Packages [313 kB]
Get:4 http://archive.raspbian.org/raspbian bullseye/contrib armhf Packages [70.3 kB]
Get:5 http://archive.raspbian.org/raspbian bullseye/rpi armhf Packages [1299 B]
Get:6 http://archive.raspbian.org/raspbian bullseye/firmware armhf Packages [1201 B]
Get:7 http://archive.raspbian.org/raspbian bullseye/main armhf Packages [18.3 MB]
Get:8 http://archive.raspbian.org/raspbian bullseye/non-free armhf Packages [130 kB]
Fetched 18.8 MB in 5s (3654 kB/s)
Reading package lists...
W: Skipping acquire of configured file 'ui/binary-armhf/Packages' as repository 'http://archive.raspberrypi.org/debian bullseye InRelease' doesn't have the component 'ui' (component misspelt in sources.list?)
debconf: delaying package configuration, since apt-utils is not installed
Selecting previously unselected package sensible-utils.
(Reading database ... 7899 files and directories currently installed.)
Preparing to unpack .../sensible-utils_0.0.14_all.deb ...
Unpacking sensible-utils (0.0.14) ...
Selecting previously unselected package cron.
Preparing to unpack .../cron_3.0pl1-137_armhf.deb ...
Unpacking cron (3.0pl1-137) ...
Preparing to unpack .../gnupg-l10n_2.2.27-2+deb11u2_all.deb ...
Unpacking gnupg-l10n (2.2.27-2+deb11u2) over (2.2.27-2+deb11u1) ...
Setting up gnupg-l10n (2.2.27-2+deb11u2) ...
(Reading database ... 7956 files and directories currently installed.)
Preparing to unpack .../gnupg-utils_2.2.27-2+deb11u2_armhf.deb ...
Unpacking gnupg-utils (2.2.27-2+deb11u2) over (2.2.27-2+deb11u1) ...
Setting up gnupg-utils (2.2.27-2+deb11u2) ...
(Reading database ... 7956 files and directories currently installed.)
Preparing to unpack .../gpgconf_2.2.27-2+deb11u2_armhf.deb ...
Unpacking gpgconf (2.2.27-2+deb11u2) over (2.2.27-2+deb11u1) ...
Setting up gpgconf (2.2.27-2+deb11u2) ...
(Reading database ... 7956 files and directories currently installed.)
Preparing to unpack .../dirmngr_2.2.27-2+deb11u2_armhf.deb ...
Unpacking dirmngr (2.2.27-2+deb11u2) over (2.2.27-2+deb11u1) ...
Setting up dirmngr (2.2.27-2+deb11u2) ...
(Reading database ... 7956 files and directories currently installed.)
Preparing to unpack .../gpg_2.2.27-2+deb11u2_armhf.deb ...
Unpacking gpg (2.2.27-2+deb11u2) over (2.2.27-2+deb11u1) ...
Setting up gpg (2.2.27-2+deb11u2) ...
(Reading database ... 7956 files and directories currently installed.)
Preparing to unpack .../gpg-agent_2.2.27-2+deb11u2_armhf.deb ...
Unpacking gpg-agent (2.2.27-2+deb11u2) over (2.2.27-2+deb11u1) ...
Setting up gpg-agent (2.2.27-2+deb11u2) ...
(Reading database ... 7956 files and directories currently installed.)
Preparing to unpack .../gpg-wks-client_2.2.27-2+deb11u2_armhf.deb ...
Unpacking gpg-wks-client (2.2.27-2+deb11u2) over (2.2.27-2+deb11u1) ...
Setting up gpg-wks-client (2.2.27-2+deb11u2) ...
(Reading database ... 7956 files and directories currently installed.)
Preparing to unpack .../gpg-wks-server_2.2.27-2+deb11u2_armhf.deb ...
Unpacking gpg-wks-server (2.2.27-2+deb11u2) over (2.2.27-2+deb11u1) ...
Setting up gpg-wks-server (2.2.27-2+deb11u2) ...
(Reading database ... 7956 files and directories currently installed.)
Preparing to unpack .../gpgv_2.2.27-2+deb11u2_armhf.deb ...
Unpacking gpgv (2.2.27-2+deb11u2) over (2.2.27-2+deb11u1) ...
Setting up gpgv (2.2.27-2+deb11u2) ...
(Reading database ... 7956 files and directories currently installed.)
Preparing to unpack .../gpgsm_2.2.27-2+deb11u2_armhf.deb ...
Unpacking gpgsm (2.2.27-2+deb11u2) over (2.2.27-2+deb11u1) ...
Setting up gpgsm (2.2.27-2+deb11u2) ...
(Reading database ... 7956 files and directories currently installed.)
Preparing to unpack .../gnupg_2.2.27-2+deb11u2_all.deb ...
Unpacking gnupg (2.2.27-2+deb11u2) over (2.2.27-2+deb11u1) ...
Setting up gnupg (2.2.27-2+deb11u2) ...
Selecting previously unselected package libelf1:armhf.
(Reading database ... 7956 files and directories currently installed.)
Preparing to unpack .../00-libelf1_0.183-1_armhf.deb ...
Unpacking libelf1:armhf (0.183-1) ...
Selecting previously unselected package libbpf0:armhf.
Preparing to unpack .../01-libbpf0_1%3a0.3-2+rpi1_armhf.deb ...
Unpacking libbpf0:armhf (1:0.3-2+rpi1) ...
Selecting previously unselected package libmd0:armhf.
Preparing to unpack .../02-libmd0_1.0.3-3_armhf.deb ...
Unpacking libmd0:armhf (1.0.3-3) ...
Selecting previously unselected package libbsd0:armhf.
Preparing to unpack .../03-libbsd0_0.11.3-1+deb11u1_armhf.deb ...
Unpacking libbsd0:armhf (0.11.3-1+deb11u1) ...
Selecting previously unselected package libcap2:armhf.
Preparing to unpack .../04-libcap2_1%3a2.44-1_armhf.deb ...
Unpacking libcap2:armhf (1:2.44-1) ...
Selecting previously unselected package libmnl0:armhf.
Preparing to unpack .../05-libmnl0_1.0.4-3_armhf.deb ...
Unpacking libmnl0:armhf (1.0.4-3) ...
Selecting previously unselected package libxtables12:armhf.
Preparing to unpack .../06-libxtables12_1.8.7-1_armhf.deb ...
Unpacking libxtables12:armhf (1.8.7-1) ...
Selecting previously unselected package libcap2-bin.
Preparing to unpack .../07-libcap2-bin_1%3a2.44-1_armhf.deb ...
Unpacking libcap2-bin (1:2.44-1) ...
Selecting previously unselected package iproute2.
Preparing to unpack .../08-iproute2_5.10.0-4_armhf.deb ...
Unpacking iproute2 (5.10.0-4) ...
Selecting previously unselected package libpopt0:armhf.
Preparing to unpack .../09-libpopt0_1.18-2_armhf.deb ...
Unpacking libpopt0:armhf (1.18-2) ...
Selecting previously unselected package logrotate.
Preparing to unpack .../10-logrotate_3.18.0-2+deb11u2_armhf.deb ...
Unpacking logrotate (3.18.0-2+deb11u2) ...
Selecting previously unselected package libedit2:armhf.
Preparing to unpack .../11-libedit2_3.1-20191231-2_armhf.deb ...
Unpacking libedit2:armhf (3.1-20191231-2) ...
Selecting previously unselected package libcbor0:armhf.
Preparing to unpack .../12-libcbor0_0.5.0+dfsg-2_armhf.deb ...
Unpacking libcbor0:armhf (0.5.0+dfsg-2) ...
Selecting previously unselected package libfido2-1:armhf.
Preparing to unpack .../13-libfido2-1_1.6.0-2_armhf.deb ...
Unpacking libfido2-1:armhf (1.6.0-2) ...
Selecting previously unselected package openssh-client.
Preparing to unpack .../14-openssh-client_1%3a8.4p1-5+deb11u3_armhf.deb ...
Unpacking openssh-client (1:8.4p1-5+deb11u3) ...
Selecting previously unselected package wget.
Preparing to unpack .../15-wget_1.21-1+deb11u1_armhf.deb ...
Unpacking wget (1.21-1+deb11u1) ...
Preparing to unpack .../16-curl_7.74.0-1.3+deb11u11_armhf.deb ...
Unpacking curl (7.74.0-1.3+deb11u11) over (7.74.0-1.3+deb11u1) ...
Preparing to unpack .../17-libcurl4_7.74.0-1.3+deb11u11_armhf.deb ...
Unpacking libcurl4:armhf (7.74.0-1.3+deb11u11) over (7.74.0-1.3+deb11u1) ...
Setting up wget (1.21-1+deb11u1) ...
Setting up libcbor0:armhf (0.5.0+dfsg-2) ...
Setting up libcap2:armhf (1:2.44-1) ...
Setting up libcap2-bin (1:2.44-1) ...
Setting up libmnl0:armhf (1.0.4-3) ...
Setting up libxtables12:armhf (1.8.7-1) ...
Setting up libmd0:armhf (1.0.3-3) ...
Setting up sensible-utils (0.0.14) ...
Setting up libcurl4:armhf (7.74.0-1.3+deb11u11) ...
Setting up curl (7.74.0-1.3+deb11u11) ...
Setting up libfido2-1:armhf (1.6.0-2) ...
Setting up libbsd0:armhf (0.11.3-1+deb11u1) ...
Setting up libelf1:armhf (0.183-1) ...
Setting up libpopt0:armhf (1.18-2) ...
Setting up libedit2:armhf (3.1-20191231-2) ...
Setting up cron (3.0pl1-137) ...
Adding group `crontab' (GID 104) ...
Done.
invoke-rc.d: could not determine current runlevel
invoke-rc.d: policy-rc.d denied execution of start.
Setting up libbpf0:armhf (1:0.3-2+rpi1) ...
Setting up logrotate (3.18.0-2+deb11u2) ...
Setting up iproute2 (5.10.0-4) ...
Setting up openssh-client (1:8.4p1-5+deb11u3) ...
Processing triggers for libc-bin (2.31-13+rpi1+deb11u3) ...
Removing intermediate container 1e7b0cc7edf9
 ---> 3b60b253935e
Step 5/6 : RUN wget -q -O - https://storage.z-wave.me/RaspbianInstall | sudo bash
 ---> [Warning] The requested image's platform (linux/arm/v6) does not match the detected host platform (linux/arm64/v8) and no specific platform was requested
 ---> Running in 98d49d16256a
Hit:1 http://archive.raspbian.org/raspbian bullseye InRelease
Hit:2 http://archive.raspberrypi.org/debian bullseye InRelease
Reading package lists...
W: Skipping acquire of configured file 'ui/binary-armhf/Packages' as repository 'http://archive.raspberrypi.org/debian bullseye InRelease' doesn't have the component 'ui' (component misspelt in sources.list?)
Reading package lists...
Building dependency tree...
Reading state information...
dirmngr is already the newest version (2.2.27-2+deb11u2).
gnupg is already the newest version (2.2.27-2+deb11u2).
wget is already the newest version (1.21-1+deb11u1).
The following NEW packages will be installed:
  apt-transport-https
0 upgraded, 1 newly installed, 0 to remove and 38 not upgraded.
Need to get 160 kB of archives.
After this operation, 166 kB of additional disk space will be used.
Get:1 http://archive.raspbian.org/raspbian bullseye/main armhf apt-transport-https all 2.2.4 [160 kB]
debconf: delaying package configuration, since apt-utils is not installed
Fetched 160 kB in 0s (1068 kB/s)
Selecting previously unselected package apt-transport-https.
(Reading database ... 8413 files and directories currently installed.)
Preparing to unpack .../apt-transport-https_2.2.4_all.deb ...
Unpacking apt-transport-https (2.2.4) ...
Setting up apt-transport-https (2.2.4) ...
Warning: apt-key is deprecated. Manage keyring files in trusted.gpg.d instead (see apt-key(8)).
Executing: /tmp/apt-key-gpghome.7YzU3NDM8B/gpg.1.sh --keyserver hkp://keyserver.ubuntu.com:80 --recv-keys 5b2f88a91611e683
gpg: key 5B2F88A91611E683: public key "Z-Wave.Me <info@z-wave.me>" imported
gpg: Total number processed: 1
gpg:               imported: 1
Hit:1 http://archive.raspberrypi.org/debian bullseye InRelease
Hit:2 http://archive.raspbian.org/raspbian bullseye InRelease
Get:3 https://repo.z-wave.me/z-way/raspbian bullseye InRelease [1808 B]
Get:4 https://repo.z-wave.me/z-way/raspbian bullseye/main armhf Packages [1337 B]
Fetched 3145 B in 1s (4079 B/s)
Reading package lists...
W: Skipping acquire of configured file 'ui/binary-armhf/Packages' as repository 'http://archive.raspberrypi.org/debian bullseye InRelease' doesn't have the component 'ui' (component misspelt in sources.list?)
Reading package lists...
Building dependency tree...
Reading state information...
The following additional packages will be installed:
  avahi-daemon bind9-host bind9-libs dbus gawk libapparmor1 libarchive13
  libatomic1 libavahi-client-dev libavahi-client3 libavahi-common-data
  libavahi-common-dev libavahi-common3 libavahi-compat-libdnssd-dev
  libavahi-compat-libdnssd1 libavahi-core7 libc-ares2 libcurl3-gnutls
  libdaemon0 libdbus-1-3 libdbus-1-dev libdpkg-perl libev4 libexpat1 libfstrm0
  libgdbm-compat4 libgdbm6 libglib2.0-0 libicu67 libjson-c5 liblmdb0
  libmaxminddb0 libmosquitto1 libmpfr6 libnss-mdns libperl5.32 libprotobuf-c1
  libsigsegv2 libuv1 libwebsockets16 libxml2 net-tools perl perl-modules-5.32
  pkg-config sharutils
Suggested packages:
  avahi-autoipd default-dbus-session-bus | dbus-session-bus gawk-doc lrzip
  debian-keyring gcc | c-compiler binutils patch git bzr gdbm-l10n mmdb-bin
  avahi-autoipd | zeroconf perl-doc libterm-readline-gnu-perl
  | libterm-readline-perl-perl make libtap-harness-archive-perl dpkg-dev
  sharutils-doc bsd-mailx | mailx
Recommended packages:
  libfile-fcntllock-perl bzip2 xz-utils libglib2.0-data shared-mime-info
  xdg-user-dirs
The following NEW packages will be installed:
  avahi-daemon bind9-host bind9-libs dbus gawk libapparmor1 libarchive13
  libatomic1 libavahi-client-dev libavahi-client3 libavahi-common-data
  libavahi-common-dev libavahi-common3 libavahi-compat-libdnssd-dev
  libavahi-compat-libdnssd1 libavahi-core7 libc-ares2 libcurl3-gnutls
  libdaemon0 libdbus-1-3 libdbus-1-dev libdpkg-perl libev4 libexpat1 libfstrm0
  libgdbm-compat4 libgdbm6 libglib2.0-0 libicu67 libjson-c5 liblmdb0
  libmaxminddb0 libmosquitto1 libmpfr6 libnss-mdns libperl5.32 libprotobuf-c1
  libsigsegv2 libuv1 libwebsockets16 libxml2 net-tools perl perl-modules-5.32
  pkg-config sharutils webif z-way-full z-way-server zbw
0 upgraded, 50 newly installed, 0 to remove and 38 not upgraded.
Need to get 65.0 MB of archives.
After this operation, 99.5 MB of additional disk space will be used.
Get:1 http://archive.raspbian.org/raspbian bullseye/main armhf libapparmor1 armhf 2.13.6-10 [94.9 kB]
Get:2 http://archive.raspbian.org/raspbian bullseye/main armhf libdbus-1-3 armhf 1.12.28-0+deb11u1 [198 kB]
Get:3 http://archive.raspbian.org/raspbian bullseye/main armhf libexpat1 armhf 2.2.10-2+deb11u5 [75.0 kB]
Get:4 https://repo.z-wave.me/z-way/raspbian bullseye/main armhf z-way-server armhf 4.1.2-wb1-lws16 [40.2 MB]
Get:5 http://archive.raspbian.org/raspbian bullseye/main armhf dbus armhf 1.12.28-0+deb11u1 [220 kB]
Get:6 http://archive.raspbian.org/raspbian bullseye/main armhf perl-modules-5.32 all 5.32.1-4+deb11u2 [2823 kB]
Get:7 http://archive.raspbian.org/raspbian bullseye/main armhf libgdbm6 armhf 1.19-2 [61.7 kB]
Get:8 http://archive.raspbian.org/raspbian bullseye/main armhf libgdbm-compat4 armhf 1.19-2 [44.5 kB]
Get:9 http://archive.raspbian.org/raspbian bullseye/main armhf libperl5.32 armhf 5.32.1-4+deb11u2 [3373 kB]
Get:10 http://archive.raspbian.org/raspbian bullseye/main armhf perl armhf 5.32.1-4+deb11u2 [293 kB]
Get:11 http://archive.raspbian.org/raspbian bullseye/main armhf libavahi-common-data armhf 0.8-5+deb11u2 [124 kB]
Get:12 http://archive.raspbian.org/raspbian bullseye/main armhf libavahi-common3 armhf 0.8-5+deb11u2 [55.7 kB]
Get:13 http://archive.raspbian.org/raspbian bullseye/main armhf libavahi-core7 armhf 0.8-5+deb11u2 [107 kB]
Get:14 http://archive.raspbian.org/raspbian bullseye/main armhf libdaemon0 armhf 0.14-7.1 [13.4 kB]
Get:15 http://archive.raspbian.org/raspbian bullseye/main armhf libuv1 armhf 1.40.0-2 [119 kB]
Get:16 http://archive.raspbian.org/raspbian bullseye/main armhf libatomic1 armhf 10.2.1-6+rpi1 [8212 B]
Get:17 http://archive.raspbian.org/raspbian bullseye/main armhf libfstrm0 armhf 0.6.0-1+b1 [18.1 kB]
Get:18 http://archive.raspbian.org/raspbian bullseye/main armhf libjson-c5 armhf 0.15-2+deb11u1 [38.8 kB]
Get:19 http://archive.raspbian.org/raspbian bullseye/main armhf liblmdb0 armhf 0.9.24-1 [38.7 kB]
Get:20 http://archive.raspbian.org/raspbian bullseye/main armhf libmaxminddb0 armhf 1.5.2-1 [28.3 kB]
Get:21 http://archive.raspbian.org/raspbian bullseye/main armhf libprotobuf-c1 armhf 1.3.3-1+b2 [24.8 kB]
Get:22 http://archive.raspbian.org/raspbian bullseye/main armhf libicu67 armhf 67.1-7 [8291 kB]
Get:23 http://archive.raspbian.org/raspbian bullseye/main armhf libxml2 armhf 2.9.10+dfsg-6.7+deb11u4 [581 kB]
Get:24 http://archive.raspbian.org/raspbian bullseye/main armhf bind9-libs armhf 1:9.16.44-1~deb11u1 [1279 kB]
Get:25 http://archive.raspbian.org/raspbian bullseye/main armhf bind9-host armhf 1:9.16.44-1~deb11u1 [309 kB]
Get:26 http://archive.raspbian.org/raspbian bullseye/main armhf avahi-daemon armhf 0.8-5+deb11u2 [91.2 kB]
Get:27 http://archive.raspbian.org/raspbian bullseye/main armhf libmpfr6 armhf 4.1.0-3 [803 kB]
Get:28 http://archive.raspbian.org/raspbian bullseye/main armhf libsigsegv2 armhf 2.13-1 [34.3 kB]
Get:29 http://archive.raspbian.org/raspbian bullseye/main armhf gawk armhf 1:5.1.0-1 [533 kB]
Get:30 http://archive.raspbian.org/raspbian bullseye/main armhf net-tools armhf 1.60+git20181103.0eebece-1 [223 kB]
Get:31 http://archive.raspbian.org/raspbian bullseye/main armhf libarchive13 armhf 3.4.3-2+deb11u1 [297 kB]
Get:32 http://archive.raspbian.org/raspbian bullseye/main armhf libavahi-client3 armhf 0.8-5+deb11u2 [58.3 kB]
Get:33 http://archive.raspbian.org/raspbian bullseye/main armhf libavahi-common-dev armhf 0.8-5+deb11u2 [69.5 kB]
Get:34 http://archive.raspbian.org/raspbian bullseye/main armhf libglib2.0-0 armhf 2.66.8-1 [1183 kB]
Get:35 http://archive.raspbian.org/raspbian bullseye/main armhf libdpkg-perl all 1.20.12+rpi1 [1551 kB]
Get:36 http://archive.raspbian.org/raspbian bullseye/main armhf pkg-config armhf 0.29.2-1 [61.5 kB]
Get:37 http://archive.raspbian.org/raspbian bullseye/main armhf libdbus-1-dev armhf 1.12.28-0+deb11u1 [229 kB]
Get:38 http://archive.raspbian.org/raspbian bullseye/main armhf libavahi-client-dev armhf 0.8-5+deb11u2 [66.3 kB]
Get:39 http://archive.raspbian.org/raspbian bullseye/main armhf libavahi-compat-libdnssd1 armhf 0.8-5+deb11u2 [50.9 kB]
Get:40 http://archive.raspbian.org/raspbian bullseye/main armhf libavahi-compat-libdnssd-dev armhf 0.8-5+deb11u2 [65.5 kB]
Get:41 http://archive.raspbian.org/raspbian bullseye/main armhf libc-ares2 armhf 1.17.1-1+deb11u3 [96.3 kB]
Get:42 http://archive.raspbian.org/raspbian bullseye/main armhf libcurl3-gnutls armhf 7.74.0-1.3+deb11u11 [306 kB]
Get:43 http://archive.raspbian.org/raspbian bullseye/main armhf libev4 armhf 1:4.33-1 [38.2 kB]
Get:44 http://archive.raspbian.org/raspbian bullseye/main armhf libmosquitto1 armhf 2.0.11-1+deb11u1 [83.9 kB]
Get:45 http://archive.raspbian.org/raspbian bullseye/main armhf libnss-mdns armhf 0.14.1-2 [25.2 kB]
Get:46 http://archive.raspbian.org/raspbian bullseye/main armhf libwebsockets16 armhf 4.0.20-2 [161 kB]
Get:47 http://archive.raspbian.org/raspbian bullseye/main armhf sharutils armhf 1:4.15.2-5 [236 kB]
Get:48 https://repo.z-wave.me/z-way/raspbian bullseye/main armhf webif armhf 1.5 [308 kB]
Get:49 https://repo.z-wave.me/z-way/raspbian bullseye/main armhf zbw armhf 2.6 [4272 B]
Get:50 https://repo.z-wave.me/z-way/raspbian bullseye/main armhf z-way-full armhf 1.0-latest-version [884 B]
debconf: delaying package configuration, since apt-utils is not installed
Fetched 65.0 MB in 9s (6978 kB/s)
Selecting previously unselected package libapparmor1:armhf.
(Reading database ... 8417 files and directories currently installed.)
Preparing to unpack .../00-libapparmor1_2.13.6-10_armhf.deb ...
Unpacking libapparmor1:armhf (2.13.6-10) ...
Selecting previously unselected package libdbus-1-3:armhf.
Preparing to unpack .../01-libdbus-1-3_1.12.28-0+deb11u1_armhf.deb ...
Unpacking libdbus-1-3:armhf (1.12.28-0+deb11u1) ...
Selecting previously unselected package libexpat1:armhf.
Preparing to unpack .../02-libexpat1_2.2.10-2+deb11u5_armhf.deb ...
Unpacking libexpat1:armhf (2.2.10-2+deb11u5) ...
Selecting previously unselected package dbus.
Preparing to unpack .../03-dbus_1.12.28-0+deb11u1_armhf.deb ...
Unpacking dbus (1.12.28-0+deb11u1) ...
Selecting previously unselected package perl-modules-5.32.
Preparing to unpack .../04-perl-modules-5.32_5.32.1-4+deb11u2_all.deb ...
Unpacking perl-modules-5.32 (5.32.1-4+deb11u2) ...
Selecting previously unselected package libgdbm6:armhf.
Preparing to unpack .../05-libgdbm6_1.19-2_armhf.deb ...
Unpacking libgdbm6:armhf (1.19-2) ...
Selecting previously unselected package libgdbm-compat4:armhf.
Preparing to unpack .../06-libgdbm-compat4_1.19-2_armhf.deb ...
Unpacking libgdbm-compat4:armhf (1.19-2) ...
Selecting previously unselected package libperl5.32:armhf.
Preparing to unpack .../07-libperl5.32_5.32.1-4+deb11u2_armhf.deb ...
Unpacking libperl5.32:armhf (5.32.1-4+deb11u2) ...
Selecting previously unselected package perl.
Preparing to unpack .../08-perl_5.32.1-4+deb11u2_armhf.deb ...
Unpacking perl (5.32.1-4+deb11u2) ...
Selecting previously unselected package libavahi-common-data:armhf.
Preparing to unpack .../09-libavahi-common-data_0.8-5+deb11u2_armhf.deb ...
Unpacking libavahi-common-data:armhf (0.8-5+deb11u2) ...
Selecting previously unselected package libavahi-common3:armhf.
Preparing to unpack .../10-libavahi-common3_0.8-5+deb11u2_armhf.deb ...
Unpacking libavahi-common3:armhf (0.8-5+deb11u2) ...
Selecting previously unselected package libavahi-core7:armhf.
Preparing to unpack .../11-libavahi-core7_0.8-5+deb11u2_armhf.deb ...
Unpacking libavahi-core7:armhf (0.8-5+deb11u2) ...
Selecting previously unselected package libdaemon0:armhf.
Preparing to unpack .../12-libdaemon0_0.14-7.1_armhf.deb ...
Unpacking libdaemon0:armhf (0.14-7.1) ...
Selecting previously unselected package libuv1:armhf.
Preparing to unpack .../13-libuv1_1.40.0-2_armhf.deb ...
Unpacking libuv1:armhf (1.40.0-2) ...
Selecting previously unselected package libatomic1:armhf.
Preparing to unpack .../14-libatomic1_10.2.1-6+rpi1_armhf.deb ...
Unpacking libatomic1:armhf (10.2.1-6+rpi1) ...
Selecting previously unselected package libfstrm0:armhf.
Preparing to unpack .../15-libfstrm0_0.6.0-1+b1_armhf.deb ...
Unpacking libfstrm0:armhf (0.6.0-1+b1) ...
Selecting previously unselected package libjson-c5:armhf.
Preparing to unpack .../16-libjson-c5_0.15-2+deb11u1_armhf.deb ...
Unpacking libjson-c5:armhf (0.15-2+deb11u1) ...
Selecting previously unselected package liblmdb0:armhf.
Preparing to unpack .../17-liblmdb0_0.9.24-1_armhf.deb ...
Unpacking liblmdb0:armhf (0.9.24-1) ...
Selecting previously unselected package libmaxminddb0:armhf.
Preparing to unpack .../18-libmaxminddb0_1.5.2-1_armhf.deb ...
Unpacking libmaxminddb0:armhf (1.5.2-1) ...
Selecting previously unselected package libprotobuf-c1:armhf.
Preparing to unpack .../19-libprotobuf-c1_1.3.3-1+b2_armhf.deb ...
Unpacking libprotobuf-c1:armhf (1.3.3-1+b2) ...
Selecting previously unselected package libicu67:armhf.
Preparing to unpack .../20-libicu67_67.1-7_armhf.deb ...
Unpacking libicu67:armhf (67.1-7) ...
Selecting previously unselected package libxml2:armhf.
Preparing to unpack .../21-libxml2_2.9.10+dfsg-6.7+deb11u4_armhf.deb ...
Unpacking libxml2:armhf (2.9.10+dfsg-6.7+deb11u4) ...
Selecting previously unselected package bind9-libs:armhf.
Preparing to unpack .../22-bind9-libs_1%3a9.16.44-1~deb11u1_armhf.deb ...
Unpacking bind9-libs:armhf (1:9.16.44-1~deb11u1) ...
Selecting previously unselected package bind9-host.
Preparing to unpack .../23-bind9-host_1%3a9.16.44-1~deb11u1_armhf.deb ...
Unpacking bind9-host (1:9.16.44-1~deb11u1) ...
Selecting previously unselected package avahi-daemon.
Preparing to unpack .../24-avahi-daemon_0.8-5+deb11u2_armhf.deb ...
Unpacking avahi-daemon (0.8-5+deb11u2) ...
Selecting previously unselected package libmpfr6:armhf.
Preparing to unpack .../25-libmpfr6_4.1.0-3_armhf.deb ...
Unpacking libmpfr6:armhf (4.1.0-3) ...
Selecting previously unselected package libsigsegv2:armhf.
Preparing to unpack .../26-libsigsegv2_2.13-1_armhf.deb ...
Unpacking libsigsegv2:armhf (2.13-1) ...
Setting up libmpfr6:armhf (4.1.0-3) ...
Setting up libsigsegv2:armhf (2.13-1) ...
Selecting previously unselected package gawk.
(Reading database ... 10684 files and directories currently installed.)
Preparing to unpack .../00-gawk_1%3a5.1.0-1_armhf.deb ...
Unpacking gawk (1:5.1.0-1) ...
Selecting previously unselected package net-tools.
Preparing to unpack .../01-net-tools_1.60+git20181103.0eebece-1_armhf.deb ...
Unpacking net-tools (1.60+git20181103.0eebece-1) ...
Selecting previously unselected package libarchive13:armhf.
Preparing to unpack .../02-libarchive13_3.4.3-2+deb11u1_armhf.deb ...
Unpacking libarchive13:armhf (3.4.3-2+deb11u1) ...
Selecting previously unselected package libavahi-client3:armhf.
Preparing to unpack .../03-libavahi-client3_0.8-5+deb11u2_armhf.deb ...
Unpacking libavahi-client3:armhf (0.8-5+deb11u2) ...
Selecting previously unselected package libavahi-common-dev:armhf.
Preparing to unpack .../04-libavahi-common-dev_0.8-5+deb11u2_armhf.deb ...
Unpacking libavahi-common-dev:armhf (0.8-5+deb11u2) ...
Selecting previously unselected package libglib2.0-0:armhf.
Preparing to unpack .../05-libglib2.0-0_2.66.8-1_armhf.deb ...
Unpacking libglib2.0-0:armhf (2.66.8-1) ...
Selecting previously unselected package libdpkg-perl.
Preparing to unpack .../06-libdpkg-perl_1.20.12+rpi1_all.deb ...
Unpacking libdpkg-perl (1.20.12+rpi1) ...
Selecting previously unselected package pkg-config.
Preparing to unpack .../07-pkg-config_0.29.2-1_armhf.deb ...
Unpacking pkg-config (0.29.2-1) ...
Selecting previously unselected package libdbus-1-dev:armhf.
Preparing to unpack .../08-libdbus-1-dev_1.12.28-0+deb11u1_armhf.deb ...
Unpacking libdbus-1-dev:armhf (1.12.28-0+deb11u1) ...
Selecting previously unselected package libavahi-client-dev:armhf.
Preparing to unpack .../09-libavahi-client-dev_0.8-5+deb11u2_armhf.deb ...
Unpacking libavahi-client-dev:armhf (0.8-5+deb11u2) ...
Selecting previously unselected package libavahi-compat-libdnssd1:armhf.
Preparing to unpack .../10-libavahi-compat-libdnssd1_0.8-5+deb11u2_armhf.deb ...
Unpacking libavahi-compat-libdnssd1:armhf (0.8-5+deb11u2) ...
Selecting previously unselected package libavahi-compat-libdnssd-dev:armhf.
Preparing to unpack .../11-libavahi-compat-libdnssd-dev_0.8-5+deb11u2_armhf.deb ...
Unpacking libavahi-compat-libdnssd-dev:armhf (0.8-5+deb11u2) ...
Selecting previously unselected package libc-ares2:armhf.
Preparing to unpack .../12-libc-ares2_1.17.1-1+deb11u3_armhf.deb ...
Unpacking libc-ares2:armhf (1.17.1-1+deb11u3) ...
Selecting previously unselected package libcurl3-gnutls:armhf.
Preparing to unpack .../13-libcurl3-gnutls_7.74.0-1.3+deb11u11_armhf.deb ...
Unpacking libcurl3-gnutls:armhf (7.74.0-1.3+deb11u11) ...
Selecting previously unselected package libev4:armhf.
Preparing to unpack .../14-libev4_1%3a4.33-1_armhf.deb ...
Unpacking libev4:armhf (1:4.33-1) ...
Selecting previously unselected package libmosquitto1:armhf.
Preparing to unpack .../15-libmosquitto1_2.0.11-1+deb11u1_armhf.deb ...
Unpacking libmosquitto1:armhf (2.0.11-1+deb11u1) ...
Selecting previously unselected package libnss-mdns:armhf.
Preparing to unpack .../16-libnss-mdns_0.14.1-2_armhf.deb ...
Unpacking libnss-mdns:armhf (0.14.1-2) ...
Selecting previously unselected package libwebsockets16:armhf.
Preparing to unpack .../17-libwebsockets16_4.0.20-2_armhf.deb ...
Unpacking libwebsockets16:armhf (4.0.20-2) ...
Selecting previously unselected package sharutils.
Preparing to unpack .../18-sharutils_1%3a4.15.2-5_armhf.deb ...
Unpacking sharutils (1:4.15.2-5) ...
Selecting previously unselected package z-way-server.
Preparing to unpack .../19-z-way-server_4.1.2-wb1-lws16_armhf.deb ...
Unpacking z-way-server (4.1.2-wb1-lws16) ...
Selecting previously unselected package webif.
Preparing to unpack .../20-webif_1.5_armhf.deb ...
Unpacking webif (1.5) ...
Selecting previously unselected package zbw.
Preparing to unpack .../21-zbw_2.6_armhf.deb ...
Unpacking zbw (2.6) ...
Selecting previously unselected package z-way-full.
Preparing to unpack .../22-z-way-full_1.0-latest-version_armhf.deb ...
Unpacking z-way-full (1.0-latest-version) ...
Setting up libexpat1:armhf (2.2.10-2+deb11u5) ...
Setting up liblmdb0:armhf (0.9.24-1) ...
Setting up net-tools (1.60+git20181103.0eebece-1) ...
Setting up libapparmor1:armhf (2.13.6-10) ...
Setting up libicu67:armhf (67.1-7) ...
Setting up gawk (1:5.1.0-1) ...
Setting up libglib2.0-0:armhf (2.66.8-1) ...
No schema files found: doing nothing.
Setting up libmosquitto1:armhf (2.0.11-1+deb11u1) ...
Setting up libmaxminddb0:armhf (1.5.2-1) ...
Setting up libev4:armhf (1:4.33-1) ...
Setting up perl-modules-5.32 (5.32.1-4+deb11u2) ...
Setting up libfstrm0:armhf (0.6.0-1+b1) ...
Setting up libcurl3-gnutls:armhf (7.74.0-1.3+deb11u11) ...
Setting up libc-ares2:armhf (1.17.1-1+deb11u3) ...
Setting up libprotobuf-c1:armhf (1.3.3-1+b2) ...
Setting up libuv1:armhf (1.40.0-2) ...
Setting up libavahi-common-data:armhf (0.8-5+deb11u2) ...
Setting up libdbus-1-3:armhf (1.12.28-0+deb11u1) ...
Setting up dbus (1.12.28-0+deb11u1) ...
invoke-rc.d: could not determine current runlevel
invoke-rc.d: policy-rc.d denied execution of start.
Setting up libatomic1:armhf (10.2.1-6+rpi1) ...
Setting up sharutils (1:4.15.2-5) ...
Setting up libdaemon0:armhf (0.14-7.1) ...
Setting up libjson-c5:armhf (0.15-2+deb11u1) ...
Setting up libxml2:armhf (2.9.10+dfsg-6.7+deb11u4) ...
Setting up libgdbm6:armhf (1.19-2) ...
Setting up libwebsockets16:armhf (4.0.20-2) ...
Setting up bind9-libs:armhf (1:9.16.44-1~deb11u1) ...
Setting up libarchive13:armhf (3.4.3-2+deb11u1) ...
Setting up libavahi-common3:armhf (0.8-5+deb11u2) ...
Setting up libgdbm-compat4:armhf (1.19-2) ...
Setting up libperl5.32:armhf (5.32.1-4+deb11u2) ...
Setting up zbw (2.6) ...
Starting zbw_connect:A private key isn't found. Fetching...
--2024-01-06 18:17:43--  https://find.z-wave.me/zbw_new_user2?box_type=deb
Resolving find.z-wave.me (find.z-wave.me)... 185.25.224.111, 185.25.224.206, 194.190.114.100, ...
Connecting to find.z-wave.me (find.z-wave.me)|185.25.224.111|:443... connected.
HTTP request sent, awaiting response... 200 OK
Length: unspecified [application/octet-stream]
Saving to: ‘/etc/zbw/new.user’

/etc/zbw/new.user       [ <=>                ]   1.70K  --.-KB/s    in 0s

2024-01-06 18:17:43 (17.7 MB/s) - ‘/etc/zbw/new.user’ saved [1738]

ok.
Setting up libavahi-common-dev:armhf (0.8-5+deb11u2) ...
Setting up libavahi-core7:armhf (0.8-5+deb11u2) ...
Setting up bind9-host (1:9.16.44-1~deb11u1) ...
Setting up libavahi-client3:armhf (0.8-5+deb11u2) ...
Setting up libavahi-compat-libdnssd1:armhf (0.8-5+deb11u2) ...
Setting up perl (5.32.1-4+deb11u2) ...
Setting up libdpkg-perl (1.20.12+rpi1) ...
Setting up avahi-daemon (0.8-5+deb11u2) ...
invoke-rc.d: could not determine current runlevel
invoke-rc.d: policy-rc.d denied execution of force-reload.
invoke-rc.d: could not determine current runlevel
invoke-rc.d: policy-rc.d denied execution of start.
Setting up libnss-mdns:armhf (0.14.1-2) ...
First installation detected...
Checking NSS setup...
Setting up pkg-config (0.29.2-1) ...
Setting up libdbus-1-dev:armhf (1.12.28-0+deb11u1) ...
Setting up libavahi-client-dev:armhf (0.8-5+deb11u2) ...
Setting up libavahi-compat-libdnssd-dev:armhf (0.8-5+deb11u2) ...
Setting up z-way-server (4.1.2-wb1-lws16) ...
Setting default automation config
Raspberry Pi 4B Detected. Setting up miniUART for Bluetooth
grep: /boot/config.txt: No such file or directory
Adding 'dtoverlay=pi3-miniuart-bt' to /boot/config.txt
Starting z-way-server: done.
Setting up webif (1.5) ...
Setting up z-way-full (1.0-latest-version) ...
Processing triggers for libc-bin (2.31-13+rpi1+deb11u3) ...
Processing triggers for dbus (1.12.28-0+deb11u1) ...
Removing intermediate container 98d49d16256a
 ---> 2c0976083851
Step 6/6 : EXPOSE 8083
 ---> [Warning] The requested image's platform (linux/arm/v6) does not match the detected host platform (linux/arm64/v8) and no specific platform was requested
 ---> Running in 04a15dad2b2e
Removing intermediate container 04a15dad2b2e
 ---> 36832fe25af6
Successfully built 36832fe25af6
Successfully tagged z-way:latest
I started z-way-server:
docker-compose up z-way

Docker PS shows that the Process is permanent restarting and docker logs shows nothing:

Code: Select all

root@raspberrypi:/opt/openhab3# docker ps
CONTAINER ID   IMAGE     COMMAND                  CREATED         STATUS                  PORTS                                       NAMES
f32e420c6c00   z-way     "/usr/bin/entry.sh /…"   6 seconds ago   Up Less than a second   0.0.0.0:8083->8083/tcp, :::8083->8083/tcp   z-way
root@raspberrypi:/opt/openhab3# docker ps
CONTAINER ID   IMAGE     COMMAND                  CREATED          STATUS                  PORTS                                       NAMES
f32e420c6c00   z-way     "/usr/bin/entry.sh /…"   13 seconds ago   Up Less than a second   0.0.0.0:8083->8083/tcp, :::8083->8083/tcp   z-way
root@raspberrypi:/opt/openhab3# docker ps
CONTAINER ID   IMAGE     COMMAND                  CREATED          STATUS                         PORTS     NAMES
f32e420c6c00   z-way     "/usr/bin/entry.sh /…"   17 seconds ago   Restarting (0) 3 seconds ago             z-way
root@raspberrypi:/opt/openhab3# docker logs f32e420c6c00
root@raspberrypi:/opt/openhab3#
Do you have a solution for this problem?

This Thread is shifted from https://forum.z-wave.me/viewtopic.php?f ... 5&start=20
Dumperios
Posts: 19
Joined: 23 Jul 2022 15:34

Re: Upgrade z-way Server in Docker Container fails

Post by Dumperios »

@PoltoS wrote on 11 Jan 2024: Make sure to use armhf and not arm64 platform.
Dumperios
Posts: 19
Joined: 23 Jul 2022 15:34

Re: Upgrade z-way Server in Docker Container fails

Post by Dumperios »

In the log output I can see that it uses the armhf platform. The downloaded script made this decision.

The log output finished with the following messages:

Code: Select all

Step 6/6 : EXPOSE 8083
 ---> [Warning] The requested image's platform (linux/arm/v6) does not match the detected host platform (linux/arm64/v8) and no specific platform was requested
 ---> Running in 04a15dad2b2e
Removing intermediate container 04a15dad2b2e
 ---> 36832fe25af6
Successfully built 36832fe25af6
Successfully tagged z-way:latest
There is a warning, but in other Threads on the web I read, that this can be ignored.
User avatar
PoltoS
Posts: 7544
Joined: 26 Jan 2011 19:36

Re: Upgrade z-way Server in Docker Container fails

Post by PoltoS »

If this is not solved, please write to support @ z-wave.me.
Post Reply