Upgrade using the backup/restore, no access to devices on new zwave

Discussions about RaZberry - Z-Wave board for Raspberry computer
Post Reply
hp1
Posts: 33
Joined: 09 Jun 2015 07:00

Upgrade using the backup/restore, no access to devices on new zwave

Post by hp1 »

Although the 7 is out, I thought I'd use this an opportunity to finally upgrade to a the 500 series card I picked up a while back, so I can see the process when the 7 becomes available here. I have an old (but reliable) setup which has served very well.

I'm upgrading from a raspberry pi 2 ZW0301 to a raspberry pi 5 ZW0500. I went into the expertUI on the rpi2 and did a backup. it created a z-way-backup-2024-03-25-22-29.zbk file. I then shut down that pi, and booted up the newer one. I went into the ExpertUI and did a restore, including the topology.

All the devices populated in the rpi5, but, nothing can be controlled. I tried to update them, but communication failed and the date turned red. I did a poweroff and poweron, but the same result. I then powered down the rpi5 and powered back up the rpi2, and fortunately I can control them. I'm doing a couple of upgrades at the same time. Version of zwave board, version of rpi, and version of software. Any advice anyone has so I can upgrade the aging rpi2 and software version would be greatly appreciated!!!!!

Current System Information:
Hardware
Vendor: RaZberry by Z-Wave.Me
Vendors Product ID: 2 / 3
Z-Wave Chip: ZW0301

Firmware
Library Type: Static Controller
SDK Version: 4.54.01
Serial API Version: 04.02

Software Information
Version number: v2.3.5
Compile-ID: 356f2deb9b78768bab065124aa211aebceb4a6ed
Compile-Date: 2017-07-29 02:43:40 +0300


New Rpi5 (Target System Information)
Hardware
Vendor: RaZberry by Z-Wave.Me
Vendors Product ID: 1024 / 2
Z-Wave Chip: ZW0500

Firmware
Library Type: Static Controller
SDK Version: 6.51.09
Serial API Version: 05.07
Capabilities:

Software Information
Version number: v4.1.2-wb1
Compile-ID: fe143659da3cd49964ae656a16e2bf2c8f70b904
Compile-Date: 2023-09-01 14:57:55 +0300
hp1
Posts: 33
Joined: 09 Jun 2015 07:00

Re: Upgrade using the backup/restore, no access to devices on new zwave

Post by hp1 »

Just an update to this. The frequency was set to EU, and I had no option to change it. I found this command from a previous post and was able to change my frequency to US and I can change devices now!

curl -u [username]:[password] --globoff '127.0.0.1:8083/JS/Run/zway.ZMEFreqChange(3)'
Post Reply