New version of RaZberry is released

Discussions about RaZberry - Z-Wave board for Raspberry computer
Posts: 10
Joined: 27 Sep 2013 12:35

Any news on 1.4.1?

Post by garp »

I also have this Fibaro FGK issue. Any idea when 1.4.1 will be ready?
Posts: 1
Joined: 09 Oct 2013 15:09

Installation failed on clean RPi

Post by gizmocuz »

Since the new version (v1.4) the system does not detect the motion sensor from the Aeon Multisensor.
Anyone else that can verify this?
I just did a complete reset/reinstall

With kind regards
Posts: 41
Joined: 13 Apr 2013 23:52


Post by Pitt13 »

yes I have a sensor AeonLab too, it gives the correct temperature, the brightness and humidity. But it stuck in motion detection to "trigged"! Impossible for the moment to have this information which is the main!
When will v1.4.1 ?
Posts: 9
Joined: 02 Oct 2013 20:25

V1.4 improvements

Post by Allen912 »


Concerning your new version, it would be great if you could improve compatibility with the MultiSensor Everspring ST814, which have troubles to update his data, and dialog with Razberry (configuration).

There is some logs here and accurate informations from differents users : ... mment-form

Here is my noob observation : ... install-14

Thank you
Posts: 1
Joined: 10 Oct 2013 23:08

Stick communication failed (-9)

Post by Fuzp »

Hello people,

I´ve been stuck on this problem quite a while.

I am using NOOBS_v1_32 on my Raspberry and went for Raspbian, after a fresh reinstallation i install z-way-server, wget -q -O - | sudo bash so far so good no errors.

After i installed it, i get an error that i am missing some shared libaries. Solved by moving /opt/z-way-server/libs and the libaries to /lib/. Yet so far so good.

However when i try to launch sudo ./z-way-server i get the following error:
Z-Way version v1.4 from 2013-09-24 04:16:14 +0400 (build c3c8f606985e948db7839377ea49ecd339fcf61c)
Using default configuration file config.xml
Starting Z-Way for device /dev/ttyAMA0...
failed to discover ZWay: Wrong packet from Z-Wave network or Discovery got bad data (stick communication failed) (-9)

Some people say that this error is due to a broken Razberry however i have just recently replaced it in hope of it being to problem, however it has not solved my problem.

I am in dire need of help, and thanks in advance!
Posts: 4
Joined: 12 Oct 2013 13:48

Another thread

Post by toni »

The symptoms in the last post seem to match mine. I created a new thread here: ... n-failed-9
Posts: 9
Joined: 02 Oct 2013 20:25

Complete feedback v1.4

Post by Allen912 »

I made my installation a few weeks ago. It's now the moment to share my feedback.

Hardware : Raspberry + Z Wave Razberry. 2 Everspring Switch ST814 + 1 Everspring Sensor (T°; Humid) ST814.
To be installed : commut. double FIBARO FGS-221.

Except a little troubleshooting that I solved by myself (Linux noob...) during installation, everything is correctly deployed .

I got some problems with the Everspring Sensor (T°; Humid) ST814.

Here are my printscreen :
Configuration capture :
Pic 1 : ... sp=sharing
Pic 1-end : ... sp=sharing

The control interface displays differents informations. The most (the only...) functionnal for me is the mobile one. Here is the capture of the four control webapps, with problems et my comments : ... sp=sharing

You'll find here the full Device XML data file (f49b66df-DevicesData.xml) : ... sp=sharing

Here, the extract of xml file of the trouble sensor (id=6) : ... sp=sharing

I also tried to apply corrections given by PoltoS here ... ot-working , without success...

I hope my remarks help, and you could help me...

Thank you
Posts: 1
Joined: 17 Oct 2013 16:13

Aeon stick lite support

Post by sergiocesar »

just try to install the latest using this:
wget -q -O - | sudo bash

All I have is the Aeon stick lite I read that back in 2013/5 it was not supported...
Is it now?
If it is can you point me to a configuration fix as I get this:
root@zwave:/opt/z-way-server# ./z-way-server
Z-Way version v1.4-14-g5d22670 from 2013-10-17 00:26:18 +0400 (build 5d226706fd3d026ab89696e66c15268ce4e70977)
Using default configuration file config.xml
Starting Z-Way for device /dev/ttyAMA0...
failed to discover ZWay: Wrong packet from Z-Wave network or Discovery got bad data (stick communication failed) (-9)
I try changing the config file to say /dev/ttyUSB0 but no joy either.

Posts: 2053
Joined: 08 Apr 2012 13:44

The ZWay software will only

Post by pz1 »

The ZWay software will only run with the RaZberry GPIO interface.
As they have to make a living, they do of course NOT make this software compatible with 'ZWave sticks" from competitors.
Since 29-12-2016 I am no longer a moderator for this forum
Posts: 5
Joined: 17 Oct 2013 18:55

Save button not available after renaming device

Post by Holland »

I tried to rename a device, and could not save the new name. The Save button is not available after changing the name

Running version 1.4

Post Reply