New version of RaZberry is released

Discussions about RaZberry - Z-Wave board for Raspberry computer
LOCOSP
Posts: 29
Joined: 22 Sep 2013 02:33

@Holland Hi, after changes go

Post by LOCOSP »

@Holland Hi, after changes go to MAP TAB and the save button will be active ;)

Holland
Posts: 5
Joined: 17 Oct 2013 18:55

Ahh, thanks. That's indeed

Post by Holland »

Ahh, thanks. That's indeed the solution. Thanks for your help


Zetat
Posts: 3
Joined: 20 Oct 2013 13:11

Fibaro RGBW?

Post by Zetat »

Has the new update support for Fibaro RGBW?

pz1
Posts: 2053
Joined: 08 Apr 2012 13:44

For version 1.4 one of the

Post by pz1 »

For version 1.4 one of the API changes is:
Command Class SensorBinary data tree has changed. Now it contains sensor types like SensorMultilevel.
I do not understand what this means. If I read the documentation about Command Sensor binary in section 13.8 page 60, I do not see references to sensor types SensorMultilevel
I have the Fibaro Universal Sensor which contains two binary (open/close), and four multilevel (temperature) sensors. The temperature sensors (which if left alone are automatically updated) are not updated any more if I poll the binary sensor with:
zway.devices[N].instances.SensorBinary.Get()
The binary sensor does not automatically update.
Since 29-12-2016 I am no longer a moderator for this forum

User avatar
PoltoS
Posts: 5824
Joined: 26 Jan 2011 19:36

Please try out v1.4.1-rc1.

Post by PoltoS »

Please try out v1.4.1-rc1. There are not much changs in it, but this particular problem is fixed.

User avatar
PoltoS
Posts: 5824
Joined: 26 Jan 2011 19:36

The Sensor Binary no indeed

Post by PoltoS »

The Sensor Binary no indeed contains types like Sensor Multilevel. This is because Sensor Binary CC V2 allows this. Your Universal Sensor supports only V1 and it is saved as [1]. The manual will be updated accordingly. The .Get() should update all supported sensors. You just might need to force interview if you have switched from v1.3.1

pz1
Posts: 2053
Joined: 08 Apr 2012 13:44

Thanks for the clarification.

Post by pz1 »

Thanks for the clarification. I'll look into this again. As a matter of fact I did start working with Universal sensor recently after I had upgraded to 1.4, and also did a couple of "force interview"
Since 29-12-2016 I am no longer a moderator for this forum

Bjorn
Posts: 4
Joined: 29 Sep 2013 15:00

v1.4.1-rc1

Post by Bjorn »

How to get hold of that version?

/ Björn

User avatar
PoltoS
Posts: 5824
Joined: 26 Jan 2011 19:36

Use the same commad as to

Post by PoltoS »

Use the same commad as to install Z-Way, but specify the version you need:
wget -q -O - razberry.z-wave.me/install/v1.4.1-rc1 | sudo bash

Holland
Posts: 5
Joined: 17 Oct 2013 18:55

@PoltoS

Post by Holland »

@PoltoS

I tried installing 1.4.1 rc1 with wget -q -O - http://razberry.z-wave.me/install | sudo bash
but that reverted me back from a 1.4+ build to 1.4 (24-09-2013)


Post Reply