Version 2

Discussions about RaZberry - Z-Wave board for Raspberry computer
zoic22
Posts: 45
Joined: 04 Apr 2014 14:21

Re: Version 2

Post by zoic22 »

I just test error disapeared but on interface I have always the same error :

Code: Select all

root@jeedom /opt/z-way-server # ./z-way-server
Z-Way version v2.0.0-rc6 from 2014-09-25 15:01:36 +0400 (build dfd7fe249f81a82bd3f028a9001ea877b2896912)
Looking for modules in ./modules
Module mod-homekit.so loaded
Module modzwave.so loaded
Module moddhs.so loaded
Module modenocean.so loaded
Module mod-ws.so loaded
cURL 7.26.0 likely has DNS timeout bug. Please update cURL. Disabling sync DNS timeouts for now.
Module mod-http.so loaded
Module modhomekit.so loaded
Module mod-zwave.so loaded
cURL 7.26.0 likely has DNS timeout bug. Please update cURL. Disabling sync DNS timeouts for now.
Module modhttp.so loaded
Module mod-enocean.so loaded
Module mod-dhs.so loaded
Module modws.so loaded
Using default configuration file config.xml
Error: 'debug-port' number is out of range. Skipping it.
Here the zway log :

Code: Select all

[2014-09-25 14:01:41.451] [I] [core] Executing script: /*** Z-Way Home Automation Engine main executable ***************************** ...
[2014-09-25 14:01:41.478] [I] [core] Executing script: ;!function(exports, undefined) { ...
[2014-09-25 14:01:41.584] [I] [core] Executing script: //     Underscore.js 1.6.0 ...
[2014-09-25 14:01:41.726] [I] [core] Actualizing config
[2014-09-25 14:01:41.735] [I] [core] Executing script: /*** Z-Way HA Virtual Device base class *************************************** ...
[2014-09-25 14:01:41.750] [I] [core] Executing script: /*** Z-Way DevicesCollection class ************************************ ...
[2014-09-25 14:01:41.840] [I] [core] Executing script: /*** Z-Way HA Controller class module ***************************************** ...
[2014-09-25 14:01:41.880] [I] [core] Executing script: /*** Z-Way HA Automation module base class ************************************ ...
[2014-09-25 14:01:41.890] [I] [core] Executing script: /*** Main Automation storage module ***************************************** ...
[2014-09-25 14:01:41.907] [I] [core] Executing script: /*** Main Automation webserver module ***************************************** ...
[2014-09-25 14:01:41.913] [I] [core] Executing script: // Make this testable by pulling in underscore from the parent module ...
[2014-09-25 14:01:41.922] [I] [core] Executing script: /*** Main Automation storage module ***************************************** ...
[2014-09-25 14:01:41.970] [I] [core] --- Loading ZAutomation classes
[2014-09-25 14:01:42.081] [I] [core] Starting ZWay Automation webserver
[2014-09-25 14:01:42.088] [I] [core] Loading modules...
[2014-09-25 14:01:42.111] [I] [core] Loading module LightScene from modules/LightScene
[2014-09-25 14:01:42.115] [I] [core] Executing script: /*** LightScene Z-Way HA module ******************************************* ...
[2014-09-25 14:01:42.128] [I] [core] Loading module TagOnOff from modules/TagOnOff
[2014-09-25 14:01:42.132] [I] [core] Executing script: /*** TagOnOff Z-Way HA module ******************************************* ...
[2014-09-25 14:01:42.137] [I] [core] Loading module GroupDevices from modules/GroupDevices
[2014-09-25 14:01:42.140] [I] [core] Executing script: /*** GroupDevices Z-Way HA module ******************************************* ...
[2014-09-25 14:01:42.142] [I] [core] Loading module AutoOff from modules/AutoOff
[2014-09-25 14:01:42.146] [I] [core] Executing script: /*** AutoOff Z-Way Home Automation module ************************************* ...
[2014-09-25 14:01:42.147] [I] [core] Loading module RGB from modules/RGB
[2014-09-25 14:01:42.151] [I] [core] Executing script: /*** RGB Z-Way HA module ******************************************* ...
[2014-09-25 14:01:42.153] [I] [core] Loading module HomeKitGate from modules/HomeKitGate
[2014-09-25 14:01:42.158] [I] [core] Executing script: /* ...
[2014-09-25 14:01:42.160] [I] [core] Loading module LogicalRules from modules/LogicalRules
[2014-09-25 14:01:42.166] [I] [core] Executing script: /*** LogicalRules Z-Way HA module ******************************************* ...
[2014-09-25 14:01:42.168] [I] [core] Loading module SensorValueLogging from modules/SensorValueLogging
[2014-09-25 14:01:42.171] [I] [core] Executing script: /*** SensorValueLogging Z-Way Home Automation module ************************************* ...
[2014-09-25 14:01:42.173] [I] [core] Loading module CodeDevice from modules/CodeDevice
[2014-09-25 14:01:42.177] [I] [core] Executing script: /*** CodeDevice Z-Way HA module ******************************************* ...
[2014-09-25 14:01:42.179] [I] [core] Loading module DummyDevice from modules/DummyDevice
[2014-09-25 14:01:42.182] [I] [core] Executing script: /*** DummyDevice Z-Way HA module ******************************************* ...
[2014-09-25 14:01:42.185] [I] [core] Loading module ZWave from modules/ZWave
[2014-09-25 14:01:42.188] [I] [core] Executing script: /*** Z-Wave Binding module ******************************************************** ...
[2014-09-25 14:01:42.230] [I] [core] Notification: error (core): Failed to load module ZWaveGate because ZWave was not instanciated
[2014-09-25 14:01:42.231] [I] [core] Loading module DelayedScene from modules/DelayedScene
[2014-09-25 14:01:42.236] [I] [core] Executing script: /*** DelayedScene Z-Way HA module ******************************************* ...
[2014-09-25 14:01:42.238] [I] [core] Loading module CustomUserCodeLoader from modules/CustomUserCodeLoader
[2014-09-25 14:01:42.241] [I] [core] Executing script:   /*** CustomUserCodeLoader ZAutomation module **************************************** ...
[2014-09-25 14:01:42.242] [I] [core] Loading module BindDevices from modules/BindDevices
[2014-09-25 14:01:42.246] [I] [core] Executing script: /*** BindDevices Z-Way HA module ******************************************* ...
[2014-09-25 14:01:42.248] [I] [core] Loading module OpenWeather from modules/OpenWeather
[2014-09-25 14:01:42.251] [I] [core] Executing script: /*** OpenWeather Z-Way HA module ******************************************* ...
[2014-09-25 14:01:42.254] [I] [core] Loading module SwitchControlGenerator from modules/SwitchControlGenerator
[2014-09-25 14:01:42.259] [I] [core] Executing script: /*** SwitchControlGenerator Z-Way HA module ******************************************* ...
[2014-09-25 14:01:42.261] [I] [core] Loading module OpenRemoteHelpers from modules/OpenRemoteHelpers
[2014-09-25 14:01:42.266] [I] [core] Executing script: /* RaZOR ...
[2014-09-25 14:01:42.268] [I] [core] Loading module NotificationSMSru from modules/NotificationSMSru
[2014-09-25 14:01:42.271] [I] [core] Executing script: /*** NotificationSMSru Z-Way HA module ******************************************* ...
[2014-09-25 14:01:42.273] [I] [core] Loading module ImportRemoteHA from modules/ImportRemoteHA
[2014-09-25 14:01:42.279] [I] [core] Executing script: /*** ImportRemoteHA Z-Way HA module ******************************************* ...
[2014-09-25 14:01:42.282] [I] [core] Loading module ZWave from modules/ZWave
[2014-09-25 14:01:42.284] [I] [core] Executing script: /*** Z-Wave Binding module ******************************************************** ...
[2014-09-25 14:01:42.302] [I] [core] Notification: error (core): Failed to load module ZWaveDeadDetection because ZWave was not instanciated
[2014-09-25 14:01:42.304] [I] [core] Loading module SecurityMode from modules/SecurityMode
[2014-09-25 14:01:42.310] [I] [core] Executing script: /*** SecurityMode Z-Way HA module ******************************************* ...
[2014-09-25 14:01:42.312] [I] [core] Loading module Cron from modules/Cron
[2014-09-25 14:01:42.317] [I] [core] Executing script: /*** Cron ZAutomation module ************************************************** ...
[2014-09-25 14:01:42.326] [I] [core] Notification: error (core): Failed to load module BatteryPolling because Cron was not instanciated
[2014-09-25 14:01:42.327] [I] [core] Loading module YandexProbki from modules/YandexProbki
[2014-09-25 14:01:42.331] [I] [core] Executing script: /*** YandexProbki Z-Way HA module ******************************************* ...
[2014-09-25 14:01:42.333] [I] [core] Loading module RoundRobinScenes from modules/RoundRobinScenes
[2014-09-25 14:01:42.336] [I] [core] Executing script: /*** RoundRobinScenes Z-Way HA module ******************************************* ...
[2014-09-25 14:01:42.338] [I] [core] Loading module Camera from modules/Camera
[2014-09-25 14:01:42.341] [I] [core] Executing script: /*** Camera Z-Way HA module ******************************************* ...
[2014-09-25 14:01:42.362] [I] [core] Loading module Cron from modules/Cron
[2014-09-25 14:01:42.364] [I] [core] Executing script: /*** Cron ZAutomation module ************************************************** ...
[2014-09-25 14:01:42.366] [I] [core] Loading module CustomUserCode from modules/CustomUserCode
[2014-09-25 14:01:42.368] [I] [core] Executing script:   /*** CustomUserCode ZAutomation module **************************************** ...
[2014-09-25 14:01:42.371] [I] [core] Loading module ScheduledScene from modules/ScheduledScene
[2014-09-25 14:01:42.374] [I] [core] Executing script: /*** ScheduledScene Z-Way HA module ******************************************* ...
[2014-09-25 14:01:42.376] [I] [core] Loading module Cron from modules/Cron
[2014-09-25 14:01:42.377] [I] [core] Executing script: /*** Cron ZAutomation module ************************************************** ...
[2014-09-25 14:01:42.383] [I] [core] Notification: error (core): Failed to load module SensorsPolling because Cron was not instanciated
[2014-09-25 14:01:42.387] [I] [core] Loading module HTTPDevice from modules/HTTPDevice
[2014-09-25 14:01:42.392] [I] [core] Executing script: /*** HTTPDevice Z-Way HA module ******************************************* ...
[2014-09-25 14:01:42.394] [I] [core] Loading module AutoLock from modules/AutoLock
[2014-09-25 14:01:42.397] [I] [core] Executing script: /*** AutoLock Z-Way Home Automation module ************************************* ...
[2014-09-25 14:01:42.398] [I] [core] Loading module Notification from modules/Notification
[2014-09-25 14:01:42.401] [I] [core] Executing script: /*** Notification Z-Way HA module ******************************************* ...
[2014-09-25 14:01:42.403] [I] [core] Loading module ZWave from modules/ZWave
[2014-09-25 14:01:42.404] [I] [core] Executing script: /*** Z-Wave Binding module ******************************************************** ...
[2014-09-25 14:01:42.406] [I] [core] Starting automation...
[2014-09-25 14:01:42.505] [I] [core] Starting storage...
[2014-09-25 14:01:42.509] [I] [core] ZWay Automation started
[2014-09-25 14:01:42.509] [I] [core] Z-Way object is not loaded. Skipping Z-Way Utilities
[2014-09-25 14:01:45.051] [E] [8083] Callback execution error: ReferenceError: zway is not defined
    at ZWaveAPI.Data (automation/main.js:154:9)
    at WebServerRequestHandler (automation/main.js:239:10)

User avatar
PoltoS
Posts: 5507
Joined: 26 Jan 2011 19:36

Re: Version 2

Post by PoltoS »

To enable Z-Wave you need to load Z-Wave Binding module with default params. After this and restart everything will be ok

zoic22
Posts: 45
Joined: 04 Apr 2014 14:21

Re: Version 2

Post by zoic22 »

How can I load Z-Wave Binding ?

User avatar
PoltoS
Posts: 5507
Joined: 26 Jan 2011 19:36

Re: Version 2

Post by PoltoS »

Add in the new UI a module with this name

pz1
Posts: 2053
Joined: 08 Apr 2012 13:44

Re: Version 2

Post by pz1 »

PoltoS wrote:Add in the new UI a module with this name
Yesterday I did ask a similar question earlier in this thread (viewtopic.php?f=3422&t=20687&p=52488#p52488). Could you further clarify my second question there?
Since 29-12-2016 I am no longer a moderator for this forum

zoic22
Posts: 45
Joined: 04 Apr 2014 14:21

Re: Version 2

Post by zoic22 »

I can't find how to add new module...

User avatar
PoltoS
Posts: 5507
Joined: 26 Jan 2011 19:36

Re: Version 2

Post by PoltoS »

Let us do a manual on how to upgrade in that case.

pz1
Posts: 2053
Joined: 08 Apr 2012 13:44

Re: Version 2

Post by pz1 »

I'll follow pofs' advice to wait a bit longer for a more mature release.
Since 29-12-2016 I am no longer a moderator for this forum

pofs
Posts: 688
Joined: 25 Mar 2011 19:03

Re: Version 2

Post by pofs »

RC 8 feels more stable now. We've fixed some bugs and a few hard-to-detect memory leaks, and added Camera module with a new proxy API.
We're still testing it, but I think you may try it already.

Z-Wave is not a mandatory part anymore, it is just one of the modules now.
If you're updating from the 1.x version, you'll need to go to HA UI after installation and add Z-Wave Binding module with default parameters. Clean installation already has it pre-configured for you.

Make sure to run "apt-get update" before installation/update to ensure the latest libraries will be used.

pz1
Posts: 2053
Joined: 08 Apr 2012 13:44

Re: Version 2

Post by pz1 »

Clean installation already has it pre-configured for you.
A clean installation sounds a bit ambiguous. Does it also mean that I do have to exclude/re-include all Z-Wave devices, or is just a
wget -q -O - razberry.z-wave.me/install/v2.0.0-rc8 | sudo bash ?
Since 29-12-2016 I am no longer a moderator for this forum

Post Reply