New 2.2.0 is out!

Discussions about RaZberry - Z-Wave board for Raspberry computer
User avatar
Posts: 5640
Joined: 26 Jan 2011 19:36

New 2.2.0 is out!

Post by PoltoS »

Dear RaZberry/Z-Way users, new 2.2.0 version is out.

What's new?

- Initial page forces to change default password and add email for password recovery. Password recovery by mail.
- New design for RGB color picker.
- Redesign of Dimmer Element. Has now 3 buttons for off, on/last state, on/full state.
- Events can now be filtered on any device.
- New design on Setup Menu, all Management functions are in single menu element shortening the menu.
- New design for device management. EnOcean UI is only shown if Enocean is active, Setup and Management for all different technologies is unified now.
- Z-Wave management now allows to remove Z-Wave device, either by Exclusion or by Removing a failed node.
- New Info Page gives valuable data for support.
- Dashboard Message improved if dashboard is still empty.
- New design for all elements. They now show the room they are assigned to plus measured values are much larger.
- Description of the bug report function added.
- Menu icons for Elements and Rooms are twisted.
- Whole new design of App store.
- Now App store is open for third parties.
- Allow update and delete of apps.
- Apps are now grouped by theme.
- Its possible to access private apps using token string.
- New section "featured" for the most important apps.
- Newly created elements are color marked to find them better.
- New Icons for Thermostats and different other sensor values.
- Elements are now ordered by name.
- Plenty of changes to adapt to different mobile device screen sizes.
- All devices now belong to a room. There is a wildcard room for devices not assigned yet.

Expert UI:
- Showing current license in Expert UI.
- Description of different colors in routing table.
- Complete redesign of Association Settings page.
- Redirection to login page if accessed directly without login.

New features:
- Added support for WebSocket client and server (not on all platforms yet).
- notification2ext modules added to save notifications on external flash.
- Asynchronous DNS resolver for http and sockets not to block JS (not on all platforms yet).
- Support SendData to broadcast (node 255).
- Added JS functions for AssignReturnRoute, AssignSUCReturnRoute, DeleteReturnRoute.

- Restore functionality fixed. Make sure to update bootloader and firmware to 5.04 on UZB and RaZberry before running restore!!!
- Conforms with latest Z-Wave Plus updated specification.
- Fixed missing scales problem for Multilevel Sensors.
- New scales added for Multilevel Sensors.
- Fix incomplete read issue in system() API function.
- Print module js file:line info when compilation error occurs.
- Fixed SerialAPI AddNodeToNetwork and RemoveNodeFromNetwork callback mess. Need firmware 5.04 on UZB and RaZberry.
- ReplaceFailedNode restarts full interview including Security interview.
- ZMEFreqChange current frequency detection bug fixed.
- Compatibility: allow setTimeout(fn, 0) which is used sometimes for deferred callbacks.
- Fixed output of SDK version name of devices and RaZberry/UZB.
- Remote Access rare problems fixed.
- All device are now grouped by namespaces to allow easy selection in App settings.
- OpenWeather now with API Key (according to changed of the service).

New Command Classes:
- MultiChannel v4, MultiChannelAssociation v3, Association v2 support
- ThermostatSetPoint v3

Stability and security fixes:
- More stable interview with Security on slow hardware
- Few potential crash situations fixed

API changes:
- zway.SetLearnMode and controller.SetLearnMode parameter can now be 0, 1 and 2 to support NWI Learn Mode. See docs.
- lastExcludedDevice is now updated AFTER device complete removal and is now also updated in RemoveFailed success callback.

What's next?

Outlook for 2.2.1:
- Backup/Restore of full automation + Z-Wave
- Minor-Bugfixes Expert/Smarthome
- User contribution merge (on github)

Outlook for 2.3.0:
- Skins for different designs (Icon Sets, Colors, ….)
- Apps, Apps, Apps!

Posts: 32
Joined: 11 Sep 2013 22:54

Re: New 2.2.0 is out!

Post by past »

Where i can find info about websockets support?

Posts: 1
Joined: 12 Dec 2015 20:24

Re: New 2.2.0 is out!

Post by jtoler5 »

Upgraded to 2.2.0 and now I am seeing constant "[core] Can not make request: Couldn't connect to server" errors in the z-way-server log file.

Posts: 2053
Joined: 08 Apr 2012 13:44

Re: New 2.2.0 is out!

Post by pz1 »

Installed it on my RaspberryPi B with RaZberry:

Fibaro Universal sensors (temperature) do no longer update automatically

Posts: 26
Joined: 11 Dec 2015 01:54

Re: New 2.2.0 is out!

Post by Ricard1 »

pz1 wrote:
- Restore functionality fixed. Make sure to update bootloader and firmware to 5.04 on UZB and RaZberry before running restore!!!
Bootloader update still fails. Tried it on a new Raspi2 and a new UZB (I did send you the report by email yesterday)
Same for me "Error hanling data"

Posts: 1
Joined: 12 Dec 2015 05:32

Re: New 2.2.0 is out!

Post by ohjay93 »

My fibaro multisensor works perfectly :-)
I set its update frequency manually though to 10 mins.

Posts: 2053
Joined: 08 Apr 2012 13:44

Re: New 2.2.0 is out!

Post by pz1 »

ohjay93 wrote:My fibaro multisensor works perfectly :-)
I set its update frequency manually though to 10 mins.
Mine has been working on my testrig for 3/4 year on default settings (20s for freq). With this new update it has stopped doing so. I can only conclude the cause must be the new s/w

Posts: 81
Joined: 20 Apr 2015 01:22

Re: New 2.2.0 is out!

Post by Plainsane »

Quick note. My scheduled scenes dropped their scenes.

Also, the dashboard doesn't show the proper states for some of my dimmer and binary switches.

All in all a great release, I can use my thermostats now.

Posts: 8
Joined: 10 Dec 2015 00:09

Re: New 2.2.0 is out!

Post by SkjeggPT »

cant use tasker with authentication

Posts: 1
Joined: 16 Dec 2015 19:22

Re: New 2.2.0 is out!

Post by Luktar »

Upgraded and now the IOS app just crash when i start it, will start investigation now.

* I can't connect via remote, but app doesn't crash.
* The app crash when it has access to my network and the razberry

* What i can see after the 2.2.0 upgrade, i get 404 when i want to check CRON, deleted it, and tried to reinstall, got 404 when trying to install.

* Rolled back to v2.1.1, now app works with LAN
* Still can't login via remote, (get 502 Bad Gateway from
* CRON still can't be added.

* silly me, cleared cache and now the Cron App could be added again, sometimes food helps.
* Still don't dare to upgrade to v2.2.0 due to iPhone app crashes.
* Still can't login via remote, but did a workaround and enabled vpn at home instead.

Post Reply