ZWay 2.2.0: issue with Fibaro FGSD-002

Discussions about RaZberry - Z-Wave board for Raspberry computer
AlphaX2
Posts: 110
Joined: 25 Jul 2015 15:03

ZWay 2.2.0: issue with Fibaro FGSD-002

Post by AlphaX2 »

Hello,

I am using the new Fibaro FGSD-002 smoke detector. It worked flawless up to Zway version 2.1.2-rc2.

I also tried later rc versions, internal as well as standard rc's like 2.1.2-rc17 and switched today to stable 2.2.0. In all tested versions after 2.1.2-rc2 the smoke detector shows in the AutomationUI just 3 elements: temperature (CC 49-1), heat alarm (CC 113-4-2) and test alarm (CC 113-1-3). It also affects the vDev API where the information is not shown. On the other hand the interview results find also all other elements like smoke alarm, buglar, system and power managment (CC Alarm), it's also listed, when using the JS API to fetch device specific information.

I've already reported this issue in a thread about last 2.1.2-rc17 and I tried also new interview and even complete exclusion and inclusion process, but was not able to fix this.

I hope you'll fix this very soon, because I'm running an E-Mail and SMS notification script on the basis of the vDev API.

Any ideas, or possible solutions, besides switching back to 2.1.2-rc2?

User avatar
PoltoS
Posts: 5824
Joined: 26 Jan 2011 19:36

Re: ZWay 2.2.0: issue with Fibaro FGSD-002

Post by PoltoS »

Please show the log - does it try to render vDev elements? Any errors in the log?

AlphaX2
Posts: 110
Joined: 25 Jul 2015 15:03

Re: ZWay 2.2.0: issue with Fibaro FGSD-002

Post by AlphaX2 »

Hi and thanks for your reply.

The log seems - for me - to be okay. There is just one error message appearing multiple times:

Code: Select all

[E] [zway] SaveData will not save data since it wasn't loaded. This is to prevent data loss.
and it seems to recognize all functions properly:

Code: Select all

[2015-12-14 06:22:44.193] [D] [zway] SETDATA devices.20.instances.0.commandClasses.113.data.interviewCounter = 9 (0x00000009)
[2015-12-14 06:22:44.193] [D] [zway] SETDATA devices.20.instances.0.commandClasses.113.data.V1supported = False
[2015-12-14 06:22:44.193] [D] [zway] SETDATA devices.20.instances.0.commandClasses.113.data.typeMask = 914 (0x00000392)
[2015-12-14 06:22:44.193] [D] [zway] SETDATA devices.20.instances.0.commandClasses.113.data.1 = Empty
[2015-12-14 06:22:44.193] [D] [zway] SETDATA devices.20.instances.0.commandClasses.113.data.1.typeString = Empty
[2015-12-14 06:22:44.193] [D] [zway] SETDATA devices.20.instances.0.commandClasses.113.data.1.typeString = "Smoke"
[2015-12-14 06:22:44.193] [D] [zway] SETDATA devices.20.instances.0.commandClasses.113.data.1.status = Empty
[2015-12-14 06:22:44.194] [D] [zway] SETDATA devices.20.instances.0.commandClasses.113.data.1.eventMask = Empty
[2015-12-14 06:22:44.194] [D] [zway] SETDATA devices.20.instances.0.commandClasses.113.data.1.eventMask = 12 (0x0000000c)
[2015-12-14 06:22:44.194] [D] [zway] SETDATA devices.20.instances.0.commandClasses.113.data.1.event = Empty
[2015-12-14 06:22:44.194] [D] [zway] SETDATA devices.20.instances.0.commandClasses.113.data.1.eventString = Empty
[2015-12-14 06:22:44.194] [D] [zway] SETDATA devices.20.instances.0.commandClasses.113.data.1.eventParameters = Empty
[2015-12-14 06:22:44.194] [D] [zway] SETDATA devices.20.instances.0.commandClasses.113.data.4 = Empty
[2015-12-14 06:22:44.194] [D] [zway] SETDATA devices.20.instances.0.commandClasses.113.data.4.typeString = Empty
[2015-12-14 06:22:44.195] [D] [zway] SETDATA devices.20.instances.0.commandClasses.113.data.4.typeString = "Heat"
[2015-12-14 06:22:44.195] [D] [zway] SETDATA devices.20.instances.0.commandClasses.113.data.4.status = Empty
[2015-12-14 06:22:44.195] [D] [zway] SETDATA devices.20.instances.0.commandClasses.113.data.4.eventMask = Empty
[2015-12-14 06:22:44.195] [D] [zway] SETDATA devices.20.instances.0.commandClasses.113.data.4.eventMask = 4 (0x00000004)
[2015-12-14 06:22:44.195] [D] [zway] SETDATA devices.20.instances.0.commandClasses.113.data.4.event = Empty
[2015-12-14 06:22:44.195] [D] [zway] SETDATA devices.20.instances.0.commandClasses.113.data.4.eventString = Empty
[2015-12-14 06:22:44.195] [D] [zway] SETDATA devices.20.instances.0.commandClasses.113.data.4.eventParameters = Empty
[2015-12-14 06:22:44.195] [D] [zway] SETDATA devices.20.instances.0.commandClasses.113.data.7 = Empty
[2015-12-14 06:22:44.196] [D] [zway] SETDATA devices.20.instances.0.commandClasses.113.data.7.typeString = Empty
[2015-12-14 06:22:44.196] [D] [zway] SETDATA devices.20.instances.0.commandClasses.113.data.7.typeString = "Burglar"
[2015-12-14 06:22:44.196] [D] [zway] SETDATA devices.20.instances.0.commandClasses.113.data.7.status = Empty
[2015-12-14 06:22:44.196] [D] [zway] SETDATA devices.20.instances.0.commandClasses.113.data.7.eventMask = Empty
[2015-12-14 06:22:44.196] [D] [zway] SETDATA devices.20.instances.0.commandClasses.113.data.7.eventMask = 8 (0x00000008)
[2015-12-14 06:22:44.196] [D] [zway] SETDATA devices.20.instances.0.commandClasses.113.data.7.event = Empty
[2015-12-14 06:22:44.196] [D] [zway] SETDATA devices.20.instances.0.commandClasses.113.data.7.eventString = Empty
[2015-12-14 06:22:44.196] [D] [zway] SETDATA devices.20.instances.0.commandClasses.113.data.7.eventParameters = Empty
[2015-12-14 06:22:44.197] [D] [zway] SETDATA devices.20.instances.0.commandClasses.113.data.8 = Empty
[2015-12-14 06:22:44.197] [D] [zway] SETDATA devices.20.instances.0.commandClasses.113.data.8.typeString = Empty
[2015-12-14 06:22:44.197] [D] [zway] SETDATA devices.20.instances.0.commandClasses.113.data.8.typeString = "Power Management"
[2015-12-14 06:22:44.197] [D] [zway] SETDATA devices.20.instances.0.commandClasses.113.data.8.status = Empty
[2015-12-14 06:22:44.197] [D] [zway] SETDATA devices.20.instances.0.commandClasses.113.data.8.eventMask = Empty
[2015-12-14 06:22:44.197] [D] [zway] SETDATA devices.20.instances.0.commandClasses.113.data.8.eventMask = 1024 (0x00000400)
[2015-12-14 06:22:44.197] [D] [zway] SETDATA devices.20.instances.0.commandClasses.113.data.8.event = Empty
[2015-12-14 06:22:44.198] [D] [zway] SETDATA devices.20.instances.0.commandClasses.113.data.8.eventString = Empty
[2015-12-14 06:22:44.198] [D] [zway] SETDATA devices.20.instances.0.commandClasses.113.data.8.eventParameters = Empty
[2015-12-14 06:22:44.198] [D] [zway] SETDATA devices.20.instances.0.commandClasses.113.data.9 = Empty
[2015-12-14 06:22:44.198] [D] [zway] SETDATA devices.20.instances.0.commandClasses.113.data.9.typeString = Empty
[2015-12-14 06:22:44.198] [D] [zway] SETDATA devices.20.instances.0.commandClasses.113.data.9.typeString = "System"
[2015-12-14 06:22:44.198] [D] [zway] SETDATA devices.20.instances.0.commandClasses.113.data.9.status = Empty
[2015-12-14 06:22:44.198] [D] [zway] SETDATA devices.20.instances.0.commandClasses.113.data.9.eventMask = Empty
[2015-12-14 06:22:44.198] [D] [zway] SETDATA devices.20.instances.0.commandClasses.113.data.9.eventMask = 2 (0x00000002)
[2015-12-14 06:22:44.199] [D] [zway] SETDATA devices.20.instances.0.commandClasses.113.data.9.event = Empty
[2015-12-14 06:22:44.199] [D] [zway] SETDATA devices.20.instances.0.commandClasses.113.data.9.eventString = Empty
[2015-12-14 06:22:44.199] [D] [zway] SETDATA devices.20.instances.0.commandClasses.113.data.9.eventParameters = Empty
But on the other side it never tries to create the elements for it.

Code: Select all

[2015-12-14 06:22:47.210] [I] [core] ZWay Automation started
[2015-12-14 06:22:47.473] [I] [core] Creating device switchBinary ZWayVDev_zway_6-0-37
[2015-12-14 06:22:47.504] [I] [core] Notification: device-info (device-OnOff): {"dev":"Devolo: TV-Bereich","l":"on"}
[2015-12-14 06:22:47.546] [I] [core] Creating device sensorMultilevel ZWayVDev_zway_6-0-50-0
[2015-12-14 06:22:47.975] [I] [core] Creating device sensorMultilevel ZWayVDev_zway_6-0-50-2
[2015-12-14 06:22:51.592] [I] [core] Creating device sensorMultilevel ZWayVDev_zway_6-0-50-4
[2015-12-14 06:22:52.569] [I] [core] Creating device sensorMultilevel ZWayVDev_zway_6-0-50-5
[2015-12-14 06:22:52.596] [I] [core] Creating device sensorMultilevel ZWayVDev_zway_6-0-50-6
[2015-12-14 06:22:53.075] [I] [core] Creating device switchBinary ZWayVDev_zway_7-0-37
[2015-12-14 06:22:53.088] [I] [core] Notification: device-info (device-OnOff): {"dev":"DüWi: Deckenleuchte Küche","l":"off"}
[2015-12-14 06:22:53.146] [I] [core] Creating device switchBinary ZWayVDev_zway_8-0-37
[2015-12-14 06:22:53.153] [I] [core] Notification: device-info (device-OnOff): {"dev":"DüWi: Schreibtisch","l":"off"}
[2015-12-14 06:22:53.214] [I] [core] Creating device switchBinary ZWayVDev_zway_16-0-37
[2015-12-14 06:22:53.224] [I] [core] Notification: device-info (device-OnOff): {"dev":"DüWi: Mikrowelle","l":"on"}
[2015-12-14 06:22:53.287] [I] [core] Creating device switchMultilevel ZWayVDev_zway_18-0-38
[2015-12-14 06:22:53.298] [I] [core] Notification: device-info (device-status): {"dev":"Dimmer 18-0 Eurotronic Technology","l":"0%"}
[2015-12-14 06:22:53.328] [I] [core] Creating device sensorMultilevel ZWayVDev_zway_18-0-49-1
[2015-12-14 06:22:53.340] [I] [core] Notification: device-info (device-status): {"dev":"Schreibtisch: Temperatur","l":"22.5 null"}
[2015-12-14 06:22:53.369] [I] [core] Creating device switchBinary ZWayVDev_zway_18-0-64
[2015-12-14 06:22:53.379] [I] [core] Notification: device-info (device-OnOff): {"dev":"Thermostat Flur: Modi (siehe ExpertUI)","l":"on"}
[2015-12-14 06:22:53.406] [I] [core] Creating device thermostat ZWayVDev_zway_18-0-67-1
[2015-12-14 06:22:53.438] [I] [core] Creating device battery ZWayVDev_zway_18-0-128
[2015-12-14 06:22:53.515] [I] [core] Creating device thermostat ZWayVDev_zway_19-0-67-1
[2015-12-14 06:22:53.539] [I] [core] Creating device battery ZWayVDev_zway_19-0-128
[2015-12-14 06:22:53.631] [I] [core] Creating device sensorMultilevel ZWayVDev_zway_20-0-49-1
[2015-12-14 06:22:53.643] [I] [core] Notification: device-info (device-temperature): {"dev":"Rauchmelder: aktuelle Temperatur","l":"22.2 °C"}
[2015-12-14 06:22:53.707] [I] [core] Creating device battery ZWayVDev_zway_20-0-128
[2015-12-14 06:22:53.794] [I] [core] Creating device sensorBinary ZWayVDev_zway_20-0-113-1-3-A
[2015-12-14 06:22:53.806] [I] [core] Creating device sensorBinary ZWayVDev_zway_20-0-113-4-2-A
[2015-12-14 06:22:53.854] [I] [core] Creating device switchMultilevel ZWayVDev_zway_21-0-38
[2015-12-14 06:22:53.864] [I] [core] Notification: device-info (device-status): {"dev":"Zipato Dimmer","l":"0%"}
[2015-12-14 06:22:53.890] [I] [core] Creating device switchRGBW ZWayVDev_zway_21-0-51-rgb
[2015-12-14 06:22:53.930] [I] [core] Notification: device-info (device-status): {"dev":"Zipato RGB-Wahl","l":"off","color":{"r":0,"g":0,"b":0}}
[2015-12-14 06:22:54.039] [I] [core] Creating device switchMultilevel ZWayVDev_zway_21-0-51-0
[2015-12-14 06:22:54.048] [I] [core] Notification: device-info (device-status): {"dev":"Zipato (warmes weiß)","l":"0%"}
[2015-12-14 06:22:54.069] [I] [core] Creating device switchMultilevel ZWayVDev_zway_21-0-51-1
[2015-12-14 06:22:54.077] [I] [core] Notification: device-info (device-status): {"dev":"Zipato (kaltes weiß)","l":"0%"}
[2015-12-14 06:22:54.142] [I] [core] Creating device switchBinary ZWayVDev_zway_22-0-37
[2015-12-14 06:22:54.149] [I] [core] Notification: device-info (device-OnOff): {"dev":"DüWi Schwibbogen","l":"off"}
[2015-12-14 06:22:54.202] [I] [core] Creating device switchBinary ZWayVDev_zway_23-0-37
[2015-12-14 06:22:54.216] [I] [core] Notification: device-info (device-OnOff): {"dev":"DüWi: Weihnachtssterne","l":"on"}
[2015-12-14 06:23:05.244] [D] [zway] Job 0x07: deleted from queue
[2015-12-14 06:23:05.275] [D] [zway] Job 0xf5: deleted from queue
[2015-12-14 06:23:05.276] [D] [zway] Job 0x06: deleted from queue
[2015-12-14 06:23:05.276] [D] [zway] Job 0x17: deleted from queue
[2015-12-14 06:23:05.276] [D] [zway] Job 0xd2: deleted from queue
Maybe you have some ideas what else I should look for? Searching specific terms?

Thank you!

rudi
Posts: 4
Joined: 15 Dec 2015 20:20

Re: ZWay 2.2.0: issue with Fibaro FGSD-002

Post by rudi »

Hi,
also i have the same problem with the smoke sensor.
Do you have a solution for this issue?

AlphaX2
Posts: 110
Joined: 25 Jul 2015 15:03

Re: ZWay 2.2.0: issue with Fibaro FGSD-002

Post by AlphaX2 »

Sorry for double post...
Last edited by AlphaX2 on 16 Dec 2015 16:11, edited 1 time in total.

AlphaX2
Posts: 110
Joined: 25 Jul 2015 15:03

Re: ZWay 2.2.0: issue with Fibaro FGSD-002

Post by AlphaX2 »

Hi,

no solution so far. But good to know there is some one else - means it's not my end that fails. :)
Hope they can help us/find a solution, hopefully PoltoS has any clue whats wrong here.

rudi
Posts: 4
Joined: 15 Dec 2015 20:20

Re: ZWay 2.2.0: issue with Fibaro FGSD-002

Post by rudi »

Hello AlphaX2,
I have included the smoke detector again.

Thereafter, the following elements in the UI were present:
113-4-2 heat alarm
0-49-1 temp.
113-1-3 smoke alarm test

It lacks:
113-7-3 is cover removed / tamper
113-9-1 is malfunction / hardware failure
113-8-10 is low battery
113-1-2 is smoke alarm

After a short time (5 min) were automatically added the following items!
113-4-254 -A
113-1-254 -A

Was it with you as well?

AlphaX2
Posts: 110
Joined: 25 Jul 2015 15:03

Re: ZWay 2.2.0: issue with Fibaro FGSD-002

Post by AlphaX2 »

This bug is still not fixed in version 2.2.1-rc1! My smoke sensor is one of the most important devices, makes the new version(s) not unusable for me! Please fix this asap!

Thank you very much!

User avatar
PoltoS
Posts: 5824
Joined: 26 Jan 2011 19:36

Re: ZWay 2.2.0: issue with Fibaro FGSD-002

Post by PoltoS »

Need full log. Please sned inclusion log by mail.

AlphaX2
Posts: 110
Joined: 25 Jul 2015 15:03

Re: ZWay 2.2.0: issue with Fibaro FGSD-002

Post by AlphaX2 »

Is a complete log after reboot and REinclusion enough? Or full reset and new inclusion? :?:

Post Reply