ZWay 2.2.0: issue with Fibaro FGSD-002

Discussions about RaZberry - Z-Wave board for Raspberry computer
rudi
Posts: 4
Joined: 15 Dec 2015 20:20

Re: ZWay 2.2.0: issue with Fibaro FGSD-002

Post by rudi »

Update to version 2.2.1-rc7!

Now in UI:
113-1-2 is smoke alarm
113-4-2 heat alarm
0-49-1 temp.

Now missing:
113-1-3 smoke alarm test
113-7-3 is cover removed / tamper
113-9-1 is malfunction / hardware failure
113-8-10 is low battery

AlphaX2
Posts: 110
Joined: 25 Jul 2015 15:03

Re: ZWay 2.2.0: issue with Fibaro FGSD-002

Post by AlphaX2 »

Hello,

I got some help from the devs and fixed it now, don't know, why the fix still isn't in the 2.2.1 release. :(

Easiest way to fix it is using WinSCP on Windows/Linux (nano editor) - connect to your RaspberryPi and browse to:
"/opt/z-way-server/automation/modules/ZWave/"
open the file "postfix.json" with WinSCP's build in editor/nano and search for the Fibaro Smoke sensor and change the lines to equal this, so it means kick out the line with the 113 stuff, to bring back all you CommandClass 113 (Alarm) type elements:

"id": "6",
"p_id": "271.3074.4098",
"product": "Fibaro Smoke Sensor",
"preInterview": [],
"postInterview": [
"preventDeviceCreation(0,156, {});"
]
Be sure that after: "preventDeviceCreation(0,156, {});" is no comma anymore.

Reboot your Pi should now fix the problem, if the elements are still not there try to Interview again, or (re)include the Smoke Sensor.

Hope it will fix your problem as well! :)

AlphaX2

Post Reply