2.2.0: CRON Error

Discussions about RaZberry - Z-Wave board for Raspberry computer
ridewithstyle
Posts: 116
Joined: 02 Jan 2016 01:20

Re: 2.2.0: CRON Error

Post by ridewithstyle »

Hey there,

Missing Cron affects me too, any news on an update/fix? Where do I send a keg of beer to to get this working? I'm currently installing a new system (including heating) and the wife already makes annoyed/annoying comments on the "What do you mean, we can't schedule heating cycles, now how is that an improvement to our local heater controls"-Problem.

Seriously, anyway I can help or contribute to fix this?

Kind Regards,

rws

islipfd19
Posts: 126
Joined: 07 Jul 2014 03:35

Re: 2.2.0: CRON Error

Post by islipfd19 »

ridewithstyle wrote:Hey there,

Missing Cron affects me too, any news on an update/fix? Where do I send a keg of beer to to get this working? I'm currently installing a new system (including heating) and the wife already makes annoyed/annoying comments on the "What do you mean, we can't schedule heating cycles, now how is that an improvement to our local heater controls"-Problem.

Seriously, anyway I can help or contribute to fix this?

Kind Regards,

rws
I'd recommend reverting back to 2.1.1 if the wife is that unhappy.

Unitone
Posts: 11
Joined: 21 Dec 2015 01:32

Re: 2.2.0: CRON Error

Post by Unitone »

islipfd19 wrote:
I'd recommend reverting back to 2.1.1 if the wife is that unhappy.
Reverting back to 2.1.1 doesn't help!

cyberhofi
Posts: 26
Joined: 31 Oct 2015 13:48

Re: 2.2.0: CRON Error

Post by cyberhofi »

it seems to work again with v2.2.1-rc3

Unitone
Posts: 11
Joined: 21 Dec 2015 01:32

Re: 2.2.0: CRON Error

Post by Unitone »

cyberhofi wrote:it seems to work again with v2.2.1-rc3
Cool! How do you install it? Please give me more details, I want to try it!

islipfd19
Posts: 126
Joined: 07 Jul 2014 03:35

Re: 2.2.0: CRON Error

Post by islipfd19 »

You can most likely update to that release by going to the standard update page in zwave. You'd have to specify the release you want to update to.

ridewithstyle
Posts: 116
Joined: 02 Jan 2016 01:20

Re: 2.2.0: CRON Error

Post by ridewithstyle »

islipfd19 wrote:I'd recommend reverting back to 2.1.1 if the wife is that unhappy.
Thanks for your reply, I think you took my commenct about my wife a little too serious :-)

I just updated to v2.2.1-rc3. Had to guess that you can simply specify the version string to get that. Once you know it, it's pretty neat. Cron ist back alive, but my schedules still didn't work. So dug a little into my razberry via ssh and took a wild guess that the system clock might be off. And as I suspected, the schedules are executed according to the system time, in my case UTC. The GUI in Z-Way mislead me, because it displays UTC+1, so I figured this is the time to use. Once I used the UTC in schedules, they worked fine.

To cut a long story short, v2.2.1-rc3 works fine, thanks for the fix.

Regards, rws

Unitone
Posts: 11
Joined: 21 Dec 2015 01:32

Re: 2.2.0: CRON Error

Post by Unitone »

islipfd19 wrote:You can most likely update to that release by going to the standard update page in zwave. You'd have to specify the release you want to update to.
Yep! that did the trick! Thanks!

islipfd19
Posts: 126
Joined: 07 Jul 2014 03:35

Re: 2.2.0: CRON Error

Post by islipfd19 »

ridewithstyle wrote:
islipfd19 wrote:I'd recommend reverting back to 2.1.1 if the wife is that unhappy.
Thanks for your reply, I think you took my commenct about my wife a little too serious :-)

I just updated to v2.2.1-rc3. Had to guess that you can simply specify the version string to get that. Once you know it, it's pretty neat. Cron ist back alive, but my schedules still didn't work. So dug a little into my razberry via ssh and took a wild guess that the system clock might be off. And as I suspected, the schedules are executed according to the system time, in my case UTC. The GUI in Z-Way mislead me, because it displays UTC+1, so I figured this is the time to use. Once I used the UTC in schedules, they worked fine.

To cut a long story short, v2.2.1-rc3 works fine, thanks for the fix.

Regards, rws
How's v2.2.1-rc3 working out for you?

ridewithstyle
Posts: 116
Joined: 02 Jan 2016 01:20

Re: 2.2.0: CRON Error

Post by ridewithstyle »

So far:
- all schedules are working fine
- daylight usermodule also works as expected
- the Fibaro Dimmer 2 now works as well. The interview still doesn't finish, but I can control the light via z-wave, that's all I need
- Love the "Stop" Button for Blind-Controls, really nice

What I still miss (generally, not specifically for 2.2.1-rc3):
- Dimming of Z-Wave ZME Remote doesn't get reported, I only get the binary switch information
- I can't set .5 Values for my devolo thermostat. The expert gui let's me set the value to e.g. 22.5, but not the standard gui.

But I digress, Cronwise everything is ok, thanks again. :-)

Regards, rws

Locked