2.2.0: Wrong Temperature Values

Discussions about RaZberry - Z-Wave board for Raspberry computer
Post Reply
cyberhofi
Posts: 26
Joined: 31 Oct 2015 13:48

2.2.0: Wrong Temperature Values

Post by cyberhofi » 04 Jan 2016 15:07

My temperature sensors began to display strange values. From time to time (in the last days nearly all the time) they displayed either 127.9 °C or -46.9 °C. I think this is the minimum and maximum for the temperature value.

Has anybody the same problem and/or a solution for this?

cyberhofi
Posts: 26
Joined: 31 Oct 2015 13:48

Re: 2.2.0: Wrong Temperature Values

Post by cyberhofi » 10 Jan 2016 17:03

Here is a Log file:

Code: Select all

[2016-01-10 13:40:57.940] [D] [zway] RECEIVED: ( 01 08 00 04 00 05 02 84 07 77 )
[2016-01-10 13:40:57.941] [D] [zway] SENT ACK
[2016-01-10 13:40:57.941] [D] [zway] SETDATA devices.5.data.lastReceived = 0 (0x00000000)
[2016-01-10 13:40:57.941] [I] [zway] Node 5:0 CC Wakeup: Wakeup notification
[2016-01-10 13:40:57.941] [D] [zway] SETDATA devices.5.instances.0.commandClasses.132.data.lastWakeup = 1452433257 (0x56925f69)
[2016-01-10 13:40:57.942] [D] [zway] SETDATA devices.5.data.isAwake = True
[2016-01-10 13:40:57.942] [D] [zway] SETDATA devices.5.data.lastSend = 185113071 (0x0b0899ef)
[2016-01-10 13:40:57.942] [D] [zway] SETDATA devices.5.data.lastNonceGet = 185112071 (0x0b089607)
[2016-01-10 13:40:57.942] [D] [zway] Running wakeup handler for node 5
[2016-01-10 13:40:57.943] [D] [zway] SETDATA devices.5.instances.0.commandClasses.132.data.lastSleep = 1452433257 (0x56925f69)
[2016-01-10 13:40:57.943] [I] [zway] Node 5:0 CC Wakeup: Send node to sleep
[2016-01-10 13:40:57.943] [I] [zway] Adding job: Wakeup Sleep
[2016-01-10 13:40:58.012] [D] [zway] SENDING (cb 0x20): ( 01 28 00 13 05 21 8F 01 06 04 31 04 01 00 04 31 04 03 00 04 31 04 05 00 04 31 04 06 00 04 31 04 09 00 04 31 04 0B 00 05 20 4E )
[2016-01-10 13:40:58.017] [D] [zway] RECEIVED ACK
[2016-01-10 13:40:58.023] [D] [zway] RECEIVED: ( 01 04 01 13 01 E8 )
[2016-01-10 13:40:58.023] [D] [zway] SENT ACK
[2016-01-10 13:40:58.024] [I] [zway] Job 0x13 (MultiCmd, SensorMultilevel V5 Get, SensorMultilevel V5 Get, SensorMultilevel V5 Get, SensorMultilevel V5 Get, SensorMultilevel V5 Get, SensorMultilevel V5 Get): Response received - transfered to encapsulated jobs
[2016-01-10 13:40:58.024] [D] [zway] Delivered to Z-Wave stack
[2016-01-10 13:40:58.024] [D] [zway] Delivered to Z-Wave stack
[2016-01-10 13:40:58.024] [D] [zway] Delivered to Z-Wave stack
[2016-01-10 13:40:58.024] [D] [zway] Delivered to Z-Wave stack
[2016-01-10 13:40:58.025] [D] [zway] Delivered to Z-Wave stack
[2016-01-10 13:40:58.025] [D] [zway] Delivered to Z-Wave stack
[2016-01-10 13:40:58.025] [D] [zway] Delivered to Z-Wave stack
[2016-01-10 13:40:58.220] [D] [zway] RECEIVED: ( 01 07 00 13 20 01 00 14 DE )
[2016-01-10 13:40:58.220] [D] [zway] SENT ACK
[2016-01-10 13:40:58.221] [I] [zway] Job 0x13 (MultiCmd, SensorMultilevel V5 Get, SensorMultilevel V5 Get, SensorMultilevel V5 Get, SensorMultilevel V5 Get, SensorMultilevel V5 Get, SensorMultilevel V5 Get): Callback received - transfered to encapsulated jobs
[2016-01-10 13:40:58.221] [I] [zway] Job 0x13 (SensorMultilevel V5 Get): Not delivered to recipient
[2016-01-10 13:40:58.221] [I] [zway] Job 0x13 (SensorMultilevel V5 Get): Not delivered to recipient
[2016-01-10 13:40:58.221] [I] [zway] Job 0x13 (SensorMultilevel V5 Get): Not delivered to recipient
[2016-01-10 13:40:58.221] [I] [zway] Job 0x13 (SensorMultilevel V5 Get): Not delivered to recipient
[2016-01-10 13:40:58.222] [I] [zway] Job 0x13 (SensorMultilevel V5 Get): Not delivered to recipient
[2016-01-10 13:40:58.222] [I] [zway] Job 0x13 (SensorMultilevel V5 Get): Not delivered to recipient
[2016-01-10 13:40:58.222] [I] [zway] Job 0x13 (MultiCmd, SensorMultilevel V5 Get, SensorMultilevel V5 Get, SensorMultilevel V5 Get, SensorMultilevel V5 Get, SensorMultilevel V5 Get, SensorMultilevel V5 Get): Not delivered to recipient
[2016-01-10 13:40:58.223] [D] [zway] SETDATA devices.5.data.lastPacketInfo.delivered = False
[2016-01-10 13:40:58.223] [D] [zway] SETDATA devices.5.data.lastPacketInfo.packetLength = 36 (0x00000024)
[2016-01-10 13:40:58.223] [D] [zway] SETDATA devices.5.data.lastPacketInfo.deliveryTime = 197 (0x000000c5)
[2016-01-10 13:40:58.224] [D] [zway] SETDATA devices.5.data.lastPacketInfo = **********
[2016-01-10 13:40:58.224] [D] [zway] SETDATA devices.5.data.isAwake = False
[2016-01-10 13:40:58.224] [D] [zway] Sending the queue for node 5 into sleep
[2016-01-10 13:40:58.224] [W] [zway] Job 0x13 (MultiCmd, SensorMultilevel V5 Get, SensorMultilevel V5 Get, SensorMultilevel V5 Get, SensorMultilevel V5 Get, SensorMultilevel V5 Get, SensorMultilevel V5 Get) dropped: too many resends
[2016-01-10 13:40:58.224] [D] [zway] Job 0x13 (MultiCmd, SensorMultilevel V5 Get, SensorMultilevel V5 Get, SensorMultilevel V5 Get, SensorMultilevel V5 Get, SensorMultilevel V5 Get, SensorMultilevel V5 Get): fail
[2016-01-10 13:40:58.224] [I] [zway] Removing job: MultiCmd, SensorMultilevel V5 Get, SensorMultilevel V5 Get, SensorMultilevel V5 Get, SensorMultilevel V5 Get, SensorMultilevel V5 Get, SensorMultilevel V5 Get
[2016-01-10 13:41:00.235] [D] [zway] RECEIVED: ( 01 30 00 04 00 05 2A 8F 01 06 06 31 05 01 22 05 07 05 31 05 03 01 52 05 31 05 05 01 58 05 31 05 06 01 0B 06 31 05 09 22 03 C1 06 31 05 0B 22 FD 96 E5 )
[2016-01-10 13:41:00.236] [D] [zway] SENT ACK
[2016-01-10 13:41:00.236] [D] [zway] SETDATA devices.5.data.lastReceived = 0 (0x00000000)
[2016-01-10 13:41:00.236] [D] [zway] SETDATA devices.5.instances.0.commandClasses.49.data.1.deviceScale = 0 (0x00000000)
[2016-01-10 13:41:00.241] [D] [zway] SETDATA devices.5.instances.0.commandClasses.49.data.1.scaleString = "°C"
[2016-01-10 13:41:00.241] [D] [zway] SETDATA devices.5.instances.0.commandClasses.49.data.1.val = 128.699997
[2016-01-10 13:41:00.243] [D] [zway] SETDATA devices.5.instances.0.commandClasses.49.data.1 = Empty
[2016-01-10 13:41:00.243] [D] [zway] SETDATA devices.5.instances.0.commandClasses.49.data.3.deviceScale = 0 (0x00000000)
[2016-01-10 13:41:00.243] [D] [zway] SETDATA devices.5.instances.0.commandClasses.49.data.3.scale = 0 (0x00000000)
[2016-01-10 13:41:00.247] [D] [zway] SETDATA devices.5.instances.0.commandClasses.49.data.3.scaleString = "%"
[2016-01-10 13:41:00.248] [D] [zway] SETDATA devices.5.instances.0.commandClasses.49.data.3.val = 82.000000
[2016-01-10 13:41:00.248] [D] [zway] SETDATA devices.5.instances.0.commandClasses.49.data.3 = Empty
[2016-01-10 13:41:00.249] [D] [zway] SETDATA devices.5.instances.0.commandClasses.49.data.5.deviceScale = 0 (0x00000000)
[2016-01-10 13:41:00.249] [D] [zway] SETDATA devices.5.instances.0.commandClasses.49.data.5.scale = 0 (0x00000000)
[2016-01-10 13:41:00.253] [D] [zway] SETDATA devices.5.instances.0.commandClasses.49.data.5.scaleString = "%"
[2016-01-10 13:41:00.253] [D] [zway] SETDATA devices.5.instances.0.commandClasses.49.data.5.val = 88.000000
[2016-01-10 13:41:00.253] [D] [zway] SETDATA devices.5.instances.0.commandClasses.49.data.5 = Empty
[2016-01-10 13:41:00.254] [D] [zway] SETDATA devices.5.instances.0.commandClasses.49.data.6.deviceScale = 0 (0x00000000)
[2016-01-10 13:41:00.254] [D] [zway] SETDATA devices.5.instances.0.commandClasses.49.data.6.scale = 0 (0x00000000)
[2016-01-10 13:41:00.258] [D] [zway] SETDATA devices.5.instances.0.commandClasses.49.data.6.scaleString = "m/s"
[2016-01-10 13:41:00.258] [D] [zway] SETDATA devices.5.instances.0.commandClasses.49.data.6.val = 11.000000
[2016-01-10 13:41:00.259] [D] [zway] SETDATA devices.5.instances.0.commandClasses.49.data.6 = Empty
[2016-01-10 13:41:00.259] [D] [zway] SETDATA devices.5.instances.0.commandClasses.49.data.9.deviceScale = 0 (0x00000000)
[2016-01-10 13:41:00.259] [D] [zway] SETDATA devices.5.instances.0.commandClasses.49.data.9.scale = 0 (0x00000000)
[2016-01-10 13:41:00.263] [D] [zway] SETDATA devices.5.instances.0.commandClasses.49.data.9.scaleString = "kPa"
[2016-01-10 13:41:00.264] [D] [zway] SETDATA devices.5.instances.0.commandClasses.49.data.9.val = 96.099998
[2016-01-10 13:41:00.264] [D] [zway] SETDATA devices.5.instances.0.commandClasses.49.data.9 = Empty
[2016-01-10 13:41:00.264] [D] [zway] SETDATA devices.5.instances.0.commandClasses.49.data.11.deviceScale = 0 (0x00000000)
[2016-01-10 13:41:00.268] [D] [zway] SETDATA devices.5.instances.0.commandClasses.49.data.11.scaleString = "°C"
[2016-01-10 13:41:00.269] [D] [zway] SETDATA devices.5.instances.0.commandClasses.49.data.11.val = -61.799999
[2016-01-10 13:41:00.269] [D] [zway] SETDATA devices.5.instances.0.commandClasses.49.data.11 = Empty
[2016-01-10 13:41:00.349] [D] [zway] RECEIVED: ( 01 30 00 04 00 05 2A 8F 01 06 06 31 05 01 22 05 07 05 31 05 03 01 52 05 31 05 05 01 58 05 31 05 06 01 0B 06 31 05 09 22 03 C1 06 31 05 0B 22 FD 96 E5 )
[2016-01-10 13:41:00.349] [D] [zway] SENT ACK
[2016-01-10 13:41:00.349] [D] [zway] SETDATA devices.5.data.lastReceived = 0 (0x00000000)
[2016-01-10 13:41:00.350] [D] [zway] SETDATA devices.5.instances.0.commandClasses.49.data.1.deviceScale = 0 (0x00000000)
[2016-01-10 13:41:00.353] [D] [zway] SETDATA devices.5.instances.0.commandClasses.49.data.1.scaleString = "°C"
[2016-01-10 13:41:00.354] [D] [zway] SETDATA devices.5.instances.0.commandClasses.49.data.1.val = 128.699997
[2016-01-10 13:41:00.354] [D] [zway] SETDATA devices.5.instances.0.commandClasses.49.data.1 = Empty
[2016-01-10 13:41:00.355] [D] [zway] SETDATA devices.5.instances.0.commandClasses.49.data.3.deviceScale = 0 (0x00000000)
[2016-01-10 13:41:00.355] [D] [zway] SETDATA devices.5.instances.0.commandClasses.49.data.3.scale = 0 (0x00000000)
[2016-01-10 13:41:00.360] [D] [zway] SETDATA devices.5.instances.0.commandClasses.49.data.3.scaleString = "%"
[2016-01-10 13:41:00.360] [D] [zway] SETDATA devices.5.instances.0.commandClasses.49.data.3.val = 82.000000
[2016-01-10 13:41:00.361] [D] [zway] SETDATA devices.5.instances.0.commandClasses.49.data.3 = Empty
[2016-01-10 13:41:00.361] [D] [zway] SETDATA devices.5.instances.0.commandClasses.49.data.5.deviceScale = 0 (0x00000000)
[2016-01-10 13:41:00.361] [D] [zway] SETDATA devices.5.instances.0.commandClasses.49.data.5.scale = 0 (0x00000000)
[2016-01-10 13:41:00.365] [D] [zway] SETDATA devices.5.instances.0.commandClasses.49.data.5.scaleString = "%"
[2016-01-10 13:41:00.366] [D] [zway] SETDATA devices.5.instances.0.commandClasses.49.data.5.val = 88.000000
[2016-01-10 13:41:00.366] [D] [zway] SETDATA devices.5.instances.0.commandClasses.49.data.5 = Empty
[2016-01-10 13:41:00.367] [D] [zway] SETDATA devices.5.instances.0.commandClasses.49.data.6.deviceScale = 0 (0x00000000)
[2016-01-10 13:41:00.367] [D] [zway] SETDATA devices.5.instances.0.commandClasses.49.data.6.scale = 0 (0x00000000)
[2016-01-10 13:41:00.371] [D] [zway] SETDATA devices.5.instances.0.commandClasses.49.data.6.scaleString = "m/s"
[2016-01-10 13:41:00.372] [D] [zway] SETDATA devices.5.instances.0.commandClasses.49.data.6.val = 11.000000
[2016-01-10 13:41:00.372] [D] [zway] SETDATA devices.5.instances.0.commandClasses.49.data.6 = Empty
[2016-01-10 13:41:00.372] [D] [zway] SETDATA devices.5.instances.0.commandClasses.49.data.9.deviceScale = 0 (0x00000000)
[2016-01-10 13:41:00.373] [D] [zway] SETDATA devices.5.instances.0.commandClasses.49.data.9.scale = 0 (0x00000000)
[2016-01-10 13:41:00.377] [D] [zway] SETDATA devices.5.instances.0.commandClasses.49.data.9.scaleString = "kPa"
[2016-01-10 13:41:00.377] [D] [zway] SETDATA devices.5.instances.0.commandClasses.49.data.9.val = 96.099998
[2016-01-10 13:41:00.377] [D] [zway] SETDATA devices.5.instances.0.commandClasses.49.data.9 = Empty
[2016-01-10 13:41:00.378] [D] [zway] SETDATA devices.5.instances.0.commandClasses.49.data.11.deviceScale = 0 (0x00000000)
[2016-01-10 13:41:00.382] [D] [zway] SETDATA devices.5.instances.0.commandClasses.49.data.11.scaleString = "°C"
[2016-01-10 13:41:00.382] [D] [zway] SETDATA devices.5.instances.0.commandClasses.49.data.11.val = -61.799999
[2016-01-10 13:41:00.382] [D] [zway] SETDATA devices.5.instances.0.commandClasses.49.data.11 = Empty
The device is a z-weather. Only the temperatures seem to be wrong. I do not think its a device error, because the Temperature Values of my Fibaro UBS are also wrong.

vvuu
Posts: 39
Joined: 30 Aug 2015 14:22

Re: 2.2.0: Wrong Temperature Values

Post by vvuu » 15 Jan 2016 19:18

and ? did you resolve a problem ?


I have 2.1 version with AEON temp. sensor... I think about upgrade system to 2.2 but.... is this problem is common for every temperature sensors or only with this ?

cyberhofi
Posts: 26
Joined: 31 Oct 2015 13:48

Re: 2.2.0: Wrong Temperature Values

Post by cyberhofi » 15 Jan 2016 22:11

I have the problem with Popp Z-Weather and With the Fibaro Universal Binary Sensor.

For the Binary Sensor it helped a bit to power off and reconnect. Now it is sending correct data in most cases (about 3 wrong temperature readings a day - it is reading temp ~every 5 minutes)

In case of the Z-weather i can not try to power off because it has a internal battery. Maybe i could try to cover te solar cell for several days. But at the moment this is not an options because we have lots of snow and the z-weather is mounted on my roof...

btw:
I do not recommend to upgrade to 2.2.0 because of problems with the CRON service (time scheduling does not work) Now i am running v2.2.1-rc3 and the CRON issue is solved. I think for you it is the best way to wait for 2.2.1

vvuu
Posts: 39
Joined: 30 Aug 2015 14:22

Re: 2.2.0: Wrong Temperature Values

Post by vvuu » 15 Jan 2016 22:43

thank You for fast respond...

I thought about change to domoticz (and compare) but when I read about awaking problem with my PIR sensors SP103 and Multisensors Aeon - I gave up ;) and I'll w8 for 2.2.1 - cause generally everything work fine :)

vilim
Posts: 1
Joined: 05 Feb 2016 09:02

Re: 2.2.0: Wrong Temperature Values

Post by vilim » 05 Feb 2016 09:08

I have the same problem with SECURE temperature sensor SES301 and Danfoss radiator thermostat (set value) :?

Post Reply