Rasberry PI 3 supported?

Discussions about RaZberry - Z-Wave board for Raspberry computer
chatchat
Posts: 2
Joined: 06 Mar 2016 13:40

Re: Rasberry PI 3 supported?

Post by chatchat » 07 Mar 2016 17:33

@rabing, where to find "raspi-config" -> 8. "Advanced Options" -> "Device Tree" ?
I'm using Jeedom...

pz1
Posts: 2053
Joined: 08 Apr 2012 13:44

Re: Rasberry PI 3 supported?

Post by pz1 » 07 Mar 2016 17:48

raspi-config is a basic command line instruction via the console of raspberrypi. Nothing to do with Zway or Jeedom

BrammiX
Posts: 1
Joined: 08 Mar 2016 00:57

Re: Rasberry PI 3 supported?

Post by BrammiX » 08 Mar 2016 01:02

chatchat wrote:@rabing, where to find "raspi-config" -> 8. "Advanced Options" -> "Device Tree" ?
I'm using Jeedom...
Thanks, this solved my problem using Domoticz

Gr33nG081
Posts: 2
Joined: 04 Mar 2016 18:06

Re: Rasberry PI 3 supported?

Post by Gr33nG081 » 09 Mar 2016 14:54

The solution by rabing is also working for me. I disabled the device tree with the raspi-config and now the RaZberry is connected. Thanks!

For me it's not a problem that te bluetooth and wifi wont work.
Last edited by Gr33nG081 on 10 Mar 2016 22:17, edited 1 time in total.

User avatar
PoltoS
Posts: 5286
Joined: 26 Jan 2011 19:36

Re: Rasberry PI 3 supported?

Post by PoltoS » 10 Mar 2016 14:13

Dear customers,

Looks like Pi 3 uses UART for Bluetooth. We will investigate this once we have the board in hands (next week).

Meanwhile have a look here:
http://www.briandorey.com/post/Raspberr ... Workaround

We think we will disable BT by default and keep WiFi. Those who will need BT will have to slow down the CPU (not sure yet if this is stable enough)

nochkin
Posts: 38
Joined: 29 Feb 2016 05:05

Re: Rasberry PI 3 supported?

Post by nochkin » 17 Mar 2016 04:23

If you are fine with Bluetooth disabled but want to have WiFi operational anyway, you can do the following (must be root or use sudo):
1. Make sure you are on the latest kernel and have the latest overlay files:

Code: Select all

rpi-update
2. Add "disable BT" overlay:

Code: Select all

echo "dtoverlay=pi3-disable-bt" >> /boot/config.txt
3. Restart the server:

Code: Select all

reboot
Last edited by nochkin on 17 Mar 2016 17:35, edited 1 time in total.

Mephix
Posts: 1
Joined: 12 Mar 2016 13:45

Re: Rasberry PI 3 supported?

Post by Mephix » 17 Mar 2016 15:40

Thanks nochkin!

I just tried your suggestion and it works perfectly fine.. both Razberry and Wifi. I don't plan to use BT for now so this is great.

ben52456j13
Posts: 8
Joined: 02 Mar 2016 11:26

Re: Rasberry PI 3 supported?

Post by ben52456j13 » 21 Mar 2016 23:18

great solution, I also work it working with bluetooth disabled. :D

User avatar
PoltoS
Posts: 5286
Joined: 26 Jan 2011 19:36

Re: Rasberry PI 3 supported?

Post by PoltoS » 26 Mar 2016 23:29

We have updated the install script to automatically disable Bluetooth during install/upgrade.

kernel-z
Posts: 2
Joined: 27 Mar 2016 14:37

Re: Rasberry PI 3 supported?

Post by kernel-z » 27 Mar 2016 14:42

Hello,

i'm having the same issue. i did the edit in config.txt.

how can i see that bluetooth is now really disabled from command line ?

also i saw that on internet and would like to apply it :

http://www.vesternet.com/resources/appl ... vfFOdDl-2k

but the file called 09-tty.rules doesn't exist why ?
ps: i plan to use the zwave module using openzwave not using the zwave install with website

Post Reply