"Something went wrong" Zipato RFID

Discussions about RaZberry - Z-Wave board for Raspberry computer
Post Reply
AlphaX2
Posts: 110
Joined: 25 Jul 2015 15:03

"Something went wrong" Zipato RFID

Post by AlphaX2 »

Hello guys,

I just updated a few days ago to 2.2.3, 2.2.4 and now 2.2.5. I don't know when or why, but my Zipato RFID app instance was lost and since that I try to get it back.

Problem:
Everytime I try to create a new Zipato RFID Keypad app instance it shows me a "something went wrong" in the moment I click save. In the event screen it gives me the following error message: "Cannot instantiate module: ZipatoMiniKeypadRFID: TypeError: Cannot read property 'status' of undefined " but it creates the widgets and it's also working and available for scenes until a reboot/restart of z-way-server. But in the "active" apps tab it do not show up. :roll:

What I tried already:
- ReIncluded the Zipato RFID Keypad
- deleted/reinstalled app
- tried different z-way-server versions from 2.2.3 - up to 2.3-rc3.
- Cleaned all the Zipato RFID related stuff from configjson
- Start/Stop z-way-server
- Rebooted Pi
- EDIT: fresh installationb (with AND without backup)

EDIT: Fresh install fixed this issue.
Another thing I can't explain is the following: Logical Rule shows the Reset button in Tab "Local Apps" after clicking it shows the update feature, but after the update it shows again the Reset button, so this can be done again and again.

EDIT: added log data

Code: Select all

[2016-11-20 13:37:25.956] [I] [core] Instantiating module 101 from class ZipatoMiniKeypadRFID
[2016-11-20 13:37:25.963] [I] [core] --- Starting module Zipato RFID Keypad
[2016-11-20 13:37:25.993] [I] [core] Creating device switchBinary MiniKeypadSecurityMode_101
[2016-11-20 13:37:26.038] [I] [core] Creating device sensorBinary MiniKeypadTamper_101
[2016-11-20 13:37:26.054] [I] [zway] Job 0x13 (Wakeup Sleep): Cancelling job: Wakeup Sleep
[2016-11-20 13:37:26.055] [I] [zway] Removing job: Wakeup Sleep
[2016-11-20 13:37:26.055] [I] [zway] Adding job: UserCode Set
[2016-11-20 13:37:26.055] [I] [zway] Adding job: UserCode Get
[2016-11-20 13:37:26.064] [I] [core] Notification: error (core): Das Modul kann nicht instanziiert werden: ZipatoMiniKeypadRFID: TypeError: Cannot read property 'status' of undefined
[2016-11-20 13:37:26.074] [I] [core] TypeError: Cannot read property 'status' of undefined
    at ZipatoMiniKeypadRFID.self.zwayReg (automation/userModules/ZipatoMiniKeypadRFID/index.js:246:37)
    at ZipatoMiniKeypadRFID.init (automation/userModules/ZipatoMiniKeypadRFID/index.js:319:18)
    at AutomationController.instantiateModule (automation/classes/AutomationController.js:424:22)
    at AutomationController.createInstance (automation/classes/AutomationController.js:856:23)
    at ZAutomationAPIWebRequest._.extend.createInstance (automation/ZAutomationAPIProvider.js:1055:40)
    at ZAutomationAPIWebRequest.ZAutomationWebRequest.handleRequest (automation/WebserverRequestRouter.js:259:41)
    at automation/WebserverRequestRouter.js:32:35
    at WebServer.document_root (automation/Webserver.js:29:11)
Some help would be nice!
Thanks in advance.

micky1500
Posts: 155
Joined: 07 Feb 2016 16:29

Re: "Something went wrong" Zipato RFID

Post by micky1500 »

As no one else has responded.
I had the same last week, but after multiple tries it eventually worked.
Last try that worked was without any tags or any other details entered, just keypad selected was "RFID Reader"

Warning though..... Make a .ZBK and .ZAB Backup first and a copy of your /opt/z-way-server folder. Something corrupts when I changed the "Daylight 104" settings.
Causes a login restart on the UI main page. and cant login anymore :(
Raspi 4(Buster), Zwave Version 3.1.1

Post Reply