Cant access Razberry IP and GUI on razbarry zway

Discussions about RaZberry - Z-Wave board for Raspberry computer
vlad
Posts: 32
Joined: 19 Oct 2016 04:58

Re: Cant access Razberry IP and GUI on razbarry zway

Post by vlad » 19 Mar 2018 16:36

Yes, the problem is still exists... Looks like they don't have devs to compile C code under the stretch properly.
Now they hosted those workaround files themselves.

Check official announcement - https://forum.z-wave.me/viewtopic.php?f=3417&t=26138

Krooms
Posts: 3
Joined: 18 Mar 2018 04:18

Re: Cant access Razberry IP and GUI on razbarry zway

Post by Krooms » 19 Mar 2018 19:13

Thx mate!

User avatar
aLiEnHeAd
Posts: 74
Joined: 02 Feb 2017 15:09

Re: Cant access Razberry IP and GUI on razbarry zway

Post by aLiEnHeAd » 09 Apr 2018 23:08

Although I did
wget -q -O - support.zwave.eu/libs | sudo bash
, it seems to use the 1.0.2:

Code: Select all

[Thread 0x71cff450 (LWP 1633) exited]
[Thread 0x700ff450 (LWP 1624) exited]
[Thread 0x6e6ff450 (LWP 1628) exited]
[Thread 0x6daff450 (LWP 1632) exited]
*** Error in `/opt/z-way-server/z-way-server': double free or corruption (fasttop): 0x701b9d90 ***

Thread 183 "zway/core" received signal SIGABRT, Aborted.
[Switching to Thread 0x70aff450 (LWP 1630)]
__GI_raise (sig=sig@entry=6) at ../sysdeps/unix/sysv/linux/raise.c:51
51      ../sysdeps/unix/sysv/linux/raise.c: No such file or directory.
(gdb) info thread
  Id   Target Id         Frame
  1    Thread 0x762dacd0 (LWP 1424) "z-way-server" 0x7638f050 in nanosleep () at ../sysdeps/unix/syscall-template.S:84
  2    Thread 0x75064450 (LWP 1428) "OptimizingCompi" 0x76985014 in futex_abstimed_wait_cancelable (private=0, abstime=0x0, expected=1, futex_word=0x6c204)
    at ../sysdeps/unix/sysv/linux/futex-internal.h:205
  3    Thread 0x74864450 (LWP 1429) "v8:SweeperThrea" 0x76985014 in futex_abstimed_wait_cancelable (private=0, abstime=0x0, expected=1, futex_word=0x6c35c)
    at ../sysdeps/unix/sysv/linux/futex-internal.h:205
  4    Thread 0x74854450 (LWP 1430) "v8:SweeperThrea" 0x76985014 in futex_abstimed_wait_cancelable (private=0, abstime=0x0, expected=1, futex_word=0x6c474)
    at ../sysdeps/unix/sysv/linux/futex-internal.h:205
  5    Thread 0x74844450 (LWP 1431) "v8:SweeperThrea" 0x76985014 in futex_abstimed_wait_cancelable (private=0, abstime=0x0, expected=1, futex_word=0x6c58c)
    at ../sysdeps/unix/sysv/linux/futex-internal.h:205
  6    Thread 0x74834450 (LWP 1432) "v8:SweeperThrea" 0x76985014 in futex_abstimed_wait_cancelable (private=0, abstime=0x0, expected=1, futex_word=0x6c6a4)
    at ../sysdeps/unix/sysv/linux/futex-internal.h:205
  7    Thread 0x74824450 (LWP 1433) "zway/core" 0x7638f050 in nanosleep () at ../sysdeps/unix/syscall-template.S:84
  8    Thread 0x73aff450 (LWP 1436) "zway/webserver" 0x763bd2a4 in select () at ../sysdeps/unix/syscall-template.S:84
  9    Thread 0x732ff450 (LWP 1437) "zway/timers" 0x7638f050 in nanosleep () at ../sysdeps/unix/syscall-template.S:84
  10   Thread 0x726ff450 (LWP 1438) "zway/core" 0x763bd2a4 in select () at ../sysdeps/unix/syscall-template.S:84
  179  Thread 0x6f6ff450 (LWP 1626) "zway/core" __GI__dl_debug_state () at dl-debug.c:74
* 183  Thread 0x70aff450 (LWP 1630) "zway/core" __GI_raise (sig=sig@entry=6) at ../sysdeps/unix/sysv/linux/raise.c:51
(gdb) bt
#0  __GI_raise (sig=sig@entry=6) at ../sysdeps/unix/sysv/linux/raise.c:51
#1  0x7631f824 in __GI_abort () at abort.c:89
#2  0x76358f78 in __libc_message (do_abort=do_abort@entry=2, fmt=<optimized out>) at ../sysdeps/posix/libc_fatal.c:175
#3  0x7635fad4 in malloc_printerr (action=<optimized out>, str=0x76412120 "double free or corruption (fasttop)", ptr=<optimized out>, ar_ptr=<optimized out>)
    at malloc.c:5049
#4  0x76360514 in _int_free (av=0x71300010, p=0x701b9d88, have_lock=<optimized out>) at malloc.c:3905
#5  0x75fcc2a0 in CRYPTO_free () from /usr/lib/arm-linux-gnueabihf/libcrypto.so.1.0.2
#6  0x76039730 in lh_free () from /usr/lib/arm-linux-gnueabihf/libcrypto.so.1.0.2
#7  0x7603bfb8 in ?? () from /usr/lib/arm-linux-gnueabihf/libcrypto.so.1.0.2
Backtrace stopped: previous frame identical to this frame (corrupt stack?)

Krooms
Posts: 3
Joined: 18 Mar 2018 04:18

Re: Cant access Razberry IP and GUI on razbarry zway

Post by Krooms » 09 Apr 2018 23:29

I don't know if it's using the 1.0.2 version, but I set up a fresh installation a week ago and everything works fine after I installed the lib-package.
Without it wasn't working very well.

Post Reply