Page 1 of 1

Australian Razberry V2 arrived set to EU frequency, can't change

Posted: 15 Dec 2017 16:53
by ben52456j13
I purchased a Razberry V2 card from a local supplier in Australia.

The card arrived set to the EU frequency and I can't set it to AU in the expert interface.
13.PNG (21.5 KiB) Viewed 3911 times
I tried restoring my Z-Wave network backup from my Razberry V1 card which didn't change it either, I've updated the cards firmware and Z-Way to the latest versions "05.23" firmware on the card.

What do I need to do to get this card working on the correct (AU) frequency?

Below is a copy paste from "Show Controller Data"

Code: Select all

/: None (23:33)
    nodeId: 1 (23:42)
    homeId: -978803414 (23:42)
    SUCNodeId: 1 (23:42)
    isPrimary: true (23:42)
    isInOthersNetwork: false (23:42)
    isRealPrimary: true (23:42)
    isSUC: true (23:42)
    SISPresent: true (23:42)
    libType: Static Controller (23:42)
    SDK: 6.71.01 (23:42)
    ZWlibMajor: 4 (23:42)
    ZWlibMinor: 61 (23:42)
    ZWLib: 1 (23:42)
    ZWVersion: 6 (23:42)
    ZWaveChip: ZW0500 (23:42)
    APIVersion: 05.23 (23:33)
    manufacturerId: 327 (23:33)
    vendor: RaZberry by Z-Wave.Me (23:33)
    manufacturerProductType: 1024 (23:33)
    manufacturerProductId: 2 (23:33)
    bootloaderCRC: 35498 (23:42)
    firmwareCRC: 275 (23:42)
    capabilities: 2,3,4,5,6,7,8,9,10,11,16,17,18,19,20,21,22,23,28,32,33,34,35,36,39,40,41,42,43,44,45,46,55,56,57,58,59,63,65,66,68,69,70,71,72,73,74,75,76,77,79,80,81,83,84,85,86,87,88,94,95,96,97,98,99,102,103,120,128,144,146,147,152,180,182,183,184,185,186,189,190,191,208,209,210,211,212,238,239,242,244,245 (23:33)
    controllerState: 0 (23:42)
    nonManagmentJobs: 0 (23:33)
    lastIncludedDevice: None (23:42)
    lastExcludedDevice: None (23:42)
    secureInclusion: true (23:33)
    oldSerialAPIAckTimeout10ms: 10 (23:42)
    oldSerialAPIByteTimeout10ms: 10 (23:42)
    curSerialAPIAckTimeout10ms: 10 (23:42)
    curSerialAPIByteTimeout10ms: 10 (23:42)
    countJobs: false (23:33)
    memoryGetAddress: 25856 (23:42)
    memoryGetData: 138,170,1,19 (23:42)
    memoryManufacturerId: None (23:33)
    memoryType: None (23:33)
    memoryCapacity: None (23:33)
    functionClasses: 2,3,4,5,6,7,8,11,18,19,21,22,23,32,33,34,35,36,39,41,42,43,44,45,57,58,59,63,65,66,68,70,71,72,73,74,75,76,77,80,81,82,83,84,85,86,87,94,96,97,98,99,128,146,147,186,190,208,209,210,211,242,243,244,245 (23:33)
    functionClassesNames: SerialAPIGetInitData,SerialAPIApplicationNodeInformation,ApplicationCommandHandler,GetControllerCapabilities,SerialAPISetTimeouts,GetSerialAPICapabilities,SerialAPISoftReset,SerialAPISetup,SendNodeInformation,SendData,GetVersion,SendDataAbort,RFPowerLevelSet,GetHomeId,MemoryGetByte,MemoryPutByte,MemoryGetBuffer,MemoryPutBuffer,FlashAutoProgSet,NVMGetId,NVMExtReadLongBuffer,NVMExtWriteLongBuffer,NVMExtReadLongByte,NVMExtWriteLongByte,ClearNetworkStats,GetNetworkStats,GetBackgroundRSSI,RemoveNodeIdFromNetwork,GetNodeProtocolInformation,SetDefault,ReplicationReceiveComplete,AssignReturnRoute,DeleteReturnRoute,RequestNodeNeighbourUpdate,ApplicationNodeUpdate,AddNodeToNetwork,RemoveNodeFromNetwork,CreateNewPrimary,ControllerChange,SetLearnMode,AssignSUCReturnRoute,EnableSUC,RequestNetworkUpdate,SetSUCNodeId,DeleteSUCReturnRoute,GetSUCNodeId,SendSUCNodeId,ExploreRequestInclusion,RequestNodeInformation,RemoveFailedNode,IsFailedNode,ReplaceFailedNode,GetRoutingTableLine,GetPriorityRoute,SetPriorityRoute,RFPowerLevelGet,SendTestFrame,SetPromiscuousMode,PromiscuousCommandHandler,WatchDogStart,WatchDogStop,ZMEFreqChange,ZMERestore,ZMEBootloaderFlash,ZMECapabilities (23:33)
    softwareRevisionVersion: v2.3.6 (23:33)
    softwareRevisionId: a25d58db56fe93180d0e891dcc11d62d87ec8c2c (23:33)
    softwareRevisionDate: 2017-10-04 15:13:33 +0300 (23:33)
    uuid: b555a9187765e8e4b8aff7140720798d (23:42)
    caps: 0,0,255,5 (23:42)
    capsNonce: 0,0,0,0 (23:42)
    countDown: 0 (23:42)
    frequency: EU (23:42)
    deviceRelaxDelay: 3 (23:33)
    statistics: None (23:33)
        backgroundRSSI: None (23:33)
            channel1: 125 (23:57)
            channel2: 125 (23:57)
            channel3: 127 (23:57)
        RFTxFrames: 97 (23:53)
        RFTxLBTBackOffs: 0 (23:53)
        RFRxFrames: 0 (23:53)
        RFRxLRCErrors: 0 (23:53)
        RFRxCRC16Errors: 0 (23:53)
        RFRxForeignHomeID: 0 (23:53)
        priorityRoute: None (23:33)
            dstNodeId: None (23:33)
            routeType: None (23:33)
            speed: None (23:33)
            hops: None (23:33)
    homeName: (24.10.2017)
    homeNotes: (24.10.2017)

Re: Australian Razberry V2 arrived set to EU frequency, can't change

Posted: 15 Dec 2017 17:41
by ben52456j13

1) Login: http://ZWAYIP:8083
2) Enable debug mode: http://ZWAYIP:8083/expert/#/network/controller
3) Go to this URL: http://ZWAYIP:8083/JS/Run/zway.ZMEFreqChange(4)

You should see "null" response, then check Expert UI and it should look like this:
14.PNG (21.48 KiB) Viewed 3908 times
Then disable the debug mode.

Can confirm the card is working on ANZ frequency now, would have been nice not to have to waste 3 hours figuring this out on my own.

Also can report that I was able to successfully restore a backup of my V1 Gen 5 Razberry card to the V2 and its working perfectly in Domoticz. :D

It was important for me to restore a Domoticz database backup from before the Z-Way Z-Wave network backup was taken to get a working system with all my existing devices working without issues.

Re: Australian Razberry V2 arrived set to EU frequency, can't change

Posted: 29 Dec 2017 20:19
by ben52456j13
I have just observed a Razberry Gen 5 V1 card which was purchased in Australia and set to AU frequency change to the EU frequency upon upgrade to firmware version 5.22. Thought I'd post in case anyone else has the same problem, I was able to change it back to AU using the info from my above posts.

Re: Australian Razberry V2 arrived set to EU frequency, can't change

Posted: 29 Dec 2017 22:17
by PoltoS
Indeed, the fw update changes to EU. This will be solved in next update

Re: Australian Razberry V2 arrived set to EU frequency, can't change

Posted: 05 Jan 2018 04:17
by ben52456j13
This is ridiculous, I just setup a UZB1 which was out of the box AU, updated the firmware and now its locked to EU and the above trick doesn't change it back to AU.

How can I set my UZB1 back to its original frequency?

Re: Australian Razberry V2 arrived set to EU frequency, can't change

Posted: 05 Jan 2018 04:23
by ben52456j13
Had to reboot the UZB1 and the above trick worked thankfully.

Dev's really should have already fixed this.

Re: Australian Razberry V2 arrived set to EU frequency, can't change

Posted: 05 Jan 2018 07:53
by PoltoS
They did, but there are still products across the world that are older. Once all upgrade the issue will go away