Errors after clean installation (Timezone, database update and send mail support)

Discussions about RaZberry - Z-Wave board for Raspberry computer
Xusqui
Posts: 7
Joined: 11 Mar 2019 15:19

Errors after clean installation (Timezone, database update and send mail support)

Post by Xusqui »

Hi, neighbours and friends...

Re-installed this morning from scratch, clean raspbian installation, and then z-way-server installation.

After that I can't:
1.- Updadate vendors and devices' database. I get an error: "Update vendors database failed.". Nevetherless, I can add z-wave devices.
2.- Cannot change time zone, not in the basic UI nor in the advanced one.
3.- I've tried to send an email support from the expert UI and get another error: "Unable to send report·
Thanks in advance

User avatar
PoltoS
Posts: 5820
Joined: 26 Jan 2011 19:36

Re: Errors after clean installation (Timezone, database update and send mail support)

Post by PoltoS »

Are you in Stretch? Which version of Z-Way?

Krooms
Posts: 22
Joined: 18 Mar 2018 04:18

Re: Errors after clean installation (Timezone, database update and send mail support)

Post by Krooms »

Have a similar problem after clean install.

Installed newest raspbian buster (February 2020) and Z-Way 3.0.4

Changing timezone (doesn't matter if in normal or expert mode) has no effect. Normal GUI shows the correct timezone, expert mode always timezone "London".

Opening the "firmware update" tab shows only "could not connect to raspberry-ip:8084" error.

Updating device database works.

Did some reboot and power off/on, no effect.

Edit: Updating apps doesn't work, also. "E-mail ME", "Logical Rule" and "OpenRemote Helper" are shown as "update available". Updating shows the error "SMARTHOME UI ERROR - Failed to update the app".

User avatar
PoltoS
Posts: 5820
Joined: 26 Jan 2011 19:36

Re: Errors after clean installation (Timezone, database update and send mail support)

Post by PoltoS »

There are few issues with v3.0.4. We are preparing v3.0.5

Krooms
Posts: 22
Joined: 18 Mar 2018 04:18

Re: Errors after clean installation (Timezone, database update and send mail support)

Post by Krooms »

Is 3.0.5 likely to be released in the near future?

In addition to my last post: Heating automation doesn't work. Set some time schedules for all thermostats and for all days, but nothing happens. Tried to set the automation off and on again with no success.

The problem with the time zone seems to be just a display problem. Time shown in the top main frame is wrong, but the time displayed at the "last updated" status of thermostats or switches is correct.

User avatar
PoltoS
Posts: 5820
Joined: 26 Jan 2011 19:36

Re: Errors after clean installation (Timezone, database update and send mail support)

Post by PoltoS »

We are now hunting for few annoying issues. Almost done with them - next is polishing JS issues including some of those you listed.

Krooms
Posts: 22
Joined: 18 Mar 2018 04:18

Re: Errors after clean installation (Timezone, database update and send mail support)

Post by Krooms »

Anything new about 3.0.5?

User avatar
PoltoS
Posts: 5820
Joined: 26 Jan 2011 19:36

Re: Errors after clean installation (Timezone, database update and send mail support)

Post by PoltoS »

Preparing it. Many many small fixes that require testing

Krooms
Posts: 22
Joined: 18 Mar 2018 04:18

Re: Errors after clean installation (Timezone, database update and send mail support)

Post by Krooms »

Anything we can help with?
Thx to corona, I have some extra free time... :D

User avatar
PoltoS
Posts: 5820
Joined: 26 Jan 2011 19:36

Re: Errors after clean installation (Timezone, database update and send mail support)

Post by PoltoS »

We have just released v3.0.5. Not in the repo yet, but you can already test it from https://storage.z-wave.me/z-way-server/ ... _armhf.deb

Quite a lot of bug fixes. See the Change Log https://storage.z-wave.me/z-way-server/ChangeLog

Post Reply