Errors after clean installation (Timezone, database update and send mail support)

Discussions about RaZberry - Z-Wave board for Raspberry computer
Krooms
Posts: 22
Joined: 18 Mar 2018 04:18

Re: Errors after clean installation (Timezone, database update and send mail support)

Post by Krooms »

Wow!
Thx for your great work!
Gonna test it tomorrow morning! :)

User avatar
aLiEnHeAd
Posts: 84
Joined: 02 Feb 2017 15:09

Re: Errors after clean installation (Timezone, database update and send mail support)

Post by aLiEnHeAd »

PoltoS wrote:
04 Apr 2020 03:03
We have just released v3.0.5. Not in the repo yet, but you can already test it from https://storage.z-wave.me/z-way-server/ ... _armhf.deb

Quite a lot of bug fixes. See the Change Log https://storage.z-wave.me/z-way-server/ChangeLog
That's great news!
I'll try it as soon as possible :-)
Do you recommend upgrading my raZberry firmware from 5.32 to 5.36 as well?

Krooms
Posts: 22
Joined: 18 Mar 2018 04:18

Re: Errors after clean installation (Timezone, database update and send mail support)

Post by Krooms »

Need some help with updating via SSH.

What command do I use for updating?

Edit: Here is the right command.

Code: Select all

cd /tmp && wget https://storage.z-wave.me/z-way-server/z-way-3.0.5_armhf.deb && sudo dpkg -i z-way-3.0.5_armhf.deb

Krooms
Posts: 22
Joined: 18 Mar 2018 04:18

Re: Errors after clean installation (Timezone, database update and send mail support)

Post by Krooms »

3.0.5 did solve some of my problems (updating apps work for example) but some problems still exist (changing time zone has no effect, heatcontrol doesn’t work).

Gonna try a clean install tomorrow.

User avatar
PoltoS
Posts: 5687
Joined: 26 Jan 2011 19:36

Re: Errors after clean installation (Timezone, database update and send mail support)

Post by PoltoS »

We will address heating app in the next release. Together with push notifications

Krooms
Posts: 22
Joined: 18 Mar 2018 04:18

Re: Errors after clean installation (Timezone, database update and send mail support)

Post by Krooms »

Could fix the time zone problem, by changing the time zone of the raspberry itself (in terminal: "sudo raspi-config").

Everything else seems to be working fine.

Again, thx for you work! :)

CorC
Posts: 7
Joined: 10 Aug 2017 10:34

Re: Errors after clean installation (Timezone, database update and send mail support)

Post by CorC »

I've upgraded to 3.0.5, could it be it was compiled with some debug options enabled still?

As it seems to run really slow, and shows the following output:
screenshot
screenshot
Screenshot 2020-04-08 at 16.49.08.png (148.95 KiB) Viewed 1011 times
Or do I have a configuration parameter set I shouldnt' have?


rafale77
Posts: 106
Joined: 23 Jun 2018 19:26

Re: Errors after clean installation (Timezone, database update and send mail support)

Post by rafale77 »

Will a non debug version of it be released?
on the ubuntu version I am also seeing this output a couple of days after the installation:

Apr 10 18:18:22 ubuntu z-way-server[4822]: SSL DEBUG LOCK: 19 > 1
Apr 10 18:18:22 ubuntu z-way-server[4822]: SSL DEBUG LOCK: 19 > 0
Apr 10 18:18:22 ubuntu z-way-server[4822]: SSL DEBUG LOCK: 18 > 0
Apr 10 18:18:22 ubuntu z-way-server[4822]: SSL DEBUG LOCK: 18 > 1
Apr 10 18:18:22 ubuntu z-way-server[4822]: SSL DEBUG LOCK: 18 > 0
Apr 10 18:18:22 ubuntu z-way-server[4822]: SSL DEBUG LOCK: 18 > 1
Apr 10 18:18:22 ubuntu z-way-server[4822]: SSL DEBUG LOCK: 19 > 1
Apr 10 18:18:22 ubuntu z-way-server[4822]: SSL DEBUG LOCK: 19 > 0

User avatar
PoltoS
Posts: 5687
Joined: 26 Jan 2011 19:36

Re: Errors after clean installation (Timezone, database update and send mail support)

Post by PoltoS »

This debug log is only on RPi. On Ubuntu it is not present. Those you see are from your openssl library

Post Reply