buster image can't get wi-fi to work

Discussions about RaZberry - Z-Wave board for Raspberry computer
Post Reply
doubledrat
Posts: 13
Joined: 25 Nov 2018 13:57

buster image can't get wi-fi to work

Post by doubledrat »

Hi

I'm using the z-wave buster image and I can't get wifi to work. I've tried two different cards and multiple configurations.

the same hardware with vanilla buster (light) works first time.

any idea what you've done to the image to prevent wifi working?

one of the adapters I've tried is an edimax. not sure what the other one is.

If I ping the pi while it's booting, it comes on the network briefly (3-4 pings) then falls off the network again.

ideas?

thanks

aivs
Posts: 44
Joined: 04 Mar 2011 15:26

Re: buster image can't get wi-fi to work

Post by aivs »

Hi!
Try different usb cable and power adapter.
I think the problem with power, I've seen the like.

doubledrat
Posts: 13
Joined: 25 Nov 2018 13:57

Re: buster image can't get wi-fi to work

Post by doubledrat »

thanks for the suggestion, but as I said, the same hardware with a clean buster image works fine. it's only with the one provided by zwave that doesn't work, so it can't be the power.

doubledrat
Posts: 13
Joined: 25 Nov 2018 13:57

Re: buster image can't get wi-fi to work

Post by doubledrat »

no ideas?

I'm having to use it wired at the moment which is not at all convenient...

aivs
Posts: 44
Joined: 04 Mar 2011 15:26

Re: buster image can't get wi-fi to work

Post by aivs »

What is the RPi model?

aivs
Posts: 44
Joined: 04 Mar 2011 15:26

Re: buster image can't get wi-fi to work

Post by aivs »

Today I tested with RPi 3B+, wi-fi works

doubledrat
Posts: 13
Joined: 25 Nov 2018 13:57

Re: buster image can't get wi-fi to work

Post by doubledrat »

for some reason I didn't get notified of your reply. It's -

Code: Select all

processor       : 0
model name      : ARMv6-compatible processor rev 7 (v6l)
BogoMIPS        : 697.95
Features        : half thumb fastmult vfp edsp java tls
CPU implementer : 0x41
CPU architecture: 7
CPU variant     : 0x0
CPU part        : 0xb76
CPU revision    : 7

Hardware        : BCM2835
Revision        : 000e
Model           : Raspberry Pi Model B Rev 2

larekm
Posts: 10
Joined: 04 Jan 2016 17:36

Re: buster image can't get wi-fi to work

Post by larekm »

Hi!

I had this problem due to the image I downloaded from zwave.me site had accesspoint installed. So the wifi-circuit was occupied all the time :-)· You can check this easily by downloading a wifi analysator to your app-phone.

To solve this I wrote
sudo apt-get remove hostapd

and to enter ssid and password I used
sudo raspi-config

/Lars

Post Reply