Page 1 of 2

Cannot start Z-Wave binding: Error: Binding with name 'zway' already exists

Posted: 17 Jan 2020 12:43
by Clubber2000
After having some problems with my 3.0.3 zway system on my raspberry (for example zway server not reachable after security alarm) I decided to restore my system from a 3.0.2 sd card image. After that I made the update zu 3.0.3 again. Still the problems, so I decided to use the restore funktion (see screenshot) with the option "Are you sure you want to overwrite your current configuration? Have you created a backup?" checked.

Maybe this was an error.

Now I have the problem that after starting z-way no items (sensors, sirens and so on) are visible and I found the message: "Cannot start Z-Wave binding: Error: Binding with name 'zway' already exists".

I there any chance to heal this without a factory reset?
Unbenannt.JPG
Unbenannt.JPG (64.87 KiB) Viewed 3928 times

Re: Cannot start Z-Wave binding: Error: Binding with name 'zway' already exists

Posted: 18 Jan 2020 11:49
by PoltoS
Sure your backup was made after adding devices?

Re: Cannot start Z-Wave binding: Error: Binding with name 'zway' already exists

Posted: 18 Jan 2020 13:30
by Clubber2000
Sorry, maybe I dont understand your question.

Means you question that the connected items differ between the backup and the connected items which are connected in the moment I played back the backup?

Yes, that could be. The backup is from November 2019 and after that I changed one or two connected Items (deinclusion and inclusion) because I had some problems with them.

Is this a problem with the backup? Could this result in this error message?

Re: Cannot start Z-Wave binding: Error: Binding with name 'zway' already exists

Posted: 19 Jan 2020 13:11
by PoltoS
You should probably stop Z-Wave Binding app before doing a restore, but this is strange. Please try to stop all apps and do restore

Re: Cannot start Z-Wave binding: Error: Binding with name 'zway' already exists

Posted: 19 Jan 2020 17:23
by Clubber2000
Thanks for you response.

What do mean exactly with "Z-Wave Binding app"? If you mean the openhab binding app. I deleted it a long time ago and I also deintalled the openhab2 software from my raspberry.

Okay, I try to stop all running apps. Do you stop them by clicking on the Pause symbol in the UI?

Until now I never understood the difference between the 2 different backups: the .zba file and the .zbk file.

Which kind of backup do you recommend?

Re: Cannot start Z-Wave binding: Error: Binding with name 'zway' already exists

Posted: 20 Jan 2020 10:59
by PoltoS
zab includes zbk.

Re: Cannot start Z-Wave binding: Error: Binding with name 'zway' already exists

Posted: 20 Jan 2020 23:28
by Clubber2000
I paused all the running apps by clicking the Pause symbol than I played back the zab file. After that the error message still occurs.

So you have any other ideas? Is purpose of the "Z-wave binding app" to connect the z way server to openhab?

Re: Cannot start Z-Wave binding: Error: Binding with name 'zway' already exists

Posted: 23 Jan 2020 10:30
by Clubber2000
Has this problem something to do with an old binding I made some time ago? I made some experencies with installing openhab2 on the the same raspberry, installed the openhab connector app in zwave.
But after I while I deintalled both.
Now I have the problem thats my z way Server stopped every two oder three days and after rebooting the error message "Cannot start Z-Wave binding: Error: Binding with name 'zway' already exists" is in the logs. Also the UI is empty. No itmes.
I have to restart the raspberry one or two times and the itmes come back.

Are there some places in the actual installation where I can delete the rest of the openhab experience? Deleting the openhab software seems not to be enough? Which modul or apps still tries to start the z-wave binding?

Re: Cannot start Z-Wave binding: Error: Binding with name 'zway' already exists

Posted: 24 Jan 2020 20:35
by PoltoS
This means something is disturbing Z-Way from speaking with the shield.

After restore make sure that the port is correct. When you migrate between UZB and RaZ or vice versa you should change the port

Re: Cannot start Z-Wave binding: Error: Binding with name 'zway' already exists

Posted: 25 Jan 2020 00:20
by Clubber2000
My port is:

/dev/ttyACM0

I am using the uzb stick for many years without changing.

What do you mean with "shield"?