Failed to install the app

Discussions about RaZberry - Z-Wave board for Raspberry computer
User avatar
PoltoS
Posts: 5867
Joined: 26 Jan 2011 19:36

Re: Failed to install the app

Post by PoltoS »

When restoring backups you should explicitelly install all your apps, skins and icons

robert
Posts: 16
Joined: 06 Jul 2013 00:42

Re: Failed to install the app

Post by robert »

Hi,

Succesfully upgraded to v3.0.4-33-gfb22f31.
However, the message "The request failed because server does not responding. Looks like you've slow or lost internet connection. Try to reconnect and refresh the page." still appears at the top.

I found a thread saying certificates might not be installed, but ca-certificates package is installed and at the latest version.

Using ps -ax, I found that 306 is used for z-way-server.
Started strace, then opened the Online Apps page.
Searching for file in the log file shows:

Code: Select all

750   stat64("automation/modules/IntChart", 0x726fdcf8) = -1 ENOENT (No such file or directory)
750   stat64("automation/modules/NetworkPresence", 0x726fdcf8) = -1 ENOENT (No such file or directory)
750   openat(AT_FDCWD, "automation/modules/SensorsPollingLogging/lang/en.json", O_RDONLY) = -1 ENOENT (No such file or directory)
750   openat(AT_FDCWD, "automation/modules/SensorsPollingLogging/lang/en.json", O_RDONLY) = -1 ENOENT (No such file or directory)
Searching for etc shows:

Code: Select all

750   read(13, "cat /etc/z-way/box_type\nreboot\ns"..., 4096) = 233
2039  access("/etc/ld.so.preload", R_OK <unfinished ...>
2039  openat(AT_FDCWD, "/etc/ld.so.preload", O_RDONLY|O_LARGEFILE|O_CLOEXEC <unfinished ...>
2039  openat(AT_FDCWD, "/etc/ld.so.cache", O_RDONLY|O_LARGEFILE|O_CLOEXEC <unfinished ...>
2039  getcwd( <unfinished ...>
2039  <... getcwd resumed> "/opt/z-way-server", 4096) = 18
2040  access("/etc/ld.so.preload", R_OK <unfinished ...>
2040  openat(AT_FDCWD, "/etc/ld.so.preload", O_RDONLY|O_LARGEFILE|O_CLOEXEC <unfinished ...>
2040  openat(AT_FDCWD, "/etc/ld.so.cache", O_RDONLY|O_LARGEFILE|O_CLOEXEC <unfinished ...>
2041  execve("/bin/cat", ["cat", "/etc/timezone"], 0x18da42c /* 6 vars */ <unfinished ...>
2041  access("/etc/ld.so.preload", R_OK <unfinished ...>
2041  openat(AT_FDCWD, "/etc/ld.so.preload", O_RDONLY|O_LARGEFILE|O_CLOEXEC <unfinished ...>
2041  openat(AT_FDCWD, "/etc/ld.so.cache", O_RDONLY|O_LARGEFILE|O_CLOEXEC <unfinished ...>
2041  openat(AT_FDCWD, "/etc/timezone", O_RDONLY|O_LARGEFILE <unfinished ...>
750   stat64("/etc/localtime", {st_mode=S_IFREG|0644, st_size=2949, ...}) = 0
Is something wrong?
Something else that can be verified?

Kind regards,
Robert

User avatar
PoltoS
Posts: 5867
Joined: 26 Jan 2011 19:36

Re: Failed to install the app

Post by PoltoS »

Do you run it as root with strace?

robert
Posts: 16
Joined: 06 Jul 2013 00:42

Re: Failed to install the app

Post by robert »

Ran it as follows:

Code: Select all

sudo strace -f -p 306 -o /home/pi/zway_trace.txt

User avatar
PoltoS
Posts: 5867
Joined: 26 Jan 2011 19:36

Re: Failed to install the app

Post by PoltoS »

Sorry, I'm lost. Can you explain in more details your issue?

robert
Posts: 16
Joined: 06 Jul 2013 00:42

Re: Failed to install the app

Post by robert »

When I go to Apps, this message appears at the top:
"The request failed because server does not responding. Looks like you've slow or lost internet connection. Try to reconnect and refresh the page."

When I then click on Online Apps, the same message appears and the rest of the page is empty.

Somewhere in the past, I installed online apps. No idea what version that was. I think somewhere in 2.x.

User avatar
PoltoS
Posts: 5867
Joined: 26 Jan 2011 19:36

Re: Failed to install the app

Post by PoltoS »

Please show browser console and network log so we can look which request failed

HeHa
Posts: 12
Joined: 30 Dec 2016 22:46

Re: Failed to install the app

Post by HeHa »

Hi,
PoltoS wrote:
31 Jan 2020 11:37
You can install a fix from the terminal using:
cd /tmp && wget https://storage.z-wave.me/z-way-server/ ... _armhf.deb && sudo dpkg -i z-way-3.0.4-33-gfb22f31_armhf.deb
Thank you - I ran into trouble after updating from 3.0.1 to 3.0.4, luckily I found this post. :D


/HeHa

robert
Posts: 16
Joined: 06 Jul 2013 00:42

Re: Failed to install the app

Post by robert »

Aah, you meant the console of the browser - I was looking somewhere on the site :)
Anyway, this message was presented:

Code: Select all

Cross-Origin Request Blocked: The Same Origin Policy disallows reading the remote resource at https://developer.z-wave.me/?uri=api-modules. (Reason: CORS request did not succeed).
This triggered me that the site is trying to access a resource from the client (and not from the server) and after allowing it to contact the outside world all is working fine!

Thanks PoltoS!

Dan
Posts: 24
Joined: 01 May 2019 11:39

Re: Failed to install the app

Post by Dan »

PoltoS wrote:
31 Jan 2020 11:37
There is a bug in 3.0.4 with SSL and HTTPS.
You can install a fix from the terminal using:
cd /tmp && wget https://storage.z-wave.me/z-way-server/ ... _armhf.deb && sudo dpkg -i z-way-3.0.4-33-gfb22f31_armhf.deb
This will be part of the next release. Apologize for the inconvenience
Here is the full command. That hepled, thx!

Code: Select all

cd /tmp && wget https://storage.z-wave.me/z-way-server/z-way-3.0.4-33-gfb22f31_armhf.deb && sudo dpkg -i z-way-3.0.4-33-gfb22f31_armhf.deb

Post Reply