Firmware upgrade from 5.0 to latest advised?

Discussions about RaZberry - Z-Wave board for Raspberry computer
Post Reply
THB
Posts: 6
Joined: 08 Oct 2017 10:44

Firmware upgrade from 5.0 to latest advised?

Post by THB »

Hi,

I noticed that my RaZberry never got a firmware upgrade. Is it advised to do so?
I read a lot about bricking when doing a firmware upgrade. I am a bit worried about the note further down to ask support.

The Firmware Update page shows :

The firmware of your Z-Wave transceiver is upgradable using this interface. You should only perform an upgrade if asked by support. Its possible that certain firmware upgrade require to upgrade the bootloader part of the firmware first.

2015-01-01 5.0 Update bootloader from default for 5.00 to 538d Upgrade bootloader
2015-09-15 5.0 5.4 Update firmware from 5.00 to 5.04 Upgrade firmware
2015-09-18 5.0 5.3 Update firmware from 5.00 to 5.03

First, I would need to upgrade the bootloader, then I would need to go through several steps, 5,04, ... 5.38, correct?

User avatar
PoltoS
Posts: 5534
Joined: 26 Jan 2011 19:36

Re: Firmware upgrade from 5.0 to latest advised?

Post by PoltoS »

if you gave 5.00, you can ugrade without fear of bricking it.

THB
Posts: 6
Joined: 08 Oct 2017 10:44

Re: Firmware upgrade from 5.0 to latest advised?

Post by THB »

Great, many thanks, as always!

At first, I got a heart attack because nothing was working. The reason: I forgot to shutdown the RasPI completely and make it powerless for some seconds. But after I did that and restarted the machine the controller info now says:

Library Type: Static Controller
SDK Version: 6.81.01
Serial API Version: 05.36

Many thanks also for your Webinars - they are very, very helpful.

Post Reply